webdevqa.jp.net

フレームワーク 'Microsoft.AspNetCore.App'、バージョン '3.1.3'が見つかりませんでした

別の開発マシンでWebアプリのtargetFrameworkをdotnet-core-2.2からdotnet-core-3.1.2にアップグレードすると、次のエラーが発生します

It was not possible to find any compatible framework version
The framework 'Microsoft.AspNetCore.App', version '3.1.3' was not found.
  - No frameworks were found.

You can resolve the problem by installing the specified framework and/or SDK.

The specified framework can be found at:
  - https://aka.ms/dotnet-core-applaunch?framework=Microsoft.AspNetCore.App&framework_version=3.1.3&Arch=x64&rid=win10-x64

私たちは問題を解決するためにいくつかのアプローチを試みました

  • エラーのある指定されたリンクからdotnetコアをダウンロードしてインストールしました
  • リンクからランタイムをダウンロード https://dotnet.Microsoft.com/download/dotnet-core/3.1
  • 3.1.2または3.1.3以外の他のdotnetコアフレームワークバージョンをアンインストールしました

それでも同じ問題が発生しています。この問題のトラブルシューティングを行ってください。

2
Prakash

3.1.101をターゲットにしていますが、これと同じエラーが発生しました。

3.1.2共有フレームワークをアンインストールすることでこの問題を解決しました(知らない誰かがインストールしました)

要点は、必要なバージョンのみを使用することです。そうしないと、.NETが混乱するようです。

0
ben_mj

実行dotnet --version in cmdを実行し、正しいバージョン(3.1.201)がインストールされているかどうかを確認します。 .NET Core Runtimeバージョン、sdkバージョンではありません。アプリケーションが最新バージョンになりました。

sDK 3.1.201-ランタイム3.1.3

0
Lasanga Guruge