webdevqa.jp.net

':app @ debug / compileClasspath'の依存関係を解決できません:com.google.Android.gms:play-services-basement:[15.0.0,16.0.0)を解決できませんでした

このエラーが発生しています:ここに私のbuild.gradle(Module:app)があります

_apply plugin: 'com.Android.application'
apply plugin: 'io.fabric'

Android {
    compileSdkVersion 26
    defaultConfig {
        applicationId "com.mycompany.myapp"
        minSdkVersion 19
        targetSdkVersion 26
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "Android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.pro'
        }
    }
    dataBinding.enabled = true
}

dependencies {
    implementation fileTree(include: ['*.jar'], dir: 'libs')
    implementation 'com.Android.support:appcompat-v7:26.1.0'
    implementation 'com.google.firebase:firebase-core:15.0.0'
    compileOnly "org.projectlombok:lombok:1.16.20"
    annotationProcessor 'org.projectlombok:lombok:1.16.20'
    implementation 'com.Android.support.constraint:constraint-layout:1.1.0'
    implementation 'com.google.code.gson:gson:2.8.1'
    implementation 'com.Android.volley:volley:1.1.0'
    implementation 'com.Android.support:design:26.1.0'
    implementation 'com.Android.support:support-v4:26.1.0'
    implementation 'com.google.Android.gms:play-services-maps:15.0.0'
    implementation 'com.google.Android.gms:play-services-location:15.0.0'
    implementation 'com.google.Android.gms:play-services-places:15.0.0'
    implementation 'com.paytm.pgsdk:pgsdk:1.0.8'
    testImplementation 'junit:junit:4.12'
    androidTestImplementation 'com.Android.support.test:runner:1.0.1'
    androidTestImplementation 'com.Android.support.test.espresso:espresso-core:3.0.1'
    compile 'com.crashlytics.sdk.Android:crashlytics:2.9.1'
}

apply plugin: 'com.google.gms.google-services'
_

ここに私のbuild.gradle(プロジェクト:myApp)があります

_buildscript {

    repositories {
        google()
        jcenter()
        maven {
            url 'https://maven.fabric.io/public'
        }
    }
    dependencies {
        classpath 'com.Android.tools.build:gradle:3.0.1'
        classpath 'io.fabric.tools:gradle:1.25.1'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
        classpath 'com.google.gms:google-services:3.1.0'
    }
}

allprojects {
    repositories {
        google()
        jcenter()
        maven {
            url 'https://maven.google.com/'
        }
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}
_

私は他のソリューションをチェックしましたが、それらのほとんどは追加することを提案します

_maven { url "https://maven.google.com" }_

プロジェクトのbuild.gradleへ。私はすでにこれを試しましたが、まだ同じエラーが発生しています。

Android studio3.0。mavenの代わりにgoogle()を追加しようとしました(別の提案)

9
Anirudh Bagri

File -> Other Settings -> Default Settings -> Build, Execution, Deployment -> Build Tools -> Gradle ->に移動します

Offline workオプションのチェックを外します。

7
Alireza Noorali

インターネット接続にVPNを使用していました。 VPNを閉じたところ、うまくいきました。

4
Vrushabh Suchak

オプション1:

解決するには以下の指示に従ってください

プロジェクトレベルのbuild.gradle

使用

_maven { url "https://www.jitpack.io" }
_

代わりに

_maven { url "https://jitpack.io" }
_

オプション2:

プロジェクトレベルのbuild.gradle

google()リポジトリは最優先事項でなければなりません

_allprojects {
    repositories {
        google()
        mavenLocal()
        jcenter()
    }
}
_

オプション3:

以下の手順に従って解決してください。

ステップ1:

プロジェクトレベルのbuild.gradle

_// Top-level build file where you can add configuration options common to all sub-projects/modules.
buildscript {
    repositories {
        google()
        jcenter()
    }
    dependencies {
        classpath 'com.google.gms:google-services:4.2.0' // google-services plugin
        classpath 'com.Android.tools.build:gradle:3.4.2'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        maven { url "http://dl.bintray.com/populov/maven" }
        maven { url "https://jitpack.io" } // For Ucrop
        maven { url "https://maven.google.com" } // Google's Maven repository - FCM
        maven {
            url 'https://dl.bintray.com/azeesoft/maven'
        }
        google()
        jcenter()
        mavenCentral()
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}
_

ステップ2:

アプリレベルのbuild.gradle

One Signalバージョンを更新しました。

使用

_implementation 'com.onesignal:OneSignal:3.11.1'
_

代わりに

_implementation 'com.onesignal:OneSignal:3.10.9' 
_
3
Vishrut Mavani

OneSignalを使用してAndroidアプリケーションでプッシュ通知を処理するときに同じ問題が発生しました。

解決策は、exclude句をその依存関係に追加することです。

implementation ('com.onesignal:OneSignal:3.8.3'){
    exclude group: 'com.google.Android.gms'
}

アプリフォルダーに、次のような他の不足している依存関係を手動で追加します。

implementation 'com.google.Android.gms:play-services-appinvite:16.1.0'

問題は、OneSignal SDKには、アプリで使用した最新バージョンのgmsおよびfiresbaseと同じバージョンではないGoogle Play Service依存関係が含まれていることです。

そのため、プロジェクトでgoogle playサービスを使用する追加した依存関係を把握し、exclude句を使用することをお勧めします。システムがインターネットに接続されている場合、Gradleを構築する必要があります。

これが役に立てば幸いです。

2
Opeyemi

VPNを使用して問題を解決しました。

2
Hamed Jaliliani

プロジェクトbuild.gradleで次のように宣言している場合

maven { url "https://jitpack.io" }

に変更してみてください

maven { url "https://www.jitpack.io" }
2
rahul desai