webdevqa.jp.net

「Gradleバージョン1.10が必要です。現在のバージョンは1.12です。」というエラーが表示されます。 「gradleラッパー」を実行するとき?

Androidプロジェクトに対してgradle wrapperを実行しようとしていますが、次のエラーが発生します:

ルートプロジェクト「myapp」の評価で問題が発生しました。

> Gradleバージョン1.10が必要です。現在のバージョンは1.12です。 Gradleラッパーを使用している場合は、/ Users/dude/myapp/gradle/wrapper /gradle-wrapper.propertiesのdistributionUrlをgradle-1.10-all.Zipに編集してみてください。

build.gradlewrapperタスクは次のようになります。

task wrapper(type: Wrapper) {
    gradleVersion = "1.12"
}

最近、Homebrew経由でGradlev1.12にアップデートしました。サポートされていませんか?もしそうなら、どこでこの種のことを確認できますか?

12

特定のバージョンのGradle Androidプラグインには特定のバージョンのGradleが必要です(少なくとも今のところ)。お使いのバージョンのGradle Androidプラグインのようです。 Gradle 1.10が必要です。これについての詳細は、Gradle Androidプラグインのドキュメントをご覧ください。

PS:上記のラッパータスクは、(生成された)gradlewスクリプトを使用してGradleを実行するために必要なファイルを作成します。これは、Gradleを実行するための推奨される方法です(手動インストールは不要です。すべてのビルドでgradle-wrapper.properties必要なGradleバージョン)。

8

Android gradleプラグインのバージョンはGradleのバージョンと互換性がある必要があります。バージョン互換性マッピングテーブルをここで確認してください: http://tools.Android.com/tech-docs/new-build-system/version-compatibility

enter image description here

2
lucas

私も同じ問題を抱えていました。古いAndroid Studioは、アプリケーションフォルダーの1レベル上にgradle関連ファイルを作成したことが判明しました。私の場合、パスは〜/ git /にあり、プロジェクトは〜/ git /にありました。 myproject。今はAndroid Studio RC2を使用しましたが、プロジェクト内の構成をどのように変更しても、gradleは古い1.10バージョンを使用したいと考えていました。したがって、プロジェクトを再チェックアウトしました。新しいパス、およびプロジェクト内のgradleバージョン参照を更新してから、コンパイルしました。

1
skyred