webdevqa.jp.net

すべてのgms / firebaseライブラリは、まったく同じバージョンを使用する必要があります。バージョン15.1.0、15.0.2、15.0.1、15.0.0が見つかりました。

プロジェクトにFirebaseを実装しようとしています。

Gradleファイル:

apply plugin: 'com.Android.application'

Android {
compileSdkVersion 27
defaultConfig {
    applicationId "com.ghaleh.myapplication"
    minSdkVersion 16
    targetSdkVersion 27
    versionCode 1
    versionName "1.0"
    testInstrumentationRunner "Android.support.test.runner.AndroidJUnitRunner"
     }


buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
implementation fileTree(dir: 'libs', include: ['*.jar'])
implementation 'com.Android.support:appcompat-v7:27.1.1'
implementation 'com.Android.support:support-media-compat:27.1.1'
implementation 'com.Android.support:support-v4:27.1.1'
testImplementation 'junit:junit:4.12'
androidTestImplementation 'com.Android.support.test:runner:1.0.2'
androidTestImplementation 'com.Android.support.test.espresso:espresso-  core:3.0.2'
implementation 'com.google.firebase:firebase-messaging:15.0.2'
}
apply plugin: 'com.google.gms.google-services'

そして、私はこのエラーを受け取っています:

All gms/firebase libraries must use the exact same version specification (mixing versions can lead to runtime crashes). Found versions 15.1.0, 15.0.2, 15.0.1, 15.0.0. Examples include com.google.firebase:firebase-iid:15.1.0 and com.google.Android.gms:play-services-measurement-base:15.0.2

GoogleのMavenリポジトリ 最新バージョンfirebase-messagingは15.0.2であり、firebase-iid:15.1.0だから私はfirebase-messagingをより高いバージョンにするか、firebase-iid:15.1.0はバージョンを一致させます。

ここで推奨されている他のソリューションをすでに試しました: 12 、、しかしそれらのどれもが有用ではありませんでした。

私もこれを試しました(ただし、適切な解決策ではないようです):

implementation ('com.google.firebase:firebase-messaging:15.0.2') {
    exclude group: "com.google.Android.gms"
}

私はこのエラーを受け取ります:

Error:Execution failed for task ':app:transformDexArchiveWithExternalLibsDexMergerForBazaarDebug'.
Java.lang.RuntimeException: com.Android.builder.dexing.DexArchiveMergerException: Unable to merge dex

前もって感謝します。

14
Amir

使用するには、google-serviceプラグインを更新する必要があります。

classpath 'com.google.gms:google-services:3.3.0'

これらのエラーを回避するには、Android studio 3.1

Android Studio 3.1を使用してアプリを開発していない場合は、IDE内で正しいバージョンチェック動作を得るためにアップグレードする必要があります。

詳細と従う手順:

新しいSDKバージョン管理の発表

コンパイルの完了に失敗しました:プログラムタイプは既に存在します:com.google.Android.gms.internal.measurement.zzabn

20
Peter Haddad

更新が必要になる場合があります

1.Playservice library
2.build tools
3.gradle wrapper
4.AndroidStudio
5.Migration to androidX
6.build tool version

このようなことをした後、最終的に適切なビルドになりました!!!

0
Pravin Yadav