webdevqa.jp.net

アイテムの親の取得中にエラーが発生しました:指定された名前に一致するリソースが見つかりません: 'Android:TextAppearance.Material.Widget.Button.Borderless.Colored'

私はアンドロイドスタジオで新しいプロジェクトを始めたとき私はこれらのエラーを受け取りました。

エラー:(1)アイテムの親の取得中にエラーが発生しました:指定された名前 'Android:TextAppearance.Material.Widget.Button.Borderless.Colored'に一致するリソースが見つかりませんでした。

エラー:(1)アイテムの親の取得中にエラーが発生しました:指定された名前 'Android:TextAppearance.Material.Widget.Button.Borderless.Colored'に一致するリソースが見つかりませんでした。

エラー:タスク ':app:processDebugResources'の実行に失敗しました。 com.Android.ide.common.process.ProcessException:org.gradle.process.internal.ExecException:「コマンド」の処理C:\ Program Files(x86)\ Android\android-sdk\build-tools\23.0.2\aapt .exe ''が0以外の終了値1で終了しました

Androidプロジェクト内のファイルにエラーが含まれているのは以下の通りです。

 <?xml version="1.0" encoding="utf-8"?>
 <resources>
  <style name="Base.TextAppearance.AppCompat.Widget.Button.Borderless.Colored" parent="Android:TextAppearance.Material.Widget.Button.Borderless.Colored"/>
  <style name="Base.TextAppearance.AppCompat.Widget.Button.Colored" parent="Android:TextAppearance.Material.Widget.Button.Colored"/>
  <style name="TextAppearance.AppCompat.Notification.Info.Media"/>
  <style name="TextAppearance.AppCompat.Notification.Media"/>
  <style name="TextAppearance.AppCompat.Notification.Time.Media"/>
  <style name="TextAppearance.AppCompat.Notification.Title.Media"/>
 </resources>

build.gradle:

apply plugin: 'com.Android.application'
Android {
compileSdkVersion 23
buildToolsVersion "23.0.2"

defaultConfig {
    applicationId "com.example.anmol.checkboxapp"
    minSdkVersion 15
    targetSdkVersion 23
    versionCode 1
    versionName "1.0"
}
buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.pro'
    }
}
}
dependencies {
compile fileTree(dir: 'libs', include: ['*.jar'])
compile 'com.Android.support:appcompat-v7:25.1.0'
}

誰もがこの問題の解決策を持っているのであれば助けてください

66
Anmol Nijhawan

コンパイルSDKのバージョンはサポートライブラリと一致する必要があります。以下のようにoneとします。

1. Build.gradleの変更点

compile 'com.Android.support:appcompat-v7:23.0.1'

2.または変更:

compileSdkVersion 23
buildToolsVersion "23.0.2"

compileSdkVersion 25
buildToolsVersion "25.0.2"

あなたが使っているようにcompile 'com.Android.support:appcompat-v7:25.3.1'

それは最新のSDKを使用しているように私は第二の方法を使用することをお勧めします - だからあなたは最新のSDKの新機能を利用することができることができます。

ビルドツールを使用したbuild.gradleの最新の例27.0.2 - ソース

apply plugin: 'com.Android.application'

Android {
    compileSdkVersion 27
    buildToolsVersion "27.0.2"
    defaultConfig {
        applicationId "your_applicationID"
        minSdkVersion 15
        targetSdkVersion 27
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "Android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    androidTestCompile('com.Android.support.test.espresso:espresso-core:2.2.2', {
        exclude group: 'com.Android.support', module: 'support-annotations'
    })
    compile 'com.Android.support:appcompat-v7:27.0.2'
    compile 'com.Android.support:design:27.0.2'
    testCompile 'junit:junit:4.12'
}

あなたがのようなバージョンを更新中に問題に直面した場合:

enter image description here

Google Mavenリポジトリ を使用して簡単にアップグレードするには、この 回答 を参照してください。

編集

facebookアカウントキットを使用している場合

使用しないでください:compile 'com.facebook.Android:account-kit-sdk:4.+'

代わりに以下のような特定のバージョンを使用してください。

compile 'com.facebook.Android:account-kit-sdk:4.12.0'

sDK 23とアカウントキットの最新バージョンに問題がある

編集

Facebook Android Sdk の場合

次の代わりにあなたのbuild.gradle

compile 'com.facebook.Android:facebook-Android-sdk: 4.+'

特定のバージョンを使う:

compile 'com.facebook.Android:facebook-Android-sdk:4.18.0'

android SDKバージョン23のFacebook SDKの最新バージョンに問題があります。

115
rafsanahmad007

この問題は最近のリリースでの問題です。この問題を解決するpull requestは https://github.com/facebook/react-native-fbsdk/pull/339 にあります。

7
Rod Nolan

私はそれを見つけた、私はFacebookのSDKを使用している私のアプリをコンパイルしようとしていました。私はそれを今日開こうとしたとき私は同じエラーを得た。その行を「comp.facebook.Android:facebook-Android-sdk:4.+」にコンパイルしてみました。 https://developers.facebook.com/docs/Android/change-log-4x このページと私はこのアプリを正常に実行していたと私は "コンパイル" com.facebookにその行を変更したときに私はSDKバージョンを見つけたandroid:facebook-Android-sdk:4.14.1 ''そしてそれはうまくいった。

6
Mami

私の場合はcompile sdk 23build tools 25.0.0を使っていましたが、compile sdkを25に変更して完了です。

6
Nilesh Deokar

上記のフォーラムで見つかった理想的な答えはこれです。

sed -i 's/facebook-Android-sdk:4.+/facebook-Android-sdk:4.22.1/g' ./node_modules/react-native-fbsdk/Android/build.gradle

この作品

2

私のための解決策(Android Studio):

1)ショートカットを使う Ctrl+Shift+Alt+S またはファイル - >プロジェクト構造

2)とSDKのレベルを上げる "コンパイルSDKのバージョン"。

0
Anonimys