webdevqa.jp.net

エラー:com.Android.tools.aapt2.Aapt2Exception:AAPT2エラー:詳細はログを確認

これは私のGradleコンソールの出力です、私は自分のプロジェクトを構築することができません

D:\Android Projects\....\app\src\main\res\layout\topic_view_header.xml
Error:error: resource attr/?? (aka -packagename- :attr/??) not found.
Error:error: resource attr/?? (aka -packagename-:attr/??) not found.
Error:error: resource attr/?? (aka -packagename-:attr/??) not found.
Error:resource attr/?? (aka -packagename-:attr/??) not found.
Error:resource attr/?? (aka -packagename-:attr/??) not found.
Error:resource attr/?? (aka -packagename-:attr/??) not found.
Error:failed linking file resources.
Error:Java.util.concurrent.ExecutionException: 
Java.util.concurrent.ExecutionException: 
com.Android.tools.aapt2.Aapt2Exception: AAPT2 error: check logs for details
Error:Java.util.concurrent.ExecutionException: 
com.Android.tools.aapt2.Aapt2Exception: AAPT2 error: check logs for details
Error:com.Android.tools.aapt2.Aapt2Exception: AAPT2 error: check logs for 
details
Error:Execution failed for task ':app:processDebugResources'.
> Failed to execute aapt
Information:BUILD FAILED in 27s
Information:11 errors
Information:0 warnings

Android Studio 3.0 RC 2

120
Farhan Ali

アップデート2(この方法に従う)

あなたは今これをするべきではありません。代わりにすべてのエラーを修正してください。これが削除されるまでの回避策です。その後は、とにかく手動でエラーを修正する必要があります。

Gradleプラグインを3.3.0-alpha06に更新して問題が解決するかどうかを確認してください。

更新1:

非ASCII文字の問題はAAPT2とAndroid gradleプラグインで修正されました(yay!)。 AAPT2を無効にする代わりに、Androidグラドルプラグインバージョン3.2.0-alpha11以降を使用することができます。もうこのエラーは発生しません。 

元の回答

グレード3のAndroidプラグインを使用している場合、Aapt2はデフォルトで有効になっています。 

これは

増分リソース処理を改善する

述べたように ここ

あなたがそれに問題に直面しているのであれば、あなたはgradle.propertiesにこれを追加することで前のバージョンに切り替えることができます

Android.enableAapt2=false
104
Yashasvi

_ update _

これらの問題を修正したGradleとAndroid-gradle-pluginの新しいバージョンが利用可能です。

build.gradle (トップレベル)

buildscript {
    dependencies {
        classpath 'com.Android.tools.build:gradle:3.2.1'
    }
}

gradle-wrapper.properties

distributionUrl=https\://services.gradle.org/distributions/gradle-4.8-all.Zip

前回の回答

あなたがAAPT2を無効にするならば、あなたはただ本当の問題を隠しています。

AAPT1は将来削除される可能性があるため、AAPT2を使用する必要があることに注意してください。実際に migration guide がこのように多くの変更を同時に見ていないので従うのは難しいことではありません将来の証拠です。

Androidマニフェストの要素階層

AAPTの以前のバージョンでは、Androidマニフェストの内の誤ったノードにネストされている要素は無視されるか、または警告が表示されます。 の例として、次の例を考えます。

<manifest xmlns:Android="http://schemas.Android.com/apk/res/Android"
   package="com.example.myname.myapplication">
   <application
       ...
       <activity Android:name=".MainActivity">
           <intent-filter>
               <action Android:name="Android.intent.action.MAIN" />
               <category Android:name="Android.intent.category.LAUNCHER" />
           </intent-filter>
           <action Android:name="Android.intent.action.CUSTOM" />
       </activity>
   </application>
</manifest>

したがって、以下に示すように、正しいマニフェスト構造に本当に従っているかどうかを最初に確認する必要があります。

マニフェストファイル構造

以下のコードスニペットは、マニフェストファイルとそれが含むことができるすべての要素の一般的な構造を示しています。各要素は、そのすべての属性とともに、個別のファイルに完全に文書化されています。 

<manifest>

    <uses-permission />
    <permission />
    <permission-tree />
    <permission-group />
    <instrumentation />
    <uses-sdk />
    <uses-configuration />  
    <uses-feature />  
    <supports-screens />  
    <compatible-screens />  
    <supports-gl-texture />  

    <application>

        <activity>
            <intent-filter>
                <action />
                <category />
                <data />
            </intent-filter>
            <meta-data />
        </activity>

        <activity-alias>
            <intent-filter> . . . </intent-filter>
            <meta-data />
        </activity-alias>

        <service>
            <intent-filter> . . . </intent-filter>
            <meta-data/>
        </service>

        <receiver>
            <intent-filter> . . . </intent-filter>
            <meta-data />
        </receiver>

        <provider>
            <grant-uri-permission />
            <meta-data />
            <path-permission />
        </provider>

        <uses-library />

    </application>

</manifest>
95
Enzokie

XMLレイアウトにエラーがありました。だからあなたのxmlレイアウトにエラーがないかチェックする。

17

Android Studioのgradle consoleタブをチェックします(デフォルトでは右下隅にあります)。私の場合、このようなエラーがありました:

C:\Users\Jozef Bar??k\.gradle\caches\transforms-1\files-1.1\appcompat-v7-25.4.0.aar\d68bb9d2059935a7891196f4dfb81686\res\drawable-hdpi-v4\abc_ic_menu_share_mtrl_alpha.png: error: file not found.

Error: Java.util.concurrent.ExecutionException: com.Android.tools.aapt2.Aapt2Exception: AAPT2 error: check logs for details
:app:mergeDebugResources FAILED

私は白人または特殊文字なしで別の場所に問題設定gradleユーザー家を解決しました: 

C:\Android\.gradle

Gradle設定ダイアログで " サービスディレクトリパス "を設定して設定することができます。私の場合は、以前の場所にある古い.gradleディレクトリを削除してAndroid Studioを再起動する必要がありました。

13
Jozef

私の問題は.9.pngで終わる画像ファイル名が原因でした。エンディングを.pngに変更したところ、問題は解消されました。 Gradleコンソールのスタックトレースからヒントを得ました。一番上のメッセージは「タスクの実行に失敗しました:app:mergeDebugResources」、一番下のメッセージは「com.Android.builder .png」です。 _.AaptProcess $ NotifierProcessOutput.out "

Gradleがもっと役に立つエラーメッセージを出力する日を楽しみにしています...

8
Samil

ここでも同じ問題があります。 @ Izabela Orlowskaが指摘したように、この問題はおそらくパス内の特殊文字(AndroidのGrandleファイル、リソースなど)によって引き起こされます。

私のために:フォルダ名にříを含めることはすべての問題を引き起こしました。パスに特殊文字が含まれていないことを確認してください。 AAPT2を無効にすることは一時的な「解決策」にすぎません。 あなたのプロジェクトパスには、非ASCII文字が含まれていますAndroid studio

7
Jiří

データバインドを使用してレイアウトタグを宣言しようとしたときに、この問題が発生しました。 私はそれが少し遅れていることを知っています、しかしこの問題に遭遇する誰かのために、 私がデータバインドを使用していないときあなたのルートレイアウトでそれを言ったこの 

  <Android.support.constraint.ConstraintLayout xmlns:Android="http://schemas.Android.com/apk/res/Android"
        xmlns:app="http://schemas.Android.com/apk/res-auto"
        xmlns:tools="http://schemas.Android.com/tools"
        Android:layout_width="match_parent"
        Android:layout_height="match_parent"
        tools:context=".MainActivity">     </Android.support.constraint.ConstraintLayout>

を削除 

xmlns:Android="http://schemas.Android.com/apk/res/Android"
        xmlns:app="http://schemas.Android.com/apk/res-auto"
        xmlns:tools="http://schemas.Android.com/tools"

そしてそれをあなたのレイアウトタグの上に置くだけです( それはあなたがデータバインディングを使っているなら

<layout xmlns:Android="http://schemas.Android.com/apk/res/Android"
    xmlns:app="http://schemas.Android.com/apk/res-auto"
    xmlns:tools="http://schemas.Android.com/tools">

</layout>

そしてうまくいけばそれはうまくいくでしょう。 Android.enableAapt2=falseはうまくいきませんでしたので、すべてを削除して、レイアウトタグを配置してデータバインディングを使用するとエラーが発生する理由を見つけなければなりません。そのため、解決策を見つけました。それが役に立てば幸い

6
CodeAndWave

将来のある時点でAAPT(1)のサポートは廃止予定になるので、あなたが報告したエラーの理由を特定するのは良いでしょう。 
\ app\src\main\res\layout\topic_view_header.xmlファイルの内容を教えてください?疑問符から、ASCII以外の文字を使用している可能性があります。と。もしそれが本当に非ASCII文字なら、 https://issuetracker.google.com/68262818 のバグに従ってください。

更新:この問題はAndroid gradle pluginバージョン3.2.0-alpha11以降で修正されています。

5

私は3つのステップでエラーを修正しました 
1。私は問題をチェックしました 
2。正しい文字列/テキストを指定した、それが原因でした 
3。私はプロジェクトをきれいにしました、あなたはそれをBUILDの下に見つけるでしょう。 
My project

5
Bukunmi

重要なアップデート

他の答えとしてこの行をプロジェクトに追加しないでください。なぜならそれは すでに解決された in より新しいGradle versionsです。

プロジェクトレベルのbuild.gradleで、ビルドグレードのバージョンを最新に更新できます。 

buildscript {
    dependencies {
        // choose latest if available
        classpath 'com.Android.tools.build:gradle:3.3.0-alpha06'
    }
}

および gradle-wrapper.properties

// choose latest if available
distributionUrl=https\://services.gradle.org/distributions/gradle-4.9-all.Zip

それで全部です!同期と実行、ビンゴ!

詳細情報 Androidドキュメント

追加すると、警告Android.enableAapt2=falseが表示されます。

警告:オプション 'Android.enableAapt2'は推奨されていないため、これ以上使用しないでください。この警告を削除するには、 'Android.enableAapt2 = true'を使用してください。 2018年末に削除されます。

2
Khemraj

私もこのエラーに遭遇しました。私にとっては、ターゲットSDKを26から25に変更したときでした。appcompatの依存関係のバージョンを 

implementation 'com.Android.support:appcompat-v7:26.1.0'

に 

implementation 'com.Android.support:appcompat-v7:25.4.0'

これにより、コンパイラーは現在見つけることができないスタイル属性にアクセスできます。 Enzokieが示唆したようにこれは実際の問題を隠すのではなく実際に問題を解決するでしょう。

2
hlbaker

私は同じエラーAAPT2エラーを得た:詳細についてはログをチェックし、私は最も一般的な解決策として、上記の解決策を適用し、私はgradle.propertiesを開いて行を追加しました 

Android.enableAapt2 = false

解決策のため、しかし、私はエラーを受け取りました。 'command' D:\ Android\sdk\Sdk\build-tools\27.0.3\aapt.exe 'の処理は0以外の終了値で終了しました1

しかし、多くの検索の結果、私はレイアウトのxmlファイルに問題があることを発見しました。

xmlns:Android="http://schemas.Android.com/apk/res/Android"
xmlns:app="http://schemas.Android.com/apk/res-auto"

Xmlファイルから繰り返し行を削除し、プロジェクトを再構築して[完了]をクリックします。

2
hetuka kodekar

私は全く同じ問題を抱えていました:Android Studio 3.1.2にアップデートした後、私のプロジェクトはstyles.xmlによって参照される私のドロアブルのいくつかを言っているAAPT2エラーでコンパイルしないでしょう。 AAPT2を無効にすることはもう解決策ではありません、なぜなら設定は廃止され、2018年の終わりに削除されるでしょうから。

犯人は全く無関係のlayout.xmlファイルのxml宣言の直前の空行でした...それでlayout.xmlファイルは次のように始まりました:

//empty line//
<?xml version="1.0" encoding="utf-8"?>

空の行を削除し、すべてが再び魅力のように働いた。信じられないほどありそうもない、しかし真実。

ファイルがxml宣言で始まっていないため(空の行のため)、Android Studioは実際に警告を出しました。ただし、警告はファイルがエディタで開かれているときにのみ表示されます。

2
Andy

.ideaフォルダーを削除して、再試行してください。オープンネットワークを使用していることを確認してください。

2
sudhanshu

私の場合、私は間違ったカラーコード#CC00000を使用していました。これは7桁ですが、カラーコードは3桁、6桁、または8桁と#プレフィックスが必要です。

2
Suraj Vaishnav

私はこれがあなたのためにまだ答えられたかどうか私には分からないが私には許してくれるかどうか私には分からない。私の問題はXMLのフォントファミリーの誤りが原因でした。

1
Beast77

私の場合、本当の問題は私のプロジェクトのランチャーミップマップアイコンを生成するためにImage Assetを生成した後に、生成されたファイル ic_launcher_foreground.xml にエラーがあるということです。ファイルの終わりに閉じるxmlタグがありませんでした。 </ vector> がありませんでした。

1
user3098756

@ Izabela Orlowskaが指摘したように:私の場合、問題はgradleキャッシュフォルダ内に見つからなかったいくつかのファイルが原因で発生しました。 (Windows OS)

デフォルトのGradleパスは、私のユーザーフォルダの中にありました。道はウムラウトとスペースを含んでいた。 環境変数GRADLE_HOMEおよびGRADLE_USER_HOMEを、ウムラウトやパスにスペースを入れずに新しく作成したフォルダーに設定することによって、gradleフォルダーを移動しました。 これで問題は解決しました。

1
Robin J

他の人が示唆しているように、

Android.enableAapt2=false

最も一般的な解決策です。

しかし、私の場合、エラーは compileSdkVersion buildToolsVersion のバージョンの違いによるものです。

メジャーバージョンが同じに維持されていることを確認してください。

1
VickyAbishek

私は間違った方法でコーディネーターのレイアウト属性を使用していました、それを削除して動作しました。レイアウトを確認する

app:layout_constraintVertical_bias="parent"

それはリテラルではない数値でなければなりません:/小さな間違い

  • ほとんどの場合、これはレイアウトファイルのばかげた間違いが原因で発生します。
  • 私の場合、別のプロジェクトからテキストビューをコピーしましたが、backgroundColorリソースは現在のプロジェクトで利用できませんでした
  • 実行時にエラーを表示していなかったが、コンパイル時に上記のエラーが発生すること。
  • プロセスに従うと、xmlの正確なエラーの場所を見つけることができます。

Android St​​udioの右側にある[Gradle]タブをクリックします->下の画像に示すようにプロジェクトビルドディレクトリを開きます-> assembleDebugを実行します

-エラーは次の画像のように表示されます

enter image description here

1
tejraj

リソース例外は、リソースにエラーがあること、すべてのリソースフォルダファイルが破損していること、描画可能フォルダ内のすべての画像を開いてこれらが正常に開かれているかどうかを確認することを意味します。

破損したリソースPNGをチェックするための良いコマンドがあります。

f -name "*.png" | xargs -L 1 -I{} file  -I {} | grep -v 'image/png; charset=binary$'
1
garry

このAndroid.enableAapt2 = falseを使用しないでください。これは解決策ではありません。 [ビルド出力]ボックスに表示されているエラーを正確に見つけ、[ビューの切り替え]をクリックして正確なエラーまたは例外の使用を確認 

 compileSdkVersion 28
 buildToolsVersion "28.0.3" 

gradel-wrapperでこれを使ってください。

 distributionUrl=https\://services.gradle.org/distributions/gradle-4.10.1-all.Zip

そして指示に従って外部ライブラリや依存関係を削除または更新します

リソース関連のエラー のように見えます。私はそこから始めます。

私はこれを( "エラー:com.Android.tools.aapt2.Aapt2Exception:AAPT2エラー:詳細についてはログを確認してください")初めて得た。サイズを変更すると解決しました。または別の時にリソースへのリンクを修復しました。 

1
Rares Serban

私は非常によく似た問題を抱えていました。 gradleのキャッシュ(Linuxでは〜/ .gradle/caches)を削除することで解決しました。これによりAndroid Studioはすべてを再ダウンロードしてすべてを再生成する必要がありました。

1
happylego91

私の場合、それはconstraint-layoutパッケージへの参照を追加することで修正されました

    implementation 'com.Android.support.constraint:constraint-layout:1.1.0'
1
Jim Factor

新しいXMLファイルのどれかに問題があるかどうかを確認してください。ただし、問題がある正しいXMLファイルにエラーは表示されません。

私の場合は、同じXMLファイルに2つのヘッダーを追加しました。 

そんな感じ: 

1

私もこの問題に直面しています。 「AAPT2エラー:詳細を確認するログ」スタジオバージョン3.1.2では、初めてアプリをビルドしたとき。

私は 'com.Android.support:appcompat-v7:26.1.0'を使用していました、そして私がエラーログを見るときいくつかのスタイルが見つかりませんでした。だから私の作業中のプロジェクトから 'com.Android.support:appcompat-v7:25.3.1'に変更して問題を解決しました。 

それを試してみてください。

それでも問題が解決しない場合は、正確なバージョンの代わりにv7:26以降を試してください。これで間違いなく問題は解決します。 

1
sudhanshu

私はまた、このような問題を抱えていた、オリジナルは私のコンピュータのシステムトレイこのパスです:

C:\ Users\'特殊文字が表示されます' \。Androidは中国語で表示されます、

そして今、パスを次のように変更しました。

C:\ Users\hjc \。アンドロイド。 

その理由は特殊文字の問題です。これは砂利のappt2Exception問題につながるこの理由のためです

1
George Williams

プロジェクトを閉じてAndroid Studioを再起動すると、この問題は解決しました。

再起動中に、Android Studioは不足しているSDKをダウンロードする必要があると通知したため、問題が解決したら問題は解決しました。

1
user8231406

プロジェクト名が非常に長いときにこのエラーが発生し、プロジェクトを保存していた場所が追加されました。ファイル名がシステムの制限を超えないようにプロジェクトを別の場所に移動すると、エラーが解決しました。 

C:\Users\<UserName>\AndroidStudioProjects\From Github\AdvancedAndroid_Emojify-TLIB.02-Exercise-DetectFaces\AdvancedAndroid_Emojify-TLIB.02-Exercise-DetectFaces\app\build\intermediates\incremental\mergeDebugResources\merged.dir\values\values.xml
Error:error: file not found.
Error:Java.util.concurrent.ExecutionException: com.Android.tools.aapt2.Aapt2Exception: AAPT2 error: check logs for details
Error:Execution failed for task ':app:mergeDebugResources'.
Error: Java.util.concurrent.ExecutionException: com.Android.tools.aapt2.Aapt2Exception: AAPT2 error: check logs for details
1
Tanusha Kamat

プロジェクト内で次のことを確認してください。

  • ファイルの開始時にXMLファイルに空白スペースがないことを確認してください。

  • ドロー可能ファイルに大文字や特殊記号などの問題がないことを確認してください。

  • Aapt2.exeが継続的に欠落している場合は、フルPCをスキャンしてください、adb.expまたはaapt2.exeを削除しているウイルスがある可能性があります

あなたが解決策を得ることを願っています。 

1
Pratik Butani

このエラーが出ました 

com.Android.tools.aapt2.Aapt2Exception: AAPT2 error 

layer-listのmy/drawable項目のうちの1つの間違ったファイル名のため 

そして、私はファイル名を修正することでそれを解決しました。

1

私はここでそして他の多くのサイトで提案されたすべてを試みました、私は問題が Bitdefender ブロックaaptにあることを結局考え出しました....

Bitdefenderがインストールされている場合は、aapt&aapt2 " Application Access "を個別にオンにする必要があります。

これが役に立つことを願っています。 

1
mcadamm4

時々 !画像の奥行きに注意してください。と画像の名前 

例:ic_xxxxx_xxxx - コピー

enter image description here

1
Croid

AAPT2を無効にすると、今後の開発で問題が発生します。私の場合、アプリアイコンを作成したときにエラーが発生しました。

<vector xmlns:Android="http://schemas.Android.com/apk/res/Android"
    Android:width="108dp"
    Android:height="108dp"
    Android:viewportWidth="Infinity"
    Android:viewportHeight="Infinity">
<path Android:fillColor="#26A69A"
      Android:pathData="M0,0h108v108h-108z"/>
<path Android:fillColor="#00000000" Android:pathData="M79,19L79,89"
      Android:strokeColor="#33FFFFFF" Android:strokeWidth="0.8"/>

この行を削除して解決します

    Android:viewportWidth="Infinity"
    Android:viewportHeight="Infinity"
1
tabztabarangao

AAPT2エラー:詳細をログで確認してください または エラー:ファイルリソースのリンクに失敗しました。 エラー:

Android:background = ""この空の属性を削除を含む .xml ファイルを確認すると、問題を解決できます。

1
MarsPeople

Android Studio 3.0.1のKotlinプロジェクトで(Gutterの実行アイコンをクリックして)個々のAndroid実装テストまたはテストクラスを実行しようとした後にこのエラーが発生した場合は、代わりに次のコマンドを実行してエラーを回避できます。フルテストパッケージ(テストパッケージを右クリックして[Run tests in ...]を選択)。

Android Studio 3.0.1には、IDEがKotlinの実装テストを通常のJUnitテストとして実行するという既知のバグがあります。これにより、OPのエラーメッセージが私のマシンに表示されます。バグは https://issuetracker.google.com/issues/71056937 で追跡されています。これはAndroid Studio 3.1 Canary 7で修正されたようです。

1
Andrew Marshall

あなたがKotlinを使用しているならば、xmlファイルにおけるいくつかの間違いのためにエラーを得ています。 kotlinでは、xmlエラーを見つけるのが非常に難しいので、単純にビルドに失敗します。正確なエラーログを知るには、Android Studio Terminalのコマンドの下で実行してください。エラーを修正するのは簡単です。

./gradlew clean
./gradlew assemble
1
Naveen Kumar M

src/main/res/rawディレクトリで有効なファイルタイプを使用していることを確認してください。私の場合、他のファイルと一緒に.movファイルをres/rawディレクトリにコピーしました。私は、問題はaaptが.movファイルを処理しようとしていて、それをどう処理するかわからなかったことにあると思う。

1
Tash Pemhiwa

以下を確認してみてください。問題は解決されるべきです。

  1. まず最初に、プロジェクトの表示に関連するエラーがないかどうか、ビルドウィンドウの下部からログを確認します。エラーが表示される場合は、それらすべてを修正してください。今すぐビルドしてもう一度実行すると、エラーのすべてが解決します。 Android gradleプラグインを3.2.0に変更せずにaapt2の問題を解決します。

  2. 次に、ビルドログにプロジェクト関連のエラーが表示されていなくてもaapt2エラーが表示されている場合は、次の手順を実行して修正できます。

下記のようにあなたのプロジェクトレベルのbuild.gradleファイルであなたのAndroid gradleプラグインを更新してください:

classpath 'com.Android.tools.build:gradle:3.2.0-alpha13'

Android.enableAapt2=trueを更新しましょう。その後、プロジェクトを確認してビルドします。

これらのステップのどれでもaapt関連の問題を解決するためにはたらくはずです。

1
0xalihn

このエラーメッセージ(AAPT2エラー:詳細をログで確認する)は、実際の問題が何であるかがわからないため、役に立ちません。

私の場合は、リソースのXML描画可能ファイルが欠落しているためです。 

error: failed linking file resources.

org.gradle.tooling.BuildException: Failed to process resources, see aapt output above for details.

XMLファイルの変更を元に戻したので、私は考え出しただけで、今回はもっと役に立つメッセージが出ました。

error: resource drawable/ic_filter_off (aka com.xxx:drawable/ic_filter_off) not found.

Message{kind=ERROR, text=error: resource drawable/ic_filter_off (aka com.xxx:drawable/ic_filter_off) not found., sources=[C:\code\xxx\app\src\main\res\layout\app_bar_main.xml:69], original message=, tool name=Optional.of(AAPT)}
1
live-love

私はclasspath 'com.Android.tools.build:gradle:3.2.1'distributionUrl=https\://services.gradle.org/distributions/gradle-4.6-all.Zipをダウングレードすることでこの問題を解決しました

0

アプリ内レベルでbuild.gradleを追加

0
Vishal

この問題がありました

AAPT2エラー:詳細についてはログを確認してください

backslash(')を使用せずに引用符(\)を文字列ファイルに追加したため

エラーテキスト

 <string name="no_internet">You don't have internet connection </string>

固定テキスト

<string name="no_internet">You don\'t have internet connection </string>

そのため、文字列ファイルに正しく追加された特殊文字を確認してください

0

私の場合は、既存のビルドフォルダを削除して再試行することで問題が解決しました。

0
Farrukh Najmi

私は同じ問題に遭遇し、グーグルで検索し、多くの解決策を試しましたが、どれも機能しませんでした。
これを解決する黄金の鍵を見つけるまで:./gradlew assembleDebug

git bashでこのコマンドを試してください。コンソールはどの行にエラーがあるかを正確に示します。
次に、コンパイルが成功するまで改善して、コマンドを再実行します。

0
MadHatter