webdevqa.jp.net

エラー:com.Android.tools.build:gradle:3.3が見つかりませんでした。 splunk:mint-Android-sdkのgradleバージョンをアップグレードした後に発生する問題

私のアプリは正常に動作していたので、com.splunk:mint-Android-sdkを追加しました。これには、gradleの上位バージョンが必要だったため、gradleを2.1から3.3にアップグレードします。その後、私は問題に直面しています。私のgradleファイルを確認して、私を助けて、それがどのように機能するかを教えてください(これは私の最初のアプリですが、すべてのシナリオでうまく動作するはずです)

Error:Could not find com.Android.tools.build:gradle:3.3.
Searched in the following locations:
    file:/C:/Program Files/Android/Android Studio/gradle/m2repository/com/Android/tools/build/gradle/3.3/gradle-3.3.pom
    file:/C:/Program Files/Android/Android Studio/gradle/m2repository/com/Android/tools/build/gradle/3.3/gradle-3.3.jar
    https://plugins.gradle.org/m2/com/Android/tools/build/gradle/3.3/gradle-3.3.pom
    https://plugins.gradle.org/m2/com/Android/tools/build/gradle/3.3/gradle-3.3.jar
    https://jcenter.bintray.com/com/Android/tools/build/gradle/3.3/gradle-3.3.pom
    https://jcenter.bintray.com/com/Android/tools/build/gradle/3.3/gradle-3.3.jar
Required by:
    :MyApp:unspecified

私の卒業

apply plugin: 'com.Android.application'
apply plugin: 'com.google.gms.google-services'

    Android {
    compileSdkVersion 23
    buildToolsVersion "25.0.2"

    defaultConfig {
        applicationId "com.example.abc.myApp"
        minSdkVersion 19
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
        multiDexEnabled= true
        manifestPlaceholders = [onesignal_app_id: "hjaadsffsddd8-2e6hgf-4fdsasdfgb63-8dad5-1111111",
                                onesignal_google_project_number: "REMOTE"]
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.pro'
        }
    }
}
dependencies {
    compile fileTree(include: ['*.jar'], dir: 'libs')
    testCompile 'junit:junit:4.12'
    compile 'com.Android.support:appcompat-v7:23.4.0'
    compile 'com.Android.support:design:23.4.0'
    compile 'com.Android.support:cardview-v7:+'
    compile 'com.getbase:floatingactionbutton:1.10.1'
    compile 'com.Android.support:recyclerview-v7:23.0.0'
    compile 'com.Android.support:support-v4:23.0.0'
    compile 'com.readystatesoftware.sqliteasset:sqliteassethelper:+'

    compile 'com.onesignal:OneSignal:[3.6.1,3.99.99]'
    compile 'com.google.firebase:firebase-core:9.2.0'                        
    compile 'com.google.firebase:firebase-messaging:9.2.0'
    compile 'com.splunk:mint-Android-sdk:5.2.1'
}

そして

// Top-level build file where you can add configuration options common to all sub-projects/modules.
buildscript {
    repositories {
        maven { url "https://plugins.gradle.org/m2/" }
        jcenter()
    }
    dependencies {
        classpath 'com.Android.tools.build:gradle:3.3'
       classpath 'com.google.gms:google-services:3.0.0'
        classpath 'com.splunk:mint-gradle-Android-plugin:5.2.1'
    }
}
allprojects {
    repositories {
        jcenter()
        maven {
            url "https://maven.google.com" // Google's Maven repository
        }
    }
}
task clean(type: Delete) {
    delete rootProject.buildDir
}
10
khawarPK

Buildscript内にgoogle()を追加してから、ターミナルの書き込みコマンドを開きます-gradlew buildを押してEnterを押します。

enter image description here

repositories {
    google()
    jcenter()
}

注意:アクティブなネットワーク接続になっていることを確認してください

12
Juyel Rana

変更したのはGradleプラグインバージョンであり、Gradleバージョンではありません

Gradle Pluginバージョンを2.3に設定します
次に開くgradle/wrapper/gradle-wrapper.propertiesおよび変更GradleバージョンdistributionUrlのバージョン

4
DeKaNszn

このバージョンのgradleプラグインは存在しません

classpath 'com.Android.tools.build:gradle:3.3'

最新のベータリリースを使用します。

classpath 'com.Android.tools.build:gradle:3.0.0-beta6'

代わりにgradleの更新を使用する場合は、gradle-wrapper.propertiesdistributionUrlを更新します。

1