webdevqa.jp.net

サポートされていないメッセージ:BaseConfig.getApplicationIdSuffix()

それで私はプログラマーのためのAndroid 6:App-Driven Approachと最初の2つのアプリケーション例を読んでいますが、今回の例では問題はありませんでした。このエラーが発生しても、プロジェクトをビルドできません。

エラー:サポートされていないメソッド:BaseConfig.getApplicationIdSuffix()。接続しているGradleのバージョンはその方法をサポートしていません。問題を解決するには、接続しているGradleのターゲットバージョンを変更/アップグレードします。あるいは、この例外を無視してモデルから他の情報を読み取ることもできます。

あなたが本のサイトからソースをダウンロードすることができます ここ 私がテストしているのと同じコードベースでテストするために。

230
exts

私はこの問題を解決する方法を考え出したよ。

  • Build.gradleを開き、gradleのバージョンを推奨バージョンに変更します。
    classpath 'com.Android.tools.build:gradle:1.3.0'
    classpath 'com.Android.tools.build:gradle:2.3.2'
  • 'Try Again'を打つ
  • メッセージボックスに'Fix Gradle Wrapper and re-import project'と表示されます。最小グラドルバージョンは3.3です。
  • 新しいエラーがポップアップしてThe SDK Build Tools revision (23.0.1) is too low for project ':app'. Minimum required is 25.0.0と表示されます - Update Build Tools version and sync projectを押してください
  • Android Gradle Plugin Update recommendedというウィンドウがポップアップすることがあります。そこから更新するだけです。

これで、プロジェクトはどのAndroid仮想デバイスでも実行可能になります。

615
exts

Android Studio 3の場合、私はエラーを修正するために2つのファイルを更新する必要があります -

1. app/build.gradle

buildscript {
    repositories {
        jcenter()
        mavenCentral()
        maven {
            url 'https://maven.google.com/'
            name 'Google'
        }
    }

    dependencies {
        classpath 'com.Android.tools.build:gradle:3.0.1'
    }
}

2. app/gradle/wrapper/gradle-wrapper.properties

distributionUrl=https\://services.gradle.org/distributions/gradle-4.1-all.Zip
90
srs

まず、あなたのアプリケーションモジュール build.gradle fileを開きます。

プロジェクトの依存関係に従って クラスパス を確認してください。そうでない場合は、このクラスパスのバージョンを変更してください。

から:

classpath 'com.Android.tools.build:gradle:1.0.0'

に:

classpath 'com.Android.tools.build:gradle:2.3.2'

あなたのAndroidスタジオのグレードに応じてそれ以上のバージョン。

それでも問題が解決しない場合は、 buildToolsVersion を変更します。

から:

buildToolsVersion '21.0.0'

に:

buildToolsVersion '25.0.0'

それから「もう一度試す」を押すとgradleは自動的に同期します。これで解決します。

46
amit pandya

私の場合、Android Studio 3.0.1では、次の2つの手順で問題を解決しました。

ステップ1:プロジェクトレベルのbuild.gradleでGradleプラグインのバージョンを変更する

buildscript {
    repositories {
        jcenter()
        mavenCentral()
        maven {
            url 'https://maven.google.com/'
            name 'Google'
        }
    }
    dependencies {
        classpath 'com.Android.tools.build:gradle:3.0.1'
    }
}

ステップ2:gradleのバージョンを変更する

distributionUrl=https\://services.gradle.org/distributions/gradle-4.1-all.Zip
16
Harry Zhang

私も同じ問題に直面し、非常によく似た解決策を得ました。

  1. クラスパスをクラスパス 'com.Android.tools.build:gradle:2.3.2'に変更します

    クラスパス追加後の画像

  2. Build Toolのバージョンを更新することを示す新しいメッセージが表示されるので、そのメッセージをクリックして更新します。 アップデート

11
Girish B.R

Gradleのバージョンを変更するか更新する

dependencies {
    classpath 'com.Android.tools.build:gradle:3.0.1'
}

alt +を押して「特定のバージョンに置き換える」を選択します。

10
Exel Staderlin

あなたはgradleファイルを変更することによってこれを行うことができます。

 build.gradle > change
    dependencies {
    classpath 'com.Android.tools.build:gradle:3.0.1'
    }
    gradle-wrapper.properties > update
    distributionUrl=https://services.gradle.org/distributions/gradle-4.6-all.Zip
4
Mudassir Khan

This()Unsupported method:BaseConfig.getApplicationIdSuffix Android Projectが古く、Android Studioを更新した場合は、 CLOSE PROJECT を実行して再度実行しました。それは私のために問題を解決しました。依存関係を追加したり、他の回答で説明されているとおりに追加したりしなかった。

0
itzo