webdevqa.jp.net

シンボル 'AppCompatActivity'を解決できません

Android Studioを使おうとしました。私は空白のプロジェクトを作成し、Activityを拡張するAppCompatActivityを作成しようとしました。不幸なAndroid Studioはそれを「言う」

シンボル 'AppCompatActivity'を解決できません

私は私の "app"モジュールの依存関係リストにcompile "com.Android.support:appcompat-v7:22.0.+"を持っていて、プロジェクトを何度か作り直しました。しかしActionBarActivityしか使えません。何がおかしいのですか?

186
Lingviston

適切なlibバージョンと適切なクラスを使用しているときに同じエラーが発生した場合は、ここで他の回答に少し追加してください。

にアップグレードしたとき

appcompat-v7:22.1.0

Android Studioの不具合のため、ActionBarActivityは推奨されなくなり、空でAppCompatActivtyが使用されるようになりましたが、バージョンの変更にはまったく対応していませんでした。

つまり、Gradleがエラーなしで実行されたとしても、IDE自体はCannot resolve symbol 'AppCompatActivity'を言い続けました(そしてそれはCtrl+N検索を通しても利用できませんでした)

.idea/librariesフォルダーを調べたところ、新しいバージョンのlibに適したメタファイルがないことに気付きました。

それで、古い - ファイル - >キャッシュの無効化/再起動 を使ってトリックをやりました。あなたが何かがAndroid Studioで魔法のように間違っていると感じるときはいつもこれを試してください。

323
Ivan Bartsov

Gradle file/"Invalidate caches"や他のIDEツールによるソフトメソッドがうまくいかない場合は、難しい方法を使ってください:

  1. Android Studioを終了します
  2. プロジェクト内で.ideaフォルダーに移動します
  3. librariesフォルダの名前を変更するだけです
  4. Android Studioを再起動します。今すぐlibrariesフォルダを再作成し、再度動作する必要があります。

これは私のために働きました

Android Studio 3.1.2
Build #AI-173.4720617, built on April 13, 2018
JRE: 1.8.0_152-release-1024-b01 AMD64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.13.0-38-generic

Shahbaz ALi 確認済み、動作している

Android Studio 3.1.3
Build #AI-173.4819257, built on June 4, 2018
JRE: 1.8.0_152-release-1024-b01 AMD64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.13.0-38-generic

moujib 確認済み、Android Studio 3.2.1で動作します

156
DBX12

今日(4月22日)、サポートライブラリv 22.1.0でリリースされた新しいAppCompatActivityを使うことができます。

依存関係を変更するだけです。

compile "com.Android.support:appcompat-v7:22.1.0"

ここ この新しいクラスの詳細情報を見ることができます。

70

Go to build.gradleファイルと依存関係のappcompatというファイルで、コンパイル'com.Android.support:appcompat-v7:XX.X.X'のように修正しました。

'com.Android.support:appcompat-v7:XX.X.+'をコンパイルするように変更しました

次に同期をクリックします。あなたのコードの他のすべてが正しければ、すべての赤い波線が正しく表示されるはずです。

それはあまりにも単純です。あなたが従う必要があるステップがあります

1終了アンドロイドスタジオ。

2 - プロジェクトディレクトリに移動します。

私の場合はこのような3 - 何か(F>アンドロイド - > YourProjectName - >。アイデア)。

4).ideaフォルダ内に存在する-deleteライブラリフォルダ。

5)あなたのAndroidスタジオを再起動します。そしてあなたの問題は解決しました。

24
Abdul Mateen

タイプミスもチェックして、AppCompatActivityの代わりにAppCompactActivityを実際に入力したときに解決策を探すのに一日無駄になった

13
Victor Michael

Android Studioを2.2.3から2.3にアップデートし、Android Gradleプラグインを2.3.0にアップデートし、そしてGradleを3.3にアップデートした後、AppCompatActivityと他の多くのクラスとメソッドに対してCannot resolve symbolエラーが発生しました。

File -> Invalidate Caches / Restartは問題を解決しませんでした。

Preferences -> Build, Execution, Deployment -> GradleはGradleホームで選択されたUse local gradle distributionを示していました:/ Applications/Android Studio.app/Contents/gradle/gradle-2.14.1および 鞍点の位置が正しくないという警告が表示されました

Use default gradle wrapper (recommended)を選択して問題を解決しました。
おそらく、新しいローカル配布場所を単に指し示すだけでもうまくいきます。

12
jk7

シンボルAppCompatActivityの問題を解決できません。

問題を解決するために単純な手順を実行します。

i)Androidスタジオを終了します。

ii)プロジェクトディレクトリに移動します。

iii)プロジェクトディレクトリで .idea フォルダを見つけます。

iv) .idea フォルダを削除します。

v)Androidスタジオを再起動します。

vi)問題は解決されるでしょう。

10

これを試して。 Android Studioでは、build.gradleに依存関係を追加した後。 「ビルド」 - >「プロジェクトのクリーン」を選択してください。

それは私のために働きました。

8

それは本当にめちゃくちゃだ、私はGradleファイルと同期し、無効にしてアンドロイドスタジオを再起動し、すべてを試してみた。それでも問題は解決しませんでした。最後の手段は .idea/libraries フォルダーを削除することでした、そして、それは魅力として働きました。

7
Raghav Sharma

あなたは新しいAppCompatActivity appcompat-v7:22.1を使うことができます。

'com.Android.support:appcompat-v7:22.1.1'をコンパイルしてください。

6

私にとっては、appcompact v7を最新のものに更新したときに解決した問題。

'com.Android.support:appcompat-v7:25.3.0'をコンパイルしてください

それが役に立てば幸い...:)

6
Nihas Nizar

Mac OS X Yosemiteマシンで開発している間、私はAndroid SDK 23でも同じ問題を抱えていました。私はJava SDK 7を持っていないことがわかった。

Java SDK 7をインストールし、Android Studioから新しいSDKにSDKを指定すると、すべてがうまくいきました。

私が従った手順は次のとおりです。

1)Android SDKをシャットダウンします

2)Mac OS X用のJava SDKを http://www.Oracle.com/technetwork/Java/javase/download/index.html からインストールします。

3)Android SDKを起動し、[ファイル] - > [プロジェクト構造] - > [JDKの場所]に移動して、このプロジェクトのSDKを新しい1.7 Java SDKに設定します。

4)Android Studioを再起動します

この助けを願っています

5
AsgharHussain

それで、私の同僚は彼らのlocal.propertiesをプッシュしてすべてを壊しました。私は別のアプリから私のSDKパスをコピーしてしました:

File -> Sync Project with Gradle Files
5
Seabass77

以下のどれも私の問題を解決しませんでした

  • Androidを再起動します
  • ファイル>> Gradleファイルとの同期プロジェクト
  • ビルド>>クリーンプロジェクト
  • ビルド>>プロジェクトのリビルド
  • ファイル>>キャッシュの無効化/再起動

代わりに、appcompatのバージョンと設計の依存関係を最新バージョンに更新して解決しました。そうするには:build.grade(Module:app) >>依存関係セクションを押してから、appcompatとデザインの両方の依存関係でALT + ENTERを押し、次に示すように、表示されているバージョンを選択します。絵 enter image description here

3
Zain

Gradle 2.3.3を4.4に更新したところ、AppCompatActivityとCardviewでエラーが発生しました。私はきれいなプロジェクトとプロジェクトの再構築を試みました。それは動作しません、それから私は プロジェクトフォルダに行きます - > .idea - > ライブラリ フォルダのバックアップを作成し、それを削除します - >そして Rebuild Project 問題。

3
manojm

押すことを忘れないでください Alt+Enter またはインポートを追加します。

import Android.support.v7.app.AppCompatActivity; 
3
Suragch

最新のサポートライブラリにアップグレードした後、IDEがAppCompatActivityを認識する前に、最新のAndroid Studio(Beta)バージョンとGradleバージョンにアップグレードする必要がありました(キャッシュを無効にして再起動してもうまくいきません)。

2
Ciske Boekelo

この依存関係をプロジェクトビルドの.gradleに追加します。

以下の例に従ってください。

dependencies {

    compile 'com.Android.support:appcompat-v7:22.1.0'
}
2
user2306383

ステップバイステップで進むことができます。

ビルド - >クリーン

これで解決しない場合は、次に第二段階を使用してください

ファイル>キャッシュの無効化/再起動...

しかし、本当の問題は上記のすべてのオプションがうまくいかないときに始まるので、あなたの究極の解決策はプロジェクトを閉じてプロジェクトの場所のディレクトリに行って削除することです

。アイディア

もう一度プロジェクトを開くことができます。

2

依存関係を追加して、Gradleアプリファイルに何らかの変更を加えるだけです。

「com.Android.support:appcompat-v7:XX:YY:ZZ」をコンパイルします

xX:YY:ZZはあなたがGradleファイルで使っているバージョンコードです。

1
Nadeem Bhat

私のAndroidスタジオを2.3.2から3.1.2にアップデートしました。そしてこのエラーが発生します。

私はプロジェクトをきれいにし、プロジェクトを再構築し、キャッシュを無効にします/再起動しますが何も動作しません。

私はからappcompatライブラリを更新することによって、このエラーを解決します

'com.Android.support:appcompat-v7:23.4.0'をコンパイルしてください。

'com.Android.support:appcompat-v7:25.1.1'をコンパイルしてください。

アプリのbuild.gradleファイルにあります。

1
mehmoodnisar125

キャッシュを無効にしても解決しない場合は、プロジェクトを閉じてからもう一度開きます。ステップ:

  • ファイル>プロジェクトを閉じる
  • 開始プロジェクトリストからプロジェクトを削除する
  • Android Studioを閉じる
  • Android Studioを開く
  • このプロジェクトと既存プロジェクトをオープン
1

これは、次のいずれかの理由により発生します。

  1. SDK APIがインストールされていません(これが私の問題でした)
  2. あなたのプロジェクト/ Android Studioは必要なファイルがどこにあるのかわかりません
  3. あなたのプロジェクトはAppCompatActivityをサポートしていない古いコンパイルバージョンを参照しています
  4. タイプミスがあります

可能な解決策:

  1. .gradleファイルを調べて、古いバージョンを参照していないことを確認してください。 AppCompatActivityはバージョン25.1.0で追加され、Maven artifact com.Android.support:appcompat-v7:28.0.0-alpha1に属しますので、これより前のバージョンは使用しないでください。 build.gradle(Module:app)ファイルには、依存関係がリストされているはずです。

    依存関係{compile 'com.Android.support:appcompat-v7:25.1.0'}

    別のバージョンを使用している可能性がありますが、依存関係がリストされていることを確認してください。

  2. SDKマネージャを開き、すべてのAPI 7以降をダウンロードします。必要なAPIを見逃していた場合は、その問題は解決されます。新しいAPIをすべてダウンロードすることで、後で面倒な手間を省くことができます。

  3. インポートステートメントの入力ミスを確認してください。 「AppCompatActivity」ではなく「AppCompactActivity」と表示されていないことを確認してください。
  4. プロジェクトを再同期します([ファイル] - [プロジェクトをGradleファイルと同期])。
  5. プロジェクトを再ビルドします([ビルド]> [再ビルド])。
  6. プロジェクトをクリーンアップします([ビルド] - [クリーンプロジェクト])。
  7. Android Studioを閉じて再起動します
  8. Android Studioをアップデートする
  9. ライブラリフォルダを再生成する - Android Studioの場合は、プロジェクトビューでファイルを表示します。 YourProjectName> .idea> librariesフォルダを見つけます。フォルダの名前を "libraries_delete_me"に変更してください。 Android Studioを閉じて再度開きます。プロジェクトをもう一度開くと、ライブラリフォルダがすべてのファイルで再生成されます。これで、 "libraries_delete_me"フォルダを削除することができます。
0
technoman23

これは私がどこかで見つけた命の恩人のコードです(申し訳ありませんがOriginを覚えていません)。それをbuild.gradle(Module:app)に追加してください。あなたは、関連するものにバージョンを置き換えることができます。

configurations.all {

    resolutionStrategy.eachDependency { DependencyResolveDetails details -
        def requested = details.requested

 if (requested.group == 'com.Android.support') {

            if (!requested.name.startsWith("multidex")) {
                details.useVersion '27.1.1'
            }
        } else if (requested.group == "com.google.Android.gms") {
            details.useVersion '15.0.0'
        } else if (requested.group == "com.google.firebase") {
            details.useVersion '15.0.0'
        }
    }
}
0

私にとっては、Gradleビルドバージョンをアップデートしたときにこの問題は解決しました。理由がわからないのですか。

0
Srikar Reddy

これは、アプリレベルでのバージョンの違いにより、一度それを確認してから再構築することができます

0
Kamal

私には解決策のどれも働いていませんでした。しかし、サポートライブラリのすべてのライブラリが私の外部ライブラリにないことを知りました。そして他のプロジェクトではAppCompatActivityは問題なく解決されました。

私にとっては、新しいプロジェクトを作成し、古いsrcフォルダーのすべてのものを新しいプロジェクトにコピーすることに成功しました。

正確な理由はわかりませんが、うまくいかない場合は最後の可能性があります。誰かが私と同じ問題を抱えている場合でも。

0
user7174483

他のすべてが失敗した場合は、importステートメントを追加したことを確認してください。私はそれがエラーを示していたのでそれを削除し、それを再び追加するのを忘れていて、他のすべてを修正しようとしていました:

android.support.v7.app.AppCompatActivityをインポートします。

0
Srihari Karanth

文字通りすべてのソリューションを試した後、私が取り組んでいたプロジェクトは、以前は3.2であった最新のAndroid St​​udioを使用しており、使用していた現在のPCはAndroid studioの更新これにより、問題は完全に解決されたようです。

解決策:Android Studio->アップデートの確認と最新ビルドのインストール

0
Louis Ferraiolo

それがうまくいかないソフトな方法を試すことによって、難しい方法を使ってください。現在のAndroid Studio画面を終了し、プロジェクトを.ideaフォルダに移動します。

Android Studioを再起動します。これで、ライブラリフォルダが再作成され、再びスムーズに機能します。 Android Studio 3.1.3

0
Nadeem Bhat

私のGoogleサービスは4.1.0バージョンを使用していましたが、API 28の最新バージョンにすべての依存関係を更新してプロジェクトにfirebaseを追加したときにエラーが発生しました。

私は4.2.0にそれを更新したとき、私はエラーを取り除きました。

0
Lovish-Pandey

Eclipseでこの問題をどのように解決したかを説明します。このリンクからZipファイルをダウンロードします。 https://github.com/dandar3/Android-support-v7-appcompat 次にこのファイルを抽出し、プロジェクトを開き、 libフォルダーには、「Android-support-v7-appcompat」という名前のjarファイルが1つ表示されます。このjarファイルをプロジェクトに追加します。それでおしまい。 enter image description here

0