webdevqa.jp.net

ライブラリcom.google.firebase:firebase-iidは[[17.0.0,17.0.0]]にある他のさまざまなライブラリによって要求されていますが、16.2.0に解決されます。

私は今日このエラーを取得し始めました、昨日はすべてうまくいきました、gradleまたはfirebaseのバージョンに変更はありませんでした

ライブラリcom.google.firebase:firebase-iidは、[[17.0.0,17.0.0]]の他のさまざまなライブラリによって要求されていますが、16.2.0に解決されます。プラグインを無効にし、。/ gradlew:app:dependenciesを使用して依存関係ツリーを確認します。

昨日はgoogle-servicesプラグインの更新であることがわかりました 、おそらく問題の原因です。

この問題を修正するには?

30
Lucky_girl

同じ問題がありました。簡単な修正方法は、この問題の原因となっている厳密なバージョンチェックを無効にすることです。追加

com.google.gms.googleservices.GoogleServicesPlugin.config.disableVersionCheck = true

アプリのbuild.gradleファイルの一番下にあります。

28
Nick

同じ問題がありました。 firebaseメッセージングを最新バージョンに更新することで解決しました(現時点では)。

implementation 'com.google.firebase:firebase-messaging:17.0.0'

implementation 'com.google.firebase:firebase-messaging:17.3.4'

そしてそれは解決されます(副作用なし)

16
masoudmjm

私にとって、バージョンチェックを無効にしても問題は解決しませんでした。私がやったことは、firebaseメッセージングライブラリからfirebase-iidモジュールを除外し、個別に追加することです

implementation ("com.google.firebase:firebase-messaging:17.3.4"){
        exclude group: 'com.google.firebase', module: 'firebase-iid'
    }

implementation 'com.google.firebase:firebase-iid:17.0.3'
9
Ana Koridze

この問題が発生した場合は、このチェックを無効にできるという多くの投稿が表示される場合があります。それが問題を隠すので、私はそれをするのが好きではありません。

しばらくして、あるライブラリが私が持っていないバージョンを要求しているということをようやく理解しました。そこで、これをbuild/app/build.gradleに追加し、ビルドしました

implementation "com.google.firebase:firebase-iid:17.0.2"

あなたの場合、16.2.0に解決されると書かれているバージョンを使用してください。

8
sfratini

これらのfirebase依存関係を使用して、com.google.firebase:firebase-iidで同様のエラーが発生しました。

  1. 実装 'com.google.firebase:firebase-core:16.0.7'
  2. 実装 'com.google.firebase:firebase-messaging:17.3.4'
  3. 実装 'com.google.firebase:firebase-database:16.0.6'
  4. 実装 'com.crashlytics.sdk.Android:crashlytics:2.9.6'
  5. 実装 'com.google.firebase:firebase-functions:16.1.3'

追加した後

  • 実装 'com.google.firebase:firebase-analytics:16.3.0'

なくなりました。

5
Aris Bartee

今日も同じエラーが発生しました。 react-native-firebasereact-native-Push-notificationを使用しています。 ./gradlew :app:dependenciesを実行すると、react-native-Push-notificationcom.google.firebase:firebase-messagingの最新バージョンを必要としており、それがcom.google.firebase:firebase-iid:[17.0.0]を必要としており、エラーが発生していることがわかりました。

here のように、firebase-messagingreact-native-Push-notificationの以前のバージョンを手動で指定しました。それは私のために問題を修正しました:

// in Android/build.gradle

ext {
    firebaseVersion = '17.1.0' // add this line
    // ...
}
4
Jack Swiggett

同じ問題がありましたが、Firebaseの依存関係をすべて最新のものに更新することで解決しました。

// Firebase
    implementation 'com.google.firebase:firebase-core:17.0.1'
    implementation 'com.google.firebase:firebase-auth:18.1.0'
    implementation 'com.google.firebase:firebase-messaging:19.0.1'

    implementation 'com.firebaseui:firebase-ui-firestore:5.0.0'
    implementation 'com.firebaseui:firebase-ui-storage:5.0.0'

    testImplementation 'junit:junit:4.12'
    androidTestImplementation 'androidx.test:runner:1.3.0-alpha01'
    androidTestImplementation 'androidx.test.espresso:espresso-core:3.3.0-alpha01'
1
Dan

私にとっては、node_modules/@ aws-amplify/pushnotificationのbuild.gradleファイルでした(react-native-Push-notificationのbuild.gradleファイルにも同じことが当てはまります)

firebaseパッケージのバージョン番号を、app/build.gradleファイルにあるものと一致するように変更します。

私にとっては

compile 'com.google.firebase:firebase-messaging:17.6.0' compile 'com.google.firebase:firebase-core:16.0.8'

1
MattDameon
  • 最新のCordova-Androidプラットフォーム(v8.0.0)を追加します

    イオンコルドバプラットフォームはAndroid @ latestを追加します

  • このプラグインのフォークを追加します

    イオン性Cordovaプラグインはcordova-plugin-firebasexを追加します

  • プロジェクトでAndroidXを有効にするプラグインを追加します

    イオン性Cordovaプラグインはcordova-plugin-androidxを追加します

  • 既存のプラグインソースにパッチを適用するプラグインを追加します

イオン性Cordovaプラグインはcordova-plugin-androidx-adapterを追加します

  • ビルド!

    イオンコルドバビルドAndroid

それは100%作品です

1
Yogesh Patil

Android St​​udioユーザーのみ

同じ問題がありました。これはapply plugin: 'com.google.gms.google-services' com.google.gms.googleservices.GoogleServicesPlugin.config.disableVersionCheck = trueの後に追加されます

あなたのアプリbuild.gradleファイルの一番下で、私の問題は解決しました

 apply plugin: 'com.google.gms.google-services' 

com.google.gms.googleservices.GoogleServicesPlugin.config.disableVersionCheck = true
1
Lalit Baghel

同様の問題がありましたが、エラーメッセージが表示されました。

依存関係の失敗:com.google.firebase:firebase-messaging:17.0.0-> com.google.firebase:firebase-iid @ [16.0.0]ですが、fire base-iidバージョンは19.0.0でした。

アプリレベルで次のバージョンを使用して解決しましたbuild.gradle;

// Google Firebase
implementation 'com.google.firebase:firebase-core:17.0.1'
implementation 'com.google.firebase:firebase-messaging:19.0.1'
0
functup

すべてのcom.google.firebaseライブラリをアップグレードしても問題が解決しない場合は、com.google.gms:google-servicesでGoogleサービスプラグインの依存関係をアップグレードしてください。

0
alexfdz