webdevqa.jp.net

使用許諾契約に同意できないAndroid SDK Platform 24

CordovaプロジェクトにAndroidプラットフォームをインストールしようとすると、次のようなエラーが表示されます。私はこのガイドに従ってきました: https://cordova.Apache.org/docs/en/latest/guide/cli/

次のコマンドを実行するとエラーが発生します。$ cordova platform add Android --save

ルートプロジェクト 'Android'の設定中に問題が発生しました。次のSDKコンポーネントの使用許諾契約に同意していません:[Android SDK Platform 24]。

Android SDK Platform 24の使用許諾契約に同意します を検索しましたが、実際には運がありません。

早めにありがとう。

111
Daneye

Cordovaがどのように機能するのか正確にはわかりませんが、ライセンスが承認されるとファイルが作成されます。そのファイルを手動で作成することができます。これは この質問 で説明されていますが、ここに必要なライセンスファイルを作成するためのコマンドがあります。

Linux:

mkdir "$Android_HOME/licenses"
echo -e "\n8933bad161af4178b1185d1a37fbf41ea5269c55" > "$Android_HOME/licenses/Android-sdk-license"

Windows:

mkdir "%Android_HOME%\licenses"
echo |set /p="8933bad161af4178b1185d1a37fbf41ea5269c55" > "%Android_HOME%\licenses\Android-sdk-license"
161
Mike

実行することもできます

$ Android_HOME/tools/bin/sdkmanager --licenses

またはWindowsの場合は実行

%Android_HOME%/ tools/bin/sdkmanager --licenses

(@ puneet-kumarに対するwindowsコマンドのクレジット)

157
Hardik Patel

私はCordova 6.4.0とAndroid Studio 2.2.3を搭載したMac OS X 10.12.1でこの問題を抱えていました。

Android Studioをインストールしたとき、プラットフォーム25はインストールされましたが、プラットフォーム24はインストールされませんでした。

  • Android Studioを開きます。
  • Android Studio Menu > Preferencesを開きます。
  • Appearance & Behavior > System Settings > Android SDK
  • Android 7.0 (Nougat) | 24のボックスにチェックを入れます
  • [OK]をクリックして指示に従います。
47
jxmallett

私は全く同じ問題を抱えていました。それから私は "アンドロイド7.0(API 24)> SDKプラットフォーム"をインストールし、それが働いた。

enter image description here

25
feyyaz

Android\sdk\tools\binに移動します。

遅れていますが、上記のすべての解決策が私にはうまくいきませんでした。

yes | sdkmanager --licenses && sdkmanager --update
22
vishwaraj

この問題を解決する最も簡単な方法は、次のコマンドを使用してライセンスに同意することです。

Windows OS:

C:\Users\{your-username}\AppData\Local\Android\sdk\tools\bin\sdkmanager --licenses

免責事項が表示されます。あなたの開発努力を続けるために、あなたはすべての免責事項に 'y'と答える必要があります。

20
Full Array

私の場合、私はAndroidスタジオを使用しません(私はEclipseを使用しています)。私は次のステップを踏みました:ただコマンドを実行することによって解決しました

Android-sdks/tools/bin$ ./sdkmanager --update

これはlicensesディレクトリを作成し、その中にAndroid-sdk-licenseというファイルを追加しました。

それからあなたは実行することができます(licensesオプションは上記のステップをしない限り利用できません)

Android-sdks/tools/bin$ ./sdkmanager --licenses

そしてライセンスに同意してください(ただし私の場合はそうする必要はありませんでした)

12
BeeZone

私は問題を抱えていた、あなたがコピーしたり、フォルダを作成する必要はありません、ただあなたのSDKパスに注意してください、それは環境変数(Android_HOME)と同じであるに違いありません。

sdk location

12
John

私はSDKマネージャを介してAndroid SDKビルドツール24(それは現在のバージョン24.0.3)をインストールしました。開くSDKマネージャへのパスは添付のimgファイルに示されています。これで私の問題は解決しました SDKマネージャ

9
Brijesh Singh

Android StudioをインストールしてAndroid SDKを入手したところ、このエラーも発生しました。 からの簡単な解決策があります

  1. Android Studioがインストールされているマシンで、Tools > Android > SDK Managerをクリックします。ウィンドウ上部の Android SDK Location に注目してください。

  2. そのディレクトリに移動して、その中のlicenses/ディレクトリを見つけます。

    licenses/ディレクトリが表示されていない場合は、ライセンス契約に必ず同意して、Android Studioおよび update SDKツールに戻ってください。 。)

  3. licenses/ディレクトリ全体をコピーして、プロジェクトを構築したいマシンのAndroid SDK home directoryに貼り付けます。

7
Java Xu

このエラーは、システムが適切なパスからAndroid_HOME環境変数を選択していない場合に発生する可能性があります。以下の画像のように、Android SDKをインストールし、Android_HOME変数を適切なパスに正しく設定したことを確認してください。

Android_HOME_PATH

Android_HOME変数が定義されていない場合、システムはデフォルトパスからパスを選択しようとします(これはAndroid SDKが定義されているパスではないため、この問題が発生する可能性があります)。

7

これを書いている時点では、デフォルトでは Ionic CLI toolがデフォルトになっているからです。

<preference name="Android-targetSdkVersion" value="LATEST_SDK_VERSION"/> 

それが、あなたが使用許諾契約に同意しなかったと文句を言う理由ですが、実際にはそのために SDKパッケージ をインストールしなかった _ api _ Levelだけでライセンスを受け入れます。

だからあなたがする必要があるのはどちらかです。

  1. ターゲットSDKのバージョンを変更する
  2. SDK Manager から最新のSDK APIレベルをインストールします。

SDKのバージョンを変更する

あなたはそれを手動で行うことができ、さらに実行することでそれを検証することができます

ionic cordova platform add Android 

ファイルはyour-awesome-app/config.xmlにありますので、開いてこの行を追加してください。

<preference name="Android-targetSdkVersion" value="24"/>

どの API LEVEL番号 を使用しているのかわからない場合は、open SDKマネージャ を参照し、 APIレベル (数字)を確認してください。

最新のSDKパッケージのインストール

_ cli _ が表示されている現在の SDKパッケージ を追加できます。これは 24 です。

Admin としてSDK MANAGERを実行します。

Run SDK Manager as Admin

ターゲットとしている SDK APIパッケージ をインストールします。

Thats where the SDK API level are written

どうやってこれを知ったの?私は今朝それをしました、そしてそれは私がそれを解決した方法であり、そして今プレイしています Android上でスティッキーバブル 少しリラックスするために/.

ハッピーデプロイ!

4
Fahad

「公式」の方法に従うこともできます。 Android SDKインストールの tools/bin フォルダー内で " sdkmanager --licenses "を実行し、すべてのライセンスを受け入れます。完了しました。

c:\Android-sdk\tools\bin>sdkmanager --licenses

MacOSまたはLinuxの場合は同じコマンドです。

4
Georgy K

次のコンポーネントをインストールしてください。

enter image description here

4
Sumant Singh

私の場合(Android CIコンテナを構築するためのDockerfileスクリプト - https://github.com/menny/docker_Android )、私はこれらのステップを実行しなければなりませんでした:

mkdir ~/.Android && touch ~/.Android/repositories.cfg
yes | sdkmanager --licenses
sdkmanager "build-tools;26.0.0"
sdkmanager "platform-tools" "tools"
sdkmanager "platforms;Android-26" "platforms;Android-25" "platforms;Android-24"
.....
sdkmanager --update
yes | sdkmanager --licenses

2つのメモ:

  1. 空のrepositories.cfgファイルを作成しなければsdkmanagerは死んでしまいます。
  2. 進行状況の表示がないので、異なる呼び出しでパッケージの取得/インストールを実行しなければなりませんでした。
4
Menny

私はMacを使用していますが、このコマンドを使用して解決しました。

$ which sdkmanager
/usr/local/bin/sdkmanager
$ /usr/local/bin/sdkmanager --licenses
Warning: File /Users/user/.Android/repositories.cfg could not be loaded.
6 of 6 SDK package licenses not accepted.
Review licenses that have not been accepted (y/N)? y

それから私は受け入れるべき6つのライセンスのリストを持っていて、その後解決されました。

3
Neel

私はAndroidのSDKを更新する必要がありました

Android update sdk --no-ui

ある時点でそれはあなたに使用許諾契約を求めるでしょう、yを押してください。その後、角張ったプラットフォームを取り外す必要があります。

3
Reza

C:\ Users {ユーザー}\AppData\Local\Android\sdk\tools\binに移動します。

それから sdkmanager --licenses を実行してください。

それはあなたが同意するために残っているどんな契約でも受け入れることをあなたに頼むでしょう。あなただけの "y"を入力して入力する必要があります。

問題を解決します

3
Lakshitha Ruwan
  1. Android SDKの場所に移動します

C:¥Users¥username¥AppData¥Local¥Android¥sdk¥tools¥bin

  1. 実行コマンドsdkmanager --licenses

  2. SDKのライセンスに同意する

3
Inder malviya

「Android Studio」を必要とするAndroidビルドのアプローチが変更されているところからSDKマネージャの古いバージョンがすでにマシンにある場合、この問題は表面化しています。 「あなたはバージョン25のライセンスに同意していません」というエラーメッセージで繰り返し中止されていたVisual Studioでこれに直面しました。これを解決するには、「Android Studioのインストール」、「環境変数」の順に選択し、Android_HOMEを「C:\ Users \\ AppData\Local\Android\Sdk」に設定します(このパスはAndroid Studioから選択できます、メニュー)。 >>ツール>> SDKマネージャ環境変数の「パス」でも同じように使用することで、新しいSDKマネージャがVisual Studio Build for Cordovaアプリケーションによるピックアップ用にマッピングされます。

これは私の2日間の努力に2度かかった

他の人がこの混乱で自分の時間を無駄にしないことを願います。

2
ekambar kodali

最新stablesdk-platformがインストールされている必要があります。私はAPI-25からSDK-Platformをインストールしました。それは私の問題を解決しました。  See Screenshot below

2
Tushar Walzade

あなたは手動でこれを助けてSDKを再インストールする必要があります: https://forum.ionicframework.com/t/you-have-not-accepted-the-license-agreements-of-the-following-sdk-component/ 69570/6

"AndroidアップデートSDK - NO-UI - フィルタービルドツール-24.0.0、Android-24、エクストラAndroid-m2リポジトリ"

1
Yevhen Kotliar

ターゲットビルドの変更は参照通りに動作するかもしれません ここ

SDKのバージョンを指定したい場合は、Ion/cordovaプロジェクトのルートにあるconfig.xmlに次の行を追加してください。

<preference name="Android-targetSdkVersion" value="23"/>
1
Madhu Kumar

これがあちらこちらでうまくいくことを願っています
私は同じ問題に直面していました!私はsdkとsdk1という2つのsdkを持っていました。これはデフォルトではsdkにリンクされていましたが、動作するものはsdk1でした。だから私はEnvironment Varaibleに行き、Android_HOMEとsdk1のパス、つまり私の場合C:\ Users\tripa_000\AppData\Local\Android\sdk1)を追加し、それが私の問題を解決しました!

1

私はちょうどこの問題に遭遇した、そしてそれがWindows上で私のためにそれを解決した、あなたはコマンドラインを使用している、そしてあなたは最近Android SDKをインストールした。

0
Norman Breau

これにより、Android SDKが更新され、同時にライセンスが承認されます(Android 25の場合など)。

AndroidアップデートSDK --no-ui - filter build-tools-25.0.0、Android-25、extra-Android-m2repository

0
Yann Ulrich

私にとっての問題は、私のAndroid_HOME変数が他のインストールに設定されていたことです。これがあなたの問題であるならば、古いインストールを削除してください。

0
Cilan

その平均的なミスはあなたがインストールしたバージョンとcordovaのAndroid SDKバージョンを一致させます。例えば、cordovaはAndroid SDK 24をサポートしていますが、Android SDK 24はありません。

0
Yusuf

あなたが手動でライセンスフォルダを作成したくない場合、そしてあなたのsdkが "Users/User"にない場合は、Android Studio => Configure => SDK Managerに行き、任意のコンポーネントをインストールすることができます。 SDKツール、それは自動的に正しい場所にライセンスを生成しました。

0

私にとっては、 "イオンビルドAndroid"コマンドを使用してイオンをビルドしていましたが、同じ問題が発生していました。解決策は

  • 必要なsdkをインストールする
  • 管理者としてCMDで同じコマンドを実行する必要があります
0
Adel

Mikeの答えはうまくいきます。しかし、生成されたライセンスをC:\ Users\user\AppData\Local\Android\sdk\licensesに置く必要があります。

0
Thyagu

android 7 - Platform 24 FullをAndroid sdk managerにインストールします

それだけ

0
Ali Gh