webdevqa.jp.net

複数のdexファイルがLcom / google / Android / gms / internal / measurement / zzabnを定義します

今朝からAndroidアプリをビルドできません

問題点:タスク ':app:transformDexArchiveWithDexMergerForDebug'の実行に失敗しました。 com.Android.build.api.transform.TransformException:com.Android.dex.DexException:複数のdexファイルがLcom/google/Android/gms/internal/measurement/zzabnを定義しています。

Firebaseバージョンを15.0.2に合わせて変更しようとしましたが、その後、他のエラーが発生します...

タスク:app:processDebugGoogleServices com.google.Android.gms:play-services-maps:15.0.0が見つかりましたが、google-servicesプラグインにはバージョン15.0.2が必要です。

com.google.Android.gms:play-services-maps:15.0.2はまだリリースされていませんか?

実稼働環境にプッシュするビルドがありますが、アプリをビルドする最良の方法は何ですか?

10
Alexis

google-serviceプラグインを更新してください:

classpath 'com.google.gms:google-services:3.3.0'

firebaseの最新バージョンを使用して、エラーを回避できるようにします。

詳細については、次をお読みください。

https://Android-developers.googleblog.com/2018/05/announcing-new-sdk-versioning.html

コンパイルの完了に失敗しました:プログラムタイプは既に存在します:com.google.Android.gms.internal.measurement.zzabn

13
Peter Haddad