webdevqa.jp.net

解決に失敗しました:com.Android.support:appcompat-v7:26.0.0

私はAndroid Studioでこの問題を抱えています。

Error:(22, 13) Failed to resolve: com.Android.support:appcompat-v7:26.0.0
<a href="install.m2.repo">Install Repository and sync project</a><br><a href="openFile:C:/Users/username/AndroidStudioProjects/ElectroSave/app/build.gradle">Show in File</a><br><a href="open.dependency.in.project.structure">Show in Project Structure dialog</a>

これは私のGradleコードです。

apply plugin: 'com.Android.application'

Android {
       compileSdkVersion 26
      buildToolsVersion "25.0.2"
    defaultConfig {
    applicationId "com.example.noelly.myapplication"
    minSdkVersion 19
    targetSdkVersion 25
    versionCode 1
    versionName "1.0"
}
   buildTypes {
      release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-Android.txt'), 
'proguard-rules.pro'




 dependencies {
     compile fileTree(dir: 'libs', include: ['*.jar'])
     compile 'com.Android.support:appcompat-v7:26.0.0'
}
75
LE LENNY FACE

バージョン26.0.0以降のサポートライブラリを使用するには、ここで説明されているように、プロジェクトのbuild.gradleファイルにGoogleのMavenリポジトリを追加する必要があります。 https://developer.Android.com/topic/libraries/support-library/setup) .html

allprojects {
        repositories {
            jcenter()
            maven {
                url "https://maven.google.com"
            }
        }
    }

Android Studio 3.0.0以上の場合

allprojects {
        repositories {
            jcenter()
            google()
        }
    }
192

注意してください、我々は リビジョン25.4.0 からサポートライブラリを使用するためにGoogle mavenを追加する必要があります。 リリースノートにある のように:

重要:サポートライブラリは、GoogleのMavenリポジトリから入手できます。 SDKマネージャからサポートリポジトリをダウンロードする必要はありません。詳細については、Support Library Setupを参照してください。

詳しくは Support Library Setup をご覧ください。

バージョン11.2.0以降のPlay servicesおよびFirebaseの依存関係もGoogle mavenが必要です。 Google Playサービスを使用するアプリの一部の更新 および Google API Android 2017年8月 - バージョン11.2.0リリースノート _。

そのため、Google Mavenを root build.gradleに追加する必要があります。

allprojects {
    repositories {
        jcenter()
        maven {
            url "https://maven.google.com"
        }
    }
}

Gradleビルドツールプラグインバージョン3.0.0の場合は、google() repositoryを使用できます(もっと詳しくは{ Gradle 3.0.0用のAndroidプラグインへの移行 ):

allprojects {
    repositories {
        jcenter()
        google()
    }
}

更新:

GoogleのMavenリポジトリ :から:

次のAndroidライブラリの最新バージョンは、GoogleのMavenリポジトリから入手できます。

それらをあなたのビルドに追加するには、最初に トップレベルの/ root build.gradleファイルにGoogleのMavenリポジトリを含める必要があります。

allprojects {
    repositories {
        google()

        // If you're using a version of Gradle lower than 4.1, you must instead use:
        // maven {
        //     url 'https://maven.google.com'
        // }
        // An alternative URL is 'https://dl.google.com/dl/Android/maven2/'
    }
}

それからモジュールの依存関係ブロックに希望のライブラリを追加してください。たとえば、appcompatライブラリは次のようになります。

dependencies {
    compile 'com.Android.support:appcompat-v7:26.1.0'
}

ただし、上記のライブラリの古いバージョンを使用しようとして依存関係が失敗した場合は、Mavenリポジトリで利用できないため、代わりにオフラインリポジトリからライブラリを入手する必要があります。

すでにjitpack.ioまたは他のリポジトリを使用している場合あなたはこのようにグーグルリポジトリを追加することができます:

allprojects {
    repositories {
        maven { url "https://jitpack.io" }
        maven { url "https://maven.google.com" }
    }
}
4
Mehmet Hanoğlu

モジュールエリアにalpha1を追加するのを忘れています

compile 'com.Android.support:appcompat-v7:26.0.0-alpha1'

プロジェクトエリアにMavenリポジトリを使用する

allprojects {
    repositories {
        jcenter()
        maven {
            url "https://maven.google.com"
        }
    }
}
3
Sumit Malik

変化する

compile 'com.Android.support:appcompat-v7:26.0'

`compile 'com.Android.support:appcompat-v7:26.+'`

私のためにうまく働いた。

2
  1. これを build.gradle(Project:projectname)に追加します

    allprojects {
      repositories {
        jcenter()
        maven { url "https://maven.google.com" }
      }
    }
    
  2. これを build.gradleに追加します(モジュール:app)

    dependencies {
      compile 'com.Android.support:appcompat-v7:26.1.0'
    }
    
1
Chinki Sai

Android Studio 3.0を使用している場合は、以下に示すようにGoogle Mavenリポジトリを追加します。

allprojects {
  repositories {
    jcenter()
    google()
 }
}
1
user8583580

enter image description here 私は同じ問題に直面していましたが、26.0.0-beta1の依存関係を26.1.0に切り替えましたが、現在は動作しています。

1
Buzz

SDKパス:SDK\extras\Android\m2repository\com\Android\support\appcompat-v7に移動して正しい依存関係名を確認し、依存関係がアルファバージョンの場合は名前を変更します。

dependencies {
  compile fileTree(dir: 'libs', include: ['*.jar'])
  compile 'com.Android.support:appcompat-v7:26.0.0'
}

に:

dependencies {
  compile fileTree(dir: 'libs', include: ['*.jar'])
  compile 'com.Android.support:appcompat-v7:26.0.0-alpha1'
}
0
Ehsan Jelodar

私の問題は、次の手順で解決しました。

グレード3.0.0以上のバージョン用

  1. jcenter()の下にgoogle()を追加
  2. CompileSdkVersionを26に、buildToolsVersionを26.0.2に変更します。
  3. Gradle_wrapper.propertiesファイルでgradle-4.2.1-all.Zipに変更します。
0
Monika Moon

[ファイル] - > [プロジェクト構造] - > [モジュール](app) - > [依存関係]タブを開く - > [すべて削除]を選択し、+を使用して提案リストから追加します。

0
TiyebM