webdevqa.jp.net

解決に失敗しました:com.Android.support:appcompat-v7:27.+(依存関係エラー)

私はAndroid Studioでこの問題を抱えています。

Error:Failed to resolve: com.Android.support:appcompat-v7:27.+
<a href="install.m2.repo">Install Repository and sync project</a><br><a href="open.dependency.in.project.structure">Show in Project Structure 
dialog</a>

私のAndroid Studioはエラーに満ちていますAndroid Studioはライブラリを識別できません。画面全体はこのように見えます。

image

これは私のGradleコードです。

apply plugin: 'com.Android.application'

Android {
    compileSdkVersion 27
    buildToolsVersion "27.0.1"

    defaultConfig {
        applicationId "com.example.hp.temp"
        minSdkVersion 21
        targetSdkVersion 27
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile 'com.Android.support:appcompat-v7:27.+'
}
57
Heli Shah

ルートのbuild.gradleファイルを見つけて、allprojectsタグの中にGoogle Mavenリポジトリを追加します。

repositories {
        mavenLocal()
        mavenCentral()
        maven {                                  // <-- Add this
            url 'https://maven.google.com/' 
            name 'Google'
        }
    } 

可変バージョンではなく特定のバージョンを使用することをお勧めします。

compile 'com.Android.support:appcompat-v7:27.0.0'

Gradle 3.0.0以降のバージョンのAndroidプラグインを使用している場合

repositories {
      mavenLocal()
      mavenCentral()
      google()        //---> Add this
} 

このようにして依存関係を注入します。

implementation 'com.Android.support:appcompat-v7:27.0.0'
112
Aryan

Android Studio 3.0以上を使用している場合プロジェクトbuild.gradleに類似したコンテンツがあることを確認してください-

buildscript {                 
    repositories {
        google()
        jcenter()
    }
    dependencies {            
        classpath 'com.Android.tools.build:gradle:3.0.1'

    }
}

allprojects {
    repositories {
        google()
        jcenter()
    }
}

注-位置は本当に重要ですgoogle()jcenter()の前に追加します

そして、の下のAndroid St​​udio 3.0からサポートライブラリ26。+プロジェクトbuild.gradleは次のようになります-

allprojects {
    repositories {
        jcenter()
        maven {
            url "https://maven.google.com"
        }
    }
}

詳細については、以下のリンクを確認してください-

1-Building Android Apps

2-ビルド依存関係の追加

3-ビルドの構成

55
D_Alpha