webdevqa.jp.net

解決に失敗しました:com.Android.support:cardview-v7:26.0.0 android

私は自分のプロジェクトにrecyclerviewを追加しようとすると、このエラーが表示されて取得し、私はAndroidのスタジオの依存関係からそれを追加 this is error appear when try to add recyclerview in Android studio

this is the compiled version ...

91
ahmed khattab

サポートライブラリのバージョン26以降では、repositoriesセクションに " https://maven.google.com "エンドポイントを含むmavenセクションが含まれるようにしてください。

何かのようなもの;

allprojects {
    repositories {
        jcenter()
        maven {
            url "https://maven.google.com"
        }
    }
}
208

これが私のやり方です。

  1. @Gabriele_Mariottiが上で示唆しているようにmaven { url "https://maven.google.com" }を追加してください。

    allprojects {
        repositories {
            jcenter()
            maven {
                url "https://maven.google.com"
            }
        }
    }
    
  2. 次にAppフォルダ内のbuild.gradleファイルに追加します。

    compileSdkVersion 26
    buildToolsVersion "25.0.3"
    defaultConfig {
        applicationId "com.xxx.yyy"
        minSdkVersion 16
        targetSdkVersion 26
    }
    
  3. それから依存関係の使用

    dependencies {
        compile 'com.Android.support:appcompat-v7:26.0.1'
        compile 'com.Android.support:design:26.0.1'
        compile 'com.google.Android.gms:play-services-maps:11.0.4'
        compile 'com.google.Android.gms:play-services-location:11.0.4'
        compile 'com.mcxiaoke.volley:library-aar:1.0.0'
        compile 'com.Android.support:cardview-v7:26.0.1'
    }
    
23
macbee

Android Studio 3.0以上を使用している場合プロジェクトbuild.gradleに類似したコンテンツがあることを確認してください-

buildscript {                 
    repositories {
        google()  // add google() before jcenter()
        jcenter()
    }
    dependencies {            
        classpath 'com.Android.tools.build:gradle:3.0.1'

    }
}

allprojects {
    repositories {
        google()  // add google() before jcenter()
        jcenter()
    }
}

そして、の下のAndroid St​​udio 3.0からサポートライブラリ26。+プロジェクトbuild.gradleは次のようになります-

allprojects {
    repositories {
        jcenter()
        maven {
            url "https://maven.google.com"
        }
    }
}

注-位置は本当に重要ですgoogle()jcenter()の前に追加します

詳細については、以下のリンクを確認してください-

1-Building Android Apps

2-ビルド依存関係の追加

3-ビルドの構成

17
D_Alpha

これをallprojects()の下のメインの全プロジェクトレベルのbuild.gradleファイルに追加するだけです。

 maven {
    url "https://maven.google.com"
 }
12

私のSDKとAndroid Studioのバージョン(3.0 beta)を更新している間、私は同じ問題に直面します。私は このチュートリアルを通してこの問題を解決しました。 これで彼らは私達に更新をするように言った

Android {
   compileSdkVersion 26
   buildToolsVersion '26.0.0'
   defaultConfig {
   targetSdkVersion 26
  }
  ...
}

dependencies {
   compile 'com.Android.support:appcompat-v7:26.0.0'
}

// REQUIRED: Google's new Maven repo is required for the latest
// support library that is compatible with Android 8.0
repositories {
   maven {
       url 'https://maven.google.com'
       // Alternative URL is 'https://dl.google.com/dl/Android/maven2/'
   }
}

お役に立てば幸いです。

10
Rahul Sharma

oneSignalが依存関係を変更した

だから私はそれをから変更しました

compile 'com.onesignal:OneSignal:[3.5.8, 3.99.99]'

compile 'com.onesignal:OneSignal:[3.5.8, 3.5.8]'

それでうまくいきます、不特定の依存関係をチェックしてください。

6

これをプロジェクトレベルのbuild.gradleファイルに追加すればうまくいきます。

allprojects {
    repositories {
        google() // this is to be added if there's something already.
        jcenter()
    }
}
4
Pei

Googleの新しいMavenリポジトリは、Android 8.0と互換性のある最新のサポートライブラリに必要です。 GoogleのMavenリポジトリを以下のように更新するだけです。

それらをあなたのビルドに追加するには、モジュールレベルのmaven.google.comファイルのMavenリポジトリにbuild.gradleを追加します。

repositories {
    maven {
        url 'https://maven.google.com'
        // Alternative URL is 'https://dl.google.com/dl/Android/maven2/'
    }
}

代わりに、build.gradleファイルを次のように更新することもできます。

    repositories {
        jcenter()
        google()
    }

その後、必要なライブラリを依存関係ブロックに追加してください。たとえば、cardviewライブラリは次のようになります。

dependencies {
    compile 'com.Android.support:cardview-v7:26.1.0'
}
3
0xAliHn

sdk 28で使用することができます

implementation 'com.Android.support:design:28.0.0'

cardViewライブラリの削除

2
amir

Googleリポジトリを追加する別の方法があります

  1. Gradle-wrapper.propertiesにgradle-4.1-rc-1-allを追加します。

    distributionUrl=https\://services.gradle.org/distributions/gradle-4.1-rc-1-all.Zip
    
  2. それからgoogle()をトップレベルのbuild.gradleに追加します

    allprojects {
      repositories {
        google()
        jcenter()
      }
    }
    
2
Liang HAN

単にbuild-versionをcompile 'com.Android.support:appcompat-v7:26.0.0'から変更してください。

'com.Android.support:appcompat-v7:26.0.0-alpha1'をコンパイルしてください。

これで問題は解決します。

2
Mayur Waghmare

SdkマネージャからあなたのAndroidサポートリポジトリを更新してください。

2
Mohammed Farhan

ここで他の解決策がうまくいかない場合は、あなたが 'オフライン'モードではない であることを確認してください。有効にすると、Androidは必要なファイルをダウンロードせず、このエラーが発生します。

enter image description here

2
Steven Spungin

ターミナルからグラドルを清掃する

./gradlew clean

それからbuild.gradleセクションでこのコードを使ってください

allprojects {
    repositories {
        jcenter()
        maven {
            url "https://maven.google.com"
        }
    }
}

付属のライブラリバージョンが利用可能であることを確認してください。あなたのチェックのために、あなたはこれを使うことができます link

1
Aslam Hossin

コンパイルしよう

 compile 'com.Android.support:cardview-v7:25.3.1'
1
Anmol
Android {
     compileSdkVersion 26
     buildToolsVersion '26.0.2'
     useLibrary 'org.Apache.http.legacy'
 defaultConfig {
    applicationId "com.test"
    minSdkVersion 15
    targetSdkVersion 26
    versionCode 1
    versionName "1.0"
    testInstrumentationRunner "Android.support.test.runner.AndroidJUnitRunner"
    multiDexEnabled true
}

これは私のために働いています

0
Pankaj Soni

これを修正する2つのステップ.. 1、インターネットに接続します。 2、きれいなプロジェクトをクリックしてください。これで修正されます:)

0
Tolani

この問題はFacebookのライブラリが原因である可能性があります。交換する

compile 'com.facebook.Android:facebook-Android-sdk:[4,5)'

によって

compile 'com.facebook.Android:facebook-Android-sdk:4.26.0'
0
Deepak Sharma

私は自分のプロジェクトをきれいにしなければなりませんでした。

ビルド - >クリーンプロジェクト

私がしなければならなかったもう一つの時間:

[ファイル] - > [プロジェクトをGradleファイルと同期]をクリックします。

0
Marc Alexander

compile 'com.Android.support:cardview-v7:25.4.0'を使う
バージョン26が必要な場合は、compile 'com.Android.support:cardview-v7:26.0.0-beta2'を使用してください。現時点ではベータ版です。

0
DeKaNszn
compile 'com.Android.support:cardview-v7:+' 

これにより、最新のバージョンが取り出され、コンパイルできるようになります。

0
Freytes
0
Dung

これを試して、

goto Android-> sdk あなたが必要とするすべての依存関係を持っていることを確認してください。そうでない場合は、それらをダウンロードしてください。それから ファイル - > Settigs - >ビルド、実行、Depoyment - > Gradle

choose デフォルトのグラドルワッパーを使う(推奨)

オフライン作業

設定を変更できるようになると、gradle buildは正常に終了します

0
Harsh

Kotlinを使用してAndroid St​​udioで新しいプロジェクトを作成すると、この問題が発生しました。最終的に私を助けた方法:

allprojects {
    repositories {
        maven {
            url "https://maven.google.com"
        }
        google()
        jcenter()
    }
}
0
Emi Raz