webdevqa.jp.net

AndroidのINSTALL_FAILED_MISSING_SHARED_LIBRARYエラー

Google APIを使用するAndroidアプリケーションを実行しようとすると、次のエラーが表示されます

[2009-07-11 11:46:43-FirstMapView]インストールエラー:INSTALL_FAILED_MISSING_SHARED_LIBRARY
[2009-07-11 11:46:43-FirstMapView]詳細については、logcatの出力を確認してください。
[2009-07-11 11:46:44-FirstMapView]打ち上げがキャンセルされました!

誰でもこのエラーの解決を手伝ってくれますか?

76
Brijesh Patel

Android向けGoogleマップでINSTALL_FAILED_MISSING_SHARED_LIBRARYエラーが発生する:

  1. GoogleマップAPIをインストールします。これは、Eclipse Windows/Android SDKおよびAVD Manager->利用可能なパッケージ->サードパーティアドオン-> Google Inc.-> Google Inc.によるGoogle API、Android AP​​I Xで実行できます。

  2. コマンドラインから新しいAVDを作成します。これは、ターゲット(Androidリストターゲット)を一覧表示してから、Android create avd -n new_avd_api_233 -t "Google Inc.:Google APIs:X"を実行することで実行できます。

  3. 次に、Eclipse Windows/Android SDKおよびAVD ManagerでAVD(Android Virtual Device)を作成します->新規...->(名前:new_avd_X、ターゲット:Google API(Google Inc.)-APIレベルX)

    IMPORTANT:Google API(Google Inc.)としてTargetを使用してAVDを作成する必要があります。作成しない場合、再度失敗します。

  4. Eclipseファイル/新規/ AndroidプロジェクトでAndroidプロジェクトを作成し、Google APIビルドターゲットを選択します。

  5. <uses-library Android:name = "com.google.Android.maps" />を<application> </ application>タグの間に追加します。

  6. プロジェクトをAndroidアプリケーションとして実行します。

エラーが続く場合、問題がある場合、それが機能する場合、このエラーは永遠にあなたの後ろにあります。

91
Mirco Mage
<uses-library
            Android:name="com.google.Android.maps"
            Android:required="false" />

必要な場合は、おそらく変更する必要があります

16
semih

Google APIエミュレーターで実行している問題を解決できます。

Google APIエミュレーターで実行するには、Android SDK&AVD Manager> Available packages> Google Reposを開き、テストする必要があるGoogle APIレベルを選択します。

それらをインストールした後、仮想デバイスとして追加して実行します。

7
samwize
  1. Eclipseを開く
  2. 後藤:

    プロジェクト>プロパティ> Android>選択:Google API Android 4.0.3

  3. アイコンをクリックします:

    Android Virtual Device Manager>編集>タブの選択ボックス> Google APIs APIsLevel15
    およびビルトインを選択:WQVGA400> AVDの編集>開始

4
Mr Douangkeo

実際のデバイスにインストールするときに、同じエラーが発生しました。不足しているライブラリをデバイスにロードするための詳細情報と解決策は、次のサイトで見つけることができます。

INSTALL_FAILED_MISSING_SHARED_LIBRARYエラーの修正

これを正しくセットアップするには、システムにコピーする必要がある2つのキーファイルがあります。

com.google.Android.maps.xml

com.google.Android.maps.jar

これらのファイルは、次のGoogleアプリパックのいずれかにあります。

http://Android.d3xt3...0120-signed.Zip

http://goo-inside.me...0120-signed.Zip

http://Android.local...0120-signed.Zip

これらのリンクは機能しなくなりましたが、Google Maps API v1を使用している場合、Android sdkでファイルを見つけることができます

これらのファイルを解凍したら、次のようにファイルをシステムにコピーします。

adb remount

adb Push system/etc/permissions/com.google.Android.maps.xml /system/etc/permissions

adb Push system/framework/com.google.Android.maps.jar /system/framework

adb reboot
2
todd

私はバージョン2.2にアプリを開発していますが、APIバージョンは8日目に同じエラーが発生し、エラーはGoogleマップAPIであると教えてくれました、私たちがしたことは私のプロジェクトAPI 2.2とAPI。

これでうまくいき、必要なライブラリAPIが見つかりました。

1
José De la O

この問題を解決する別の方法は、必要な不足しているライブラリをインストールすることです。

ライブラリをダウンロードして、インストール方法を確認できます here

0
Sergeenho

これは、エミュレータでアプリケーションを実行しようとしたときに発生します。エミュレータには共有Googleマップライブラリがありません。

0
kreker

これらのソリューションを試すとき。
解決策:
新しい仮想デバイスを作成し(Google API(Google Inc)-APIレベル15を選択してAndroid 4.0.3-APILevel 15を置換)、再度実行します。解決しました。

デバイスにGoogle APIがないためだと思います〜

IDE:Android-studio OS:ubuntu 12.04

0
Alps1992