webdevqa.jp.net

Androidエミュレータがまったく起動しない

今日、私はEclipse内からAndroid=アプリを起動しようとしましたが、何も起こりませんでした。昨日はすべてうまくいきました。adbkill-server、adb-start-serverなどのいくつかのことを試しました。ある時点で、 「ユーザーデータイメージが別のエミュレーターで使用されています」というエラーが表示されたため、avdイメージの.lockフォルダーを削除しようとしましたが、役に立ちませんでした。

私は新しいavdを作成しましたが、エミュレーターはこのイメージでさえ開始しません。私はそれから始めようとしました

emulator -avd avdname

->なし。エラーなし。 emulator.exeはTaskmanagerで実行されています。

Windows 7 Android SDKツール、リビジョン7

pdate:エラーが発生したタイミングがわかりました

エミュレーター:エラー:ユーザー・データ・イメージは別のエミュレーターによって使用されています。中止

それは、emulator.exeがすでにTaksmanagerでぶら下がっている後で、アプリケーションをもう一度実行しようとしたときです。

更新: 20分間待機しました。 emulator.exeはちょうど00:00:00 CPU時間でそこに座っています。

16
boston

「昨日はすべてうまくいった」と言うときは、最初に何が変わったのかを自問する必要があります。エミュレータを妨害する可能性のあるものをインストールしましたか?

個人的には、Android SDKの新しいコピーをダウンロードし、現在インストールされているバージョンへの参照をPATHから削除して、新しいバージョンを追加します。

私はそれがあなたの問題を解決するだろうと考えるべきです(少なくとも、AVDを開始できることです)。

もう1つ注意すべき点は、AVDの起動が非常に遅くなることがあります。私のマシンの1つでは、起動に最大7分かかりました。 emulator -avd avdname、それからコーヒーを作りに行き、戻ったときにそれが機能するかどうかを確認します:)

幸運を!

6
Jimmy

MacOS Sierra 10.12.4およびAndroid Studio 2.3.1。

私はすべてを試し、アンインストールして再インストールしましたAndroid Studio、コンピューターを再起動し、.Androidフォルダーをクリアして新しいavdイメージを作成しました。何の助けにもなりませんでしたが、最後にこのコマンドを実行しました(詳細は Androidドキュメント ):

emulator -partition-size 512 -avd avd_name 

そして私はこのエラーを受け取りました:

emulator: WARNING: encryption is off
Hax is enabled
Hax ram_size 0x40000000
HAX is working and emulator runs in fast virt mode.
Failed to sync vcpu reg
Failed to sync vcpu reg
Failed to sync vcpu reg
Failed to sync HAX vcpu contextInternal error: Initial hax sync failed 

それで、私の解決策はDocker-Machineを停止することであり、魔法のように問題が解決したことを発見しました。

13
carolnogueira

さて、私は同じ問題に遭遇しました。アンインストール、再インストール、DSKツール、およびEclipseを個別に数時間費やしましたが、バンドルもめちゃくちゃで、VMは単に起動していませんでした。その前に、私は仮想マシンを作成し、1日間うまくいきました。私がしたことは、単純にC:\ Users\USER \フォルダーから.Androidフォルダーを消去したおよび新しい仮想マシンを作成しました。それ以来、問題なく動作しました。

6
user1908637

Android Studioのアップグレード後にこれが発行されました。

  • AVDマネージャーを開く
  • 画像のコンテキストメニューを開きます。 (右クリック)
  • 選択今すぐコールドブート

ScreenShot

5
Steven Spungin

または:ウィンドウ-> AVDマネージャー->仮想デバイスを選択->編集->スナップショット(無効になっていることを確認)-> AVDを編集(まだ機能しない場合は、再試行して、AVDマネージャーから直接エミュレーターを起動してみてください->開始)。

4
user1207965

ハードウェアの代わりにソフトウェアグラフィックサポートを有効にするとうまくいきました。

3
stream28

「adb-serverを終了してadb-serverを開始する」アプローチを試しましたが、うまくいきませんでした。 AVDを削除し、同じ構成で新しいAVDを作成しました。ほとんど30秒かかりませんでした。

2
RohitD

Linuxの場合:

ホームディレクトリに移動します

$cd ~/.Android/avd 
$ls
$NexusS.avd/  NexusS.ini
$rm *.ini
$rm -rf NexusS.avd/      (don't use Sudo and use TAB to bring in Nexus avd directory)

Eclipseを再起動して新しいAVDを作成する

Windowsユーザーは、ユーザーディレクトリ(C:/Users/FooBar/Android/avd)でも同じことを行う必要があります。

2
HimalayanCoder

私は同様の問題に直面し、うまくいった何かは、Android仮想デバイスマネージャーを実行し、AVDを起動するときに、最後のスナップショットからチェック開始を削除します。

私はこれを行い、それは私のために働いた。

1
Ray

まず、SDKの名前を取得します

emulator -list-avds

次に、carolnogueiraが推奨したように、コマンドemulator -partition-size 512 -avd avd_nameを実行します

私にとってはそれは十分なディスク容量ではなく、いくつかの不要なファイルをクリアした後、それはうまくいきました

1
Ali Özyer

ほとんどの場合、ユーザーの.Androidフォルダーを削除することには意味がありますが、

信じられないほど、これらのタイプの問題のいくつかは、ディスプレイドライバーが原因である可能性があります。ドライバーを専用グラフィックスに切り替えるか、メインドライバーを再インストールしてください....

1
Binod Rokka

AVDの起動に問題を引き起こす新しいデバイスを作成した可能性があります。そのデバイスを削除すると、すべて正常に動作します。

0
Shivam Dawar

Windows 10にアップデートした後、私のグラフィックスドライバーが奇妙に動作し始めました。

Disable the "Use Host GPU"

エミュレーターが起動できるようにしました

0
Ashitakalax

ディスクに十分なスペースがないため、同様の問題に直面しました。だから私は不要なものを削除し、それは私のために働いた。

0
Asbar Ali

私は次のようにしてそれを機能させました:

  1. リスト内のエミュレータを右クリックします。
  2. 選択する Wipe Data
0
Henning Hall

私にとっての問題は、ルートからAndroid studioをターミナルから実行したことです。

通常、アプリケーションフォルダからスタジオを開き、新しいAVD(ルートAVDが存在しない)を作成すると、AVDが起動しました。

0