webdevqa.jp.net

Androidバージョン0.5.0へのStudio Gradleの問題-0.8から0.9へのGradle移行-またAndroid Studioの0.8.1へのアップグレード

アップグレード後のメッセージの状態:

Failed to refresh Gradle project 'XXX'
The project is using an unsupported version of the Android Gradle plug-in (0.8.3).
Version 0.9.0 introduced incompatible changes in the build language.
Please read the migration guide to learn how to update your project.

Android Studioからバージョン> = 0.8.0へのアップグレード後の同じ種類の問題

27
Cedric Simon

修正するには、プロジェクトルートでbuild.gradleというファイルを開き、そこのgradleバージョンを0.9。+に変更します。

buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.Android.tools.build:gradle:0.9.+'
    }
}

プロジェクトごとに繰り返される;(

Unable to load class 'org.gradle.api.artifacts.result.ResolvedComponentResult」のようなメッセージが表示された場合。

project_folder/gradle/wrapperディレクトリに移動し、Unable to load class 'org.gradle.api.artifacts.result.ResolvedComponentResult'.ファイルを編集してdistributionUrlを変更します

distributionUrl=http\://services.gradle.org/distributions/gradle-1.10-all.Zip

バージョン0.8.1へのアップグレード後(SDKフォルダーの完全ダウンロードとコピー)、IDE(「Fix it」リンクを数回使用して:S )、および以下のようにプロジェクトフォルダーのgradleファイルの「Android」セクションを19.0から19.1に変更します。buildscript {リポジトリ{mavenCentral()}依存関係{classpath 'com.Android.tools.build:gradle:0.12.+' }}プラグインの適用:「Android」

repositories {
    mavenCentral()
}

Android {
    compileSdkVersion 19
    buildToolsVersion '19.1.0'

    defaultConfig {
        minSdkVersion 7
        targetSdkVersion 19
    }
}

dependencies {
    compile 'com.Android.support:appcompat-v7:19.1.+'
    compile 'com.Android.support:support-v4:19.1.0'
}
42
Cedric Simon

Android Studio 0.5.0にはgradle-plugin 0.9.0が必要です

Gradle-plugin0.9.0は、Gradle 1.10またはGradle 1.11で動作します

Cedricの提案に従ってbuild.gradleスクリプトを変更します。

gradle-pluginとgradleバージョンの間には関係があります。たとえば

2015/11/27に更新

com.Android.tools.build:gradle:0.6.+   -> gradle 1.8
com.Android.tools.build:gradle:0.7.+   -> gradle 1.9
com.Android.tools.build:gradle:0.8.+   -> gradle 1.9/1.10
com.Android.tools.build:gradle:0.9.+   -> gradle 1.10/1.11
com.Android.tools.build:gradle:0.10.+  -> gradle 1.10/1.11/1.12
com.Android.tools.build:gradle:0.11.+  -> gradle 1.10/1.11/1.12
com.Android.tools.build:gradle:0.12.+  -> gradle 1.10/1.11/1.12
com.Android.tools.build:gradle:0.13.+  -> gradle 2.1
com.Android.tools.build:gradle:0.14.+  -> gradle 2.1
com.Android.tools.build:gradle:1.0.+   -> gradle 2.2.1-2.3
com.Android.tools.build:gradle:1.1.+   -> gradle 2.2.1-2.3
com.Android.tools.build:gradle:1.2.+   -> gradle 2.2.1+
com.Android.tools.build:gradle:1.3.+   -> gradle 2.2.1+
com.Android.tools.build:gradle:1.3.+   -> gradle 2.2.1+
com.Android.tools.build:gradle:1.5.+   -> gradle 2.2.1+
com.Android.tools.build:gradle:2.0.+   -> gradle 2.10.0+

プロジェクトで使用されているgradleバージョンは、ファイルgradle/wrapper/gradle-wrapper.properties

また、gradle-pluginとIDEバージョン。

Android Studio 0.3.x  -> gradle-plugin 0.6
Android Studio 0.4.x  -> gradle-plugin 0.7
Android Studio 0.4.3+ -> gradle-plugin 0.8
Android Studio 0.5.x  -> gradle-plugin 0.9
Android Studio 0.5.8  -> gradle-plugin 0.9.+ or 0.10.+
Android Studio 0.5.9  -> gradle-plugin 0.9.+ or 0.10.4+
Android Studio 0.6.x  -> gradle-plugin 0.11.+
Android Studio 0.8.x  -> gradle-plugin 0.12.+
Android Studio 0.8.11+  -> gradle-plugin 0.13.+ / gradle-plugin 0.12.+
Android Studio 0.9.x  -> gradle-plugin 0.14.+
Android Studio 1.0.0  -> gradle-plugin 1.0.0
Android Studio 1.1.x  -> gradle-plugin 1.0.0/ 1.1.x / 1.2.x
Android Studio 1.2.x  -> gradle-plugin 1.0.0/ 1.1.x / 1.2.x
Android Studio 1.3.x  -> gradle-plugin 1.0.0/ 1.1.x / 1.2.x / 1.3.x 
Android Studio 1.4.x  -> gradle-plugin 1.0.0/ 1.1.x / 1.2.x / 1.3.x 
Android Studio 1.5.x  -> gradle-plugin 1.0.0/ 1.1.x / 1.2.x / 1.3.x / 1.5.x
Android Studio 2.0.x  -> gradle-plugin 2.0.0

 Also gradle 1.12 requires Android Studio 0.5.8+

更新されたニュースについては、次のリンクを確認できます。 http://tools.Android.com/recent
Gradleプラグインに関する最新のドキュメントについては、 こちらで確認してください

プラグインのバージョンを変更する場合は、互換性を確認してから、プロジェクトをgradleファイルと同期します。必要に応じて、新しいプラグインのバージョンがダウンロードされます。

61

私は同じエラーがありましたが、すでに持っていました

classpath 'com.Android.tools.build:gradle:0.9.+'

セドリック・サイモンが示唆したように、このように設定します。 mattblangのコメントのおかげで、0.9.0に変更して更新しました

更新ボタンがどこにあるかわからない人のために、以下を見てください:

enter image description here

その後、0.9。+に戻して再度更新するとどうなるかを試しましたが、それでも動作します。

だから、更新ボタンを押すだけで十分だと思う

4
lucidbrot

私は同じ問題に直面しましたgradleバージョン1.0.0への移行..この解決策は私を助け、日付を保存します..

プラグインとGradleのバージョン番号を更新

Android Gradleプラグインのバージョンは、通常、プロジェクトの最上位build.gradleファイルにリストされており、次のように更新されました。

私はバージョン0.8を持っていると考えてみましょう。私のbuild.gradle(プロジェクトルートフォルダ/build.gradle)ショーを表示します

依存関係{classpath 'com.Android.tools.build:gradle:0.8.+'}

古いバージョン(0.8)を削除し、次のように新しいバージョン1.0.0を追加します

依存関係{classpath 'com.Android.tools.build:gradle:1.0.0'}

また、gradle/wrapper/gradle-wrapper.propertiesも変更します。

古いdistributionUrlを削除し、新しいURLを追加します

distributionUrl = http://services.gradle.org/distributions/gradle-2.2.1-all.Zip

プロジェクトroot/app/build.gradleのrunProguardを変更します

前:

buildTypes {release {runProguard true proguardFiles getDefaultProguardFile( 'proguard-Android.txt')、 'proguard-rules.pro'}}

AFTER:

buildTypes {release {minifyEnabled true proguardFiles getDefaultProguardFile( 'proguard-Android.txt')、 'proguard-rules.pro'}}

詳細: gradleプロジェクトの移行(ここをクリック)

2
AnanThDev

最も単純なAndroidプロジェクトには、次のbuild.gradleがあります。

buildscript {
    repositories {
        mavenCentral()
    }

    dependencies {
        classpath 'com.Android.tools.build:gradle:0.9.0'
    }
}

apply plugin: 'Android'

Android {
    compileSdkVersion 19
    buildToolsVersion "19.0.0"
}

これには3つの主要な領域がありますAndroidビルドファイル:

new-build-systemユーザーガイド

0
codercat

Android Studio 1.0にアップデートしたとき、1.0.0バージョンのgradleを使用するにはアップデートする必要があることがわかりました。

持っていた

  dependencies {
        classpath 'com.Android.tools.build:gradle:1.0.0-rc2'

「-rc2」を削除するように変更しました

  dependencies {
        classpath 'com.Android.tools.build:gradle:1.0.0'
0
GR Envoy

Android Studioバージョン1.0.2 IDEバージョンとビルドバージョンの間の密結合のアイデアは悪いです。

Android Studio 1.0.2。 Graldeプラグイン1.0。+ gradle.properties、配布URL = http://services.gradle.org/distributions/gradle-2.2.1-bin.Zip

0
user827096