webdevqa.jp.net

Androidビルドツール19.1.0にアップデートした後のStudio

Androidビルドツールのバージョンを19.1.0にアップグレードしたところ、次のようになりました。

サポートされていないメソッド:Dependencies.getJars()。接続するGradleのバージョンは、その方法をサポートしていません。この問題を解決するには、接続しているGradleのターゲットバージョンを変更/アップグレードします。または、この例外を無視して、モデルから他の情報を読み取ることもできます。サポートされていないメソッド:Dependencies.getJars()。

すべてのライブラリと依存関係を検索しましたが、すべて19.1.0に設定されています

何が足りないのですか?

15
Ilya Gazman

Android Gradleプラグインがリリースされました(6/6/14)のバージョン0.11)。build.gradle設定を「0.10。+」に変更します。

classpath 'com.Android.tools.build:gradle:0.10.+'

注:これは一時的な解決策と見なされます更新できるようになるまでAndroid StudioとAndroid SDK(特にビルドツール) 。

17
Austin Hanson

問題を解決したAndroid Studioを更新しました。

3
Prakash

このエラーはIntelliJIDEAでも発生します。そして私はIntelliJIDEのいくつかのバージョンを試します

ビルドツール19.1.0およびgradleプラグイン0.11

  • Android Studio 0.8.1:ビルドの成功
  • IntelliJ IDEA 13.1:このエラーはIU-135.760でも発生します
  • IntelliJ IDEA 13.1 EAP:このエラーはIU-135.1019でも発生します
  • IntelliJ IDEA 14 EAP:IU-138.777でビルドの成功

この修正は14EAPのリリースノートにはありませんが、14EAPで修正されているようです。

2
Yuki Yoshida