webdevqa.jp.net

Android Studioの古いKotlin Runtimeの警告

最新のKotlinプラグインをダウンロードしてインストールした後、私は 古いKotlin Runtimeを持っています / Android Studioからの警告で、

'kotlin-stdlib-1.1.2'ライブラリーのKotlinランタイムのバージョンは1.1.2ですが、プラグインのバージョンは1.1.2-release-Studio2.3-3です。互換性の問題を回避するためにランタイムライブラリを更新する必要があります。

Update Runtime ボタンをクリックしようとしましたが、別のメッセージが表示されます。

Gradleプロジェクトの自動ライブラリバージョンアップデートは現在サポートされていません。手動でbuild.gradleを更新してください。

この問題を解決するには?

146
Arsenius

プロジェクトレベルのbuild.gradleファイルでKotlinのバージョンを更新できます。通常の方法で設定した場合は、上部に次の行があります。

ext.kotlin_version = '1.1.2'

自分のプラグインと一致するバージョンにアップグレードするには、単にこの行を次のように変更します。

ext.kotlin_version = '1.1.2-3'

編集 (下記の質問に回答する場合):

エラーはあなたがあなたのバージョンをアップグレードする必要があることをあなたに告げます、質問はあなたが言う代わりに1.1.2-3を入れなければならないことをどこに見つけるべきかです、例えば、1.1.2-release-Studio2.3-3

Kotlinの最新版を見つけるための最善の方法は、 kotlinlang.org に行き、 "Latest version"を探すことです。フロントページのすぐそこにあるべきです。

このようにバージョン番号が重要でない場合に行うべきもう1つのことは、バージョンがホストされているリポジトリーを確認することです。 Androidの場合は、おそらくjcenterから入手することになるでしょう。 repositoryページ には、利用可能なすべてのバージョンがリストされています。

ファイルが実際にホストされているjcenterのraw mavenリポジトリを here で参照するか、 mvnrepository または mavencentral (後者のrawバージョン のいずれかでKotlinを検索することもできます。ここに )。

134
zsmb13

(Project: [projectName])build.gradleファイルでこれを見つけます:ext.kotlin_version = 'x.x.x'そしてx.x.xをあなたのKotlinプラグインの現在のバージョンで置き換えてください。 enter image description here

Kotlinプラグインの現在のバージョンがどれであるかを確認するために:

  1. [ツール] - > [Kotlin] - > [Confugure Kotlin Plugin Updates]に移動します。

  2. [もう一度確認]をクリックします。しばらくすると、Kotlinプラグインのバージョンが表示されます。 (最新でない場合は、Kotlinプラグインは更新されます。) enter image description here enter image description here

N.B .: また、(Module: app)build.gradleファイルを調べて、使用しないようにしてください。

compile "org.jetbrains.kotlin:kotlin-stdlib-jre7:1.2.21" 

しかし

compile 'org.jetbrains.kotlin:kotlin-stdlib-jdk7:1.2.40'

"... jre7 ..." - > "... jdk7 ..."の違いに注意してください。また、 "1.2.40"を現在のKotlinプラグインのバージョンに置き換えてください。

126
Ivo Stoyanov

それは(Android Studio 3.0.1上で)文句を言いました...おそらく参照ライブラリの依存関係のために:

'org.jetbrains.kotlin:kotlin-stdlib:[email protected]'ライブラリーのKotlinランタイムのバージョンは1.1.3ですが、プラグインのバージョンは1.1.51-release-Studio3.0-1です。

それから私はそれが要求したバージョンに対して、モジュールレベルで構築することを強制しました:build.gradle

configurations.all() {
    resolutionStrategy.force 'org.jetbrains.kotlin:kotlin-stdlib:1.1.51'
}

結果は次のとおりです。

./gradlew app:dependencies | grep kotlin
Download https://jcenter.bintray.com/org/jetbrains/kotlin/kotlin-stdlib/1.1.51/kotlin-stdlib-1.1.51.pom
 |    |    +--- org.jetbrains.kotlin:kotlin-stdlib:1.1.3 -> 1.1.51
 ...
11
Martin Zeitler

更新したい部分が2つあります。

  1. プロジェクトのkotlinランタイム
  2. コトリンプラグイン

Ivo Stoyanovによる答えは、Androidのスタジオメニューを使ってこれを行う方法を示しています。私がエラーメッセージを受け取って、これ(kotlinプラグインをアップデートする)だけを試みたとき、それはまだkotlinランタイムについて不平を言いました。他の回答のいくつかが示すように、プロジェクトごとにext.kotlin_versionの行をプロジェクトビルドグレードに追加することで、プロジェクトごとにプロジェクトを更新できます。しかし、そのためにはkotlinのランタイムバージョンを知る必要があります。別の方法として、以下に示すように、Androidスタジオで利用可能なバージョンが表示され、最新のバージョンを選択できるというボーナスを使用して、メニューからも実行できます。

step 1

step 2

step 3

step 4

そして、Androidスタジオはあなたのプロジェクトビルドgradleに適切な行を追加します。

6
auspicious99

ext.kotlin_versionを '1.1.2-4'からext.kotlin_version = '1.1.2-5'に変更すると問題が解決しました

3
Mauve Guava

kotlinの最新バージョン1.2.21でこれを使用してプロジェクトの合成を行ってください。

buildscript {
ext.kotlin_version = '1.2.41'
repositories {
    google()
    jcenter()
}
dependencies {
    classpath 'com.Android.tools.build:gradle:3.1.2'
    classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"

    // NOTE: Do not place your application dependencies here; they belong
    // in the individual module build.gradle files
}
}
2
abhilasha Yadav

この2行のコードを検索

ext.kotlin_version = '1.3.11'

クラスパス "org.jetbrains.kotlin:kotlin-gradle-plugin:$ kotlin_version"

$ kotlin_version を実際の値に置き換えます(ここでは1.3.11です)。

クラスパス "org.jetbrains.kotlin:kotlin-gradle-plugin:1.3.11"

この後あなたのIDEは自動的にあなたに最新版を提案します

幸せなコーディング:)

1
muhammad awais

2019年3月8日 現在のkotlinのバージョンは'1.3.21'です

build.gradleの下

buildscript {
   ext.kotlin_version = '1.3.21'
   repositories {
      google()
      jcenter()
   }
   dependencies {
      classpath 'com.Android.tools.build:gradle:3.3.2'
      classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"

    // NOTE: Do not place your application dependencies here; they belong
    // in the individual module build.gradle files
}

乾杯

1
ralphgabb

この問題は、Android StudioからポップアップされたKotlinプラグインのバージョンを更新すると発生しますが、Android Studioの現在のバージョンでは、 プロジェクトレベルのBuild.gradle にあるkotlin gradleプラグインを動的に変更できません。ファイル。

dependencies {
     classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:1.2.10"
}

この問題を解決するには?

だから、あなたは手動でこのバージョンを変更する必要があります、あなたはそれを見つけることができます ここ

1
TapanHP
buildscript {
    ext.kotlin_version = '1.2.50'
    repositories {
        google()
        jcenter()
    }
    dependencies {
        classpath 'com.Android.tools.build:gradle:3.1.2'
        classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}
1
abhilasha Yadav

私はあなたがあなたのプロジェクトのGradleファイルに入り、kotlin-gradle-pluginのバージョンを$kotlin_versionに設定するなら、あなたがどのバージョンをあなたに知らせるかを私はAndroid StudioとIDEAでこの問題に数回遭遇しました。 ext.kotlin_versionをに設定する必要があります。

buildscript {
ext.kotlin_version = '1.2.40'
repositories {
    google()
    jcenter()
}
dependencies {
    classpath 'com.Android.tools.build:gradle:3.1.2'
    classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"

    // NOTE: Do not place your application dependencies here; they belong
    // in the individual module build.gradle files
}
}

enter image description here

0
Sal Aldana

Kotlin最新バージョン:

buildscript {
    ext.kotlin_version = '1.2.41'

    repositories {
        google()
        jcenter()
    }
    dependencies {
        classpath 'com.Android.tools.build:gradle:3.0.1'
        classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"
        classpath 'com.github.dcendents:Android-maven-gradle-plugin:1.5'
        classpath 'com.google.gms:google-services:1.5.0-beta2'


        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}
0
abhilasha Yadav

ちょっと面倒ですが、スタジオはそのように動作することがあります。以下の手順で問題を解決できます。

に行く

設定 - >ビルド、実行、開発 - > Gradle - >デフォルトのグラドルラッパーを使用(推奨)

これをUse localに変更し、Use defaultに戻します。 Studioは設定ウィンドウを閉じた後にgradleの更新について尋ねます。

0
Vishal Pawar

私のAndroidスタジオを3.0.1から3.2.1にアップデートした後、同じ問題に直面していました。これを使用した後、私の問題は解決しました。

buildscript {
ext.kotlin_version = '1.2.51'
repositories {
    google()
    jcenter()
    mavenCentral()
    maven { url "https://jitpack.io" }
}
dependencies {
    classpath 'com.Android.tools.build:gradle:3.2.1'
    classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"

    // NOTE: Do not place your application dependencies here; they belong
    // in the individual module build.gradle files
}

}

0
Narendra.kr