webdevqa.jp.net

Android Studioプラグインが古すぎる

私はうまく同期していましたが、突然Android Studioからデバイスでテストを実行しようとすると、エラーが発生し始めました:

Error:(1, 0) Plugin is too old, please update to a more recent version, or set Android_DAILY_OVERRIDE environment variable ...

私は周りを見回しましたが、最新バージョンが2.10であることがgradle Webサイトからわかりました。それを運なしで依存関係に追加しようとしました。次のようなさまざまなエラーを含むさまざまなバージョン番号を試しました。

Could not find com.Android.tools.build:gradle:2.1
Searched in the following locations ...

私が行ったすべての検索から、それは明らかに間違ったバージョンのgradleであることを理解しています-しかし、IS私が使用しなければならない現在のバージョンラベルと、それが私のmachine?私はいつもAndroid Studioを更新しました。

だから私は現在build.gradleにあります:

    dependencies {
    classpath 'com.Android.tools.build:gradle:2.0.0-alpha1'
}
17
yoyoma

更新(2017年3月28日):

2.4.0-alpha3は最新リリースです

classpath 'com.Android.tools.build:gradle:2.4.0-alpha3'

https://bintray.com/Android/android-tools/com.Android.tools.build.gradle/view で最新のgradleバージョンを確認してください。


2.0.0-alpha1はCanaryチャンネルにあり、明らかにこれらのリリースには有効期限があります。 2.0.0-alpha3が最新リリースです。切り替える

classpath 'com.Android.tools.build:gradle:2.0.0-alpha3'

そして、あなたは元気でなければなりません。 http://tools.Android.com/tech-docs/new-build-system をチェックして最新リリースを確認してください。

Dexエラーが発生する場合があります。ビルド>クリーンプロジェクトを1回実行して、機能させる必要がありました。

30

これで既存の構成を変更します

  1. プロジェクトビューで、Gradle Scriptsを選択します
  2. gradle-wrapper.propertiesを開きます
  3. この行を変更します。

     distributionUrl=https\://services.gradle.org/distributions/gradle-2.4-all.Zip
    

     distributionUrl=https\://services.gradle.org/distributions/gradle-2.8-all.Zip
  1. Build.gradleに移動します(プロジェクト:your_app_name)
  2. この行を変更

     classpath 'com.Android.tools.build:gradle:2.0.0-alpha1'
    

これに

     classpath 'com.Android.tools.build:gradle:1.5.0'
  1. Sync Nowをクリックしないでください
  2. メニューからFile -> Invalidate Caches/Restart...を選択します
  3. 最初のオプションを選択:Invalidate and Restart

Android Studioが再起動します。この後、正常に動作するはずです

お役に立てば幸いです

18
piotrek1543

com.Android.tools.build:gradle:2.0.0-alpha3は古いものです

 com.Android.tools.build:gradle:2.0.0-beta2
7
Asthme

プラグインの解決に問題がある場合。 repositoriesbuildscriptjcenter()(Jcenter)が含まれていることを確認してください。 GoogleはプラグインをmavenCentral()(Maven Central)に公開しません。

buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.Android.tools.build:gradle:2.0.0-alpha3'
    }
}

他の人が言及したように、最新のATMは2.0.0-alpha3しかし、それはいつでも変わる可能性があります。利用可能な最新バージョンの真実のソースは次のとおりです。 https://jcenter.bintray.com/com/Android/tools/build/gradle

実際のエラーについては、ここで最高の答えはリンクです。非リリースプラグインのドキュメントに記載されていない機能であるTLDRは、有効期限が切れており、更新する必要があります。 https://stackoverflow.com/a/31293869/873237

4
JBirdVegas

次の手順を実行して解決しました。

1-開くgradle-wrapper.properties

交換

distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.Zip

distributionUrl=https\://services.gradle.org/distributions/gradle-2.14.1-all.Zip

2-build.gradleを開きます(プロジェクト:app_name)

交換

classpath 'com.Android.tools.build:gradle:2.2.0-alpha3'

classpath 'com.Android.tools.build:gradle:2.2.1'
0
Faisal Ahsan