webdevqa.jp.net

Android Studio Gradle:エラー:タスク ':app:processDebugGoogleServices'の実行に失敗しました。 >パッケージに一致するクライアントが見つかりません

Googleが提供する here の例に従って、Google Playサービスの依存関係を8.4.0にアップグレードしようとしていますが、次のようなエラーが表示されます( 'com.example.exampleapp'は私のアプリパッケージ名の代わりです)。 :

Error:Execution failed for task ':app:processDebugGoogleServices'.
> No matching client found for package name 'com.example.exampleapp'

プロジェクトbuild.gradle:

buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.Android.tools.build:gradle:2.0.0-alpha3'
        classpath 'com.google.gms:google-services:2.0.0-alpha3'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        jcenter()
    }
}

モジュールapp/build.gradle:

apply plugin: 'com.Android.application'

Android {
    compileSdkVersion 23
    buildToolsVersion "23.0.2"

    defaultConfig {
        applicationId "com.example.exampleapp"
        minSdkVersion 19
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    }
    useLibrary 'org.Apache.http.legacy'

    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(include: ['*.jar'], dir: 'libs')
    testCompile 'junit:junit:4.12'
    compile 'com.Android.support:appcompat-v7:23.1.1'
    compile 'com.Android.support:cardview-v7:23.1.1'
    compile 'com.Android.support:design:23.1.1'
    compile 'com.google.Android.exoplayer:exoplayer:r1.5.2'
    compile 'com.google.Android.gms:play-services-auth:8.4.0'
    compile 'com.google.Android.gms:play-services-maps:8.4.0'
    compile('com.mapbox.mapboxsdk:mapbox-Android-sdk:[email protected]') {
        transitive = true
    }
    compile files('libs/commons-lang3-3.3.2.jar')
}

apply plugin: 'com.google.gms.google-services'

gradle-wrapper.properties:

#Fri Jan 01 08:23:56 CST 2016
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-2.8-all.Zip

なぜgradleが自分のアプリパッケージ名を認識できないのかというアイデアはありますか?


編集:

さて、今回は違うエラーが出ます。

Shawn Thyeが提供したリンクに基づいて、これをapp/build.gradleの一番下に追加しました。

apply plugin: 'com.google.gms.google-services'

そして私が以前にリストしたものを他のすべてを残して私はこのエラーを得ました:

Information:Gradle tasks [clean, :app:generateDebugSources, :app:generateDebugAndroidTestSources, :app:compileDebugSources, :app:compileDebugAndroidTestSources]
/Users/user/Documents/AndroidStudio/ExampleApp/app/build.gradle
Error:(1, 1) A problem occurred evaluating project ':app'.
> Failed to apply plugin [id 'com.Android.application']
   > Gradle version 2.10 is required. Current version is 2.8. If using the gradle wrapper, try editing the distributionUrl in /Users/user/Documents/AndroidStudio/ExampleApp/gradle/wrapper/gradle-wrapper.properties to gradle-2.10-all.Zip
Information:BUILD FAILED
Information:Total time: 0.921 secs
Information:1 error
Information:0 warnings
Information:See complete output in console

そしてGradleコンソール

Executing tasks: [clean, :app:generateDebugSources, :app:generateDebugAndroidTestSources]

Configuration on demand is an incubating feature.

FAILURE: Build failed with an exception.

* Where:
Build file '/Users/user/Documents/AndroidStudio/ExampleApp/app/build.gradle' line: 1

* What went wrong:
A problem occurred evaluating project ':app'.
> Failed to apply plugin [id 'com.Android.application']
   > Gradle version 2.10 is required. Current version is 2.8. If using the gradle wrapper, try editing the distributionUrl in /Users/user/Documents/AndroidStudio/ExampleApp/gradle/wrapper/gradle-wrapper.properties to gradle-2.10-all.Zip

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 1.211 secs

それで、私は「gradle-2.10-all」に要求されるようにgradle-wrapper.propertiesを変更して、このエラーを得ました:

Information:Gradle tasks [clean, :app:generateDebugSources, :app:generateDebugAndroidTestSources]
google-services plugin could not detect any version for com.google.Android.gms, default version: 8.3.0 will be used.
please apply google-services plugin at the bottom of the build file.
:clean
:app:clean
:app:preBuild UP-TO-DATE
:app:preDebugBuild UP-TO-DATE
:app:checkDebugManifest
:app:preReleaseBuild UP-TO-DATE
:app:prepareComAndroidSupportAppcompatV72311Library
:app:prepareComAndroidSupportCardviewV72311Library
:app:prepareComAndroidSupportDesign2311Library
:app:prepareComAndroidSupportGridlayoutV72311Library
:app:prepareComAndroidSupportRecyclerviewV72311Library
:app:prepareComAndroidSupportSupportV42311Library
:app:prepareComDigitsSdkAndroidDigits192Library
:app:prepareComFacebookAndroidFacebookAndroidSdk470Library
:app:prepareComGoogleAndroidExoplayerExoplayerR152Library
:app:prepareComGoogleAndroidGmsPlayServicesAuth840Library
:app:prepareComGoogleAndroidGmsPlayServicesBase840Library
:app:prepareComGoogleAndroidGmsPlayServicesBasement840Library
:app:prepareComGoogleAndroidGmsPlayServicesMaps840Library
:app:prepareComGoogleAndroidGmsPlayServicesMeasurement830Library
:app:prepareComMapboxMapboxsdkMapboxAndroidSdk230Library
:app:prepareComTwitterSdkAndroidTweetComposer102Library
:app:prepareComTwitterSdkAndroidTweetUi180Library
:app:prepareComTwitterSdkAndroidTwitter1110Library
:app:prepareComTwitterSdkAndroidTwitterCore162Library
:app:prepareIoFabricSdkAndroidFabric1310Library
:app:prepareDebugDependencies
:app:compileDebugAidl
:app:compileDebugRenderscript
:app:generateDebugBuildConfig
:app:generateDebugAssets UP-TO-DATE
:app:mergeDebugAssets
:app:processDebugManifest
:app:fabricGenerateResourcesDebug
:app:generateDebugResValues UP-TO-DATE
:app:processDebugGoogleServices
Found com.google.Android.gms:play-services-auth:8.4.0, but version 8.3.0 is needed for the google-services plugin.
Found com.google.Android.gms:play-services-maps:8.4.0, but version 8.3.0 is needed for the google-services plugin.
:app:processDebugGoogleServices FAILED
Error:Execution failed for task ':app:processDebugGoogleServices'.
> Please fix the version conflict either by updating the version of the google-services plugin (information about the latest version is available at https://bintray.com/Android/android-tools/com.google.gms.google-services/) or updating the version of com.google.Android.gms to 8.3.0.
Information:BUILD FAILED
Information:Total time: 5.724 secs
Information:1 error
Information:0 warnings
Information:See complete output in console

そしてGradleコンソール:

Executing tasks: [clean, :app:generateDebugSources, :app:generateDebugAndroidTestSources]

Configuration on demand is an incubating feature.
google-services plugin could not detect any version for com.google.Android.gms, default version: 8.3.0 will be used.
please apply google-services plugin at the bottom of the build file.
Incremental Java compilation is an incubating feature.
:clean
:app:clean
:app:preBuild UP-TO-DATE
:app:preDebugBuild UP-TO-DATE
:app:checkDebugManifest
:app:preReleaseBuild UP-TO-DATE
:app:prepareComAndroidSupportAppcompatV72311Library
:app:prepareComAndroidSupportCardviewV72311Library
:app:prepareComAndroidSupportDesign2311Library
:app:prepareComAndroidSupportGridlayoutV72311Library
:app:prepareComAndroidSupportRecyclerviewV72311Library
:app:prepareComAndroidSupportSupportV42311Library
:app:prepareComDigitsSdkAndroidDigits192Library
:app:prepareComFacebookAndroidFacebookAndroidSdk470Library
:app:prepareComGoogleAndroidExoplayerExoplayerR152Library
:app:prepareComGoogleAndroidGmsPlayServicesAuth840Library
:app:prepareComGoogleAndroidGmsPlayServicesBase840Library
:app:prepareComGoogleAndroidGmsPlayServicesBasement840Library
:app:prepareComGoogleAndroidGmsPlayServicesMaps840Library
:app:prepareComGoogleAndroidGmsPlayServicesMeasurement830Library
:app:prepareComMapboxMapboxsdkMapboxAndroidSdk230Library
:app:prepareComTwitterSdkAndroidTweetComposer102Library
:app:prepareComTwitterSdkAndroidTweetUi180Library
:app:prepareComTwitterSdkAndroidTwitter1110Library
:app:prepareComTwitterSdkAndroidTwitterCore162Library
:app:prepareIoFabricSdkAndroidFabric1310Library
:app:prepareDebugDependencies
:app:compileDebugAidl
:app:compileDebugRenderscript
:app:generateDebugBuildConfig
:app:generateDebugAssets UP-TO-DATE
:app:mergeDebugAssets
:app:processDebugManifest
:app:fabricGenerateResourcesDebug
:app:generateDebugResValues UP-TO-DATE
:app:processDebugGoogleServices
Found com.google.Android.gms:play-services-auth:8.4.0, but version 8.3.0 is needed for the google-services plugin.
Found com.google.Android.gms:play-services-maps:8.4.0, but version 8.3.0 is needed for the google-services plugin.
:app:processDebugGoogleServices FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':app:processDebugGoogleServices'.
> Please fix the version conflict either by updating the version of the google-services plugin (information about the latest version is available at https://bintray.com/Android/android-tools/com.google.gms.google-services/) or updating the version of com.google.Android.gms to 8.3.0.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 5.724 secs

ビルドファイルの一番下にあるgoogle-servicesプラグインを要求しています。これはすでに存在しています。また、8.3.0をもう一度実行するように要求されています。

122
sean
"client": [
{
  "client_info": {
    "mobilesdk_app_id": "9:99999999:Android:9ccdbb6c1ae659b8",
    "Android_client_info": {
      "package_name": "[packagename]"
    }
  }

package_nameは、マニフェストファイルの内容と一致する必要があります。下の写真を見ればgoogle-services.jsonファイルを見つけることができます。

enter image description here

165
tech support

Simpal簡単私の場合、それは以下のようにして解決しました

enter image description here

Mainifestsファイル内のあなたのパッケージ名があなたのGradleのapplicationIdと同じであることを確認してください。

95
Hiren

味を切り替えるときに私に起こった。

これで、 google-services.json をさまざまな種類で使用できます。

https://stackoverflow.com/a/34364376/570168 を参照してください。

37
Tobias

例外が発生する問題を解決しました

Java.lang.IllegalStateException:デフォルトのFirebaseAppはこのプロセスでは初期化されていません最初にFirebaseApp.initializeApp(Context)を呼び出すようにしてください。

firebaseInstanceId.getInstance()。getToken()内

package_name applicationId 1) build.gradle と完全に一致することを確認してください。

defaultConfig {
        applicationId "build.gradle.exactly.matches.json"
...
}

正確に 2に一致) google-services.json

{
      "client_info": {
        "mobilesdk_app_id": "xxxxxxxxxxxxxxxxxxxxxxxxxx",
        "Android_client_info": {
          "package_name": "build.gradle.exactly.matches.json"
        ....

20
Alex Burov

デバッグビルドタイプをビルドしようとしたときにだけ、これとまったく同じエラーが発生しました。私がそれを解決した方法は私のデバッグビルドタイプのために私のgoogle-services.jsonを変更することでした。私の元のフィールドはclient_idという名前のフィールドを持ち、その値はAndroid:com.example.exampleappでした、そして私はちょうどAndroid:接頭辞を削除してcom.example.exampleappのままにして、その後私のグラドルビルドは成功しました。

それが役に立てば幸い!

_編集_

Android:google-services.json接頭辞を付け加えたところで、正しく機能し続けました。何が正確に起こったのかわからないが、私は上記の解決策で私の問題を解決することができた。

18
carotorrehdz

固定のために:

パッケージ名 'com.example.exampleappに一致するクライアントが見つかりませんでした。

あなたのパッケージ用の有効なgoogle-service.jsonファイルを here から入手してください。

固定のために:

Google-servicesプラグインのバージョンを更新するか、バージョンの競合を修正してください(最新バージョンについての情報は https://bintray.com/Android/android-tools/com.google.gms.google-にあります)。 services/ )またはcom.google.Android.gmsのバージョンを8.3.0に更新する。

apply plugin: 'com.google.gms.google-services'をアプリのgradle.buildファイルの末尾に移動する必要があります。このようなもの:

dependencies {
    ...
}
apply plugin: 'com.google.gms.google-services'
15
epool

Firebaseを使用しているときに問題が発生したため、別のパッケージで問題が発生したと思います。

Firebase Consoleに新しいアプリのパッケージを追加して解決し、もう一度google-services.jsonをダウンロードしました。 enter image description here enter image description here enter image description here enter image description here

10
HenryChuang

Androidスタジオでgoogle-services.jsonを開くと、jsonオブジェクトが表示され、 'client' jsonarrayに次の項目が含まれます。

"client_id": "アンドロイド:あなたのパッケージ名"、 "パッケージ名": "あなたのパッケージ名"、

パッケージを確認して先に進んでください。

6
sree

ダウンロードしたgoogle-services.jsonファイルにパッケージ名が表示されていなかったときに、これが起こりました。 google-services.jsonファイルを開き、マニフェストパッケージ名に対応するパッケージ名を持つclient_infoオブジェクトがあることを確認してください。

Googleservices.jsonで:

"client": [
  {
    "client_info": {
    "mobilesdk_app_id": "my-app-id",
    "Android_client_info": {
      "package_name": "com.me.Android.test.myapp"
  }

そしてあなたのマニフェストの中で:

<manifest xmlns:Android="http://schemas.Android.com/apk/res/Android"
package="com.me.Android.test.myapp" >

プロジェクト用に新しいgoogle-services.jsonを再作成する必要があります。これはここで作成できます: https://developers.google.com/mobile/add?platform=Android&cntapi=gcm

5
Chris

私はこの設定を使用して成功を見つけました:

classpath 'com.Android.tools.build:gradle:1.5.0'
classpath 'com.google.gms:google-services:2.0.0-alpha3'
//or use
//classpath 'com.Android.tools.build:gradle:2.0.0-alpha6'

そして

distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.Zip

8.40 Google Playサービスを使用する。 Alpha5とAlpha6では、distributionUrlが2.10であるにもかかわらず、2.8と同じエラーが発生しました。

5
Cole Murray

あなたの google-services.json パッケージ名はあなたの build.gradle applicationId(applicationId "あなたのパッケージ名")と一致しなければなりません。

5
lingyfh

"google-services.json"ファイルでpackage_nameが利用可能かどうかを確認してください

3

私は同じ問題を抱えていて、manifest.xmlファイル内のmainfestタグ内のpackageのパッケージ名と、gradle appレベルファイル内のapplicationタグ内のapplicationIdが同じパッケージ名であることを確認するだけで簡単に解決できます。

manifest.xml内

package="com.example.work"

gradleアプリレベルで

applicationId "com.example.work"

それが役立つことを願っています

アプリケーションパッケージ名の変更 の後にこれが起こった場合は、以下を更新する必要があります。

1) google-services.json "package_name"属性のファイルを検索して新しいパッケージ名で更新し、アプリケーションに追加します。

2) Google Developers Console でアプリケーションクライアントの認証情報を更新し、Credentialsに移動してAndroidクライアントキーを選択し、パッケージ名を新しいもので更新します。

これが役立つことを願っています。

3
Sami Eltamawy

ダウンロードしたgoogle-services.jsonファイルにパッケージ名が表示されていなかったときに、これが起こりました。 google-services.jsonファイルを開き、マニフェストパッケージ名に対応するパッケージ名を持つclient_infoオブジェクトがあることを確認してください。

プロジェクトのパッケージ名 manifest が、 google-services.json fileとまったく同じであることを確認してください。

ありがとう。

1
TareqBallan

私はあなたがplay-service 8.4.0を使っていると思います

必須

classpath 'com.Android.tools.build:gradle:2.0.0-alpha5'
classpath 'com.google.gms:google-services:2.0.0-alpha5'

this を参照することもできます。

1
Shawn Thye

私にとっては、google-services.jsonファイルをチェックし、"package_name"が私のAndroidアプリのパッケージ名に正しく設定されていることを確認する必要がありました。私の場合、自動生成サービスファイルには.backendが追加されています。

1
Micro

これをプロジェクトGradleファイルに追加します

classpath 'com.google.gms:google-services:3.0.0'
1
Makvin

Androidスタジオで「管理者として実行」を実行するだけで動作します

または google-services.json fileでパッケージ名を確認してください。

1
Muhammed Fasil

マニフェストファイル内のそのパッケージ名とグラドルビルドファイル内のアプリケーションIDが同じである必要があります。私の問題は解決しませんでした。

実際には、グラドルビルドファイルのアプリケーションIDはgoogle-services.jsonファイルのパッケージ名と同じである必要があります。 google-services.jsonファイルのパッケージ名が異なる場合そのアプリをGoogle AnalyticsまたはFirebase Consoleから削除します。そして新しいファイルを入手してください。

0
Hammad Tariq

build.gradle.を確認してください

defaultConfig {
        applicationId "<packagename>"
        minSdkVersion 15
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    }

パッケージ名を確認してください。エラーの原因にもなります。

0
Reju Koshy

1)パッケージ名がgoogle-services.jsonファイルと同じであることを確認してください。

2)同じパッケージ名を持つ他のプロジェクトが存在しないことを確認してください。

3)インターネットにアクセスできることを確認する

4)プロジェクトを同期してもう一度実行してみます

0
Arya Prabagar

どちらの場合も、パッケージ名を書きます。1. Android Studioで新しいプロジェクトを作成したときと2.設定ファイルを作成したとき

あなたはそれを小文字で書くべきです - それがうまく動く小文字に変えた後。時間を無駄にしたくない場合は、単に.jsonファイルにアクセスし、com.myname.MyAPPlicationnamEをcom.myname.myapplicationnameに置き換えてください(jsonファイル内のすべての一致について)。

他のタイプのビルド(apkなどの署名など​​)を実行する場合は、アプリのタイプのビルドを選択してからプロジェクトを実行する必要があります。

次の画像を見てください。このプロジェクトを実行するには、実行設定ポップアップで「app」を選択する必要があります。 enter image description here

0
Ali Rasouli

私の場合、私はしなければならなかった

  1. クリック ビルド
  2. クリック プロジェクトの作成

それはすべてうまくいきました。何が起こったのかまだわかりません。

0
Abel Callejo