webdevqa.jp.net

APIレベルの変更Android Studio

Android Studioの最小SDKバージョンをAPI 12からAPI 14に変更したいです。マニフェストファイルで変更してみました。

<uses-sdk
    Android:minSdkVersion="14"
    Android:targetSdkVersion="18" />

プロジェクトを再ビルドしても、Android Studio IDEがエラーを発生させます。 IDEが変更を認識するように、最小のSDKを 'プロジェクトプロパティ'または同様のものに設定する必要があると思いますが、Android Studioのどこでこれが行われているのかわかりません。

379
James B

既存のプロジェクトでminSdkVersionを更新したい場合は...

  1. Update build.gradle(Module: app) - Gradle Scriptの下にあるもので、_build.gradle(Project: yourproject)ではない)であることを確認してください。

Build.gradleの例:

apply plugin: 'com.Android.application'

Android {
    compileSdkVersion 28
    buildToolsVersion "28.0.2"

    defaultConfig {
        applicationId "com.stackoverflow.answer"
        minSdkVersion 21
        targetSdkVersion 28
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.pro'
    }
}

dependencies {
    androidTestCompile 'junit:junit:4.12'
    compile fileTree(dir: 'libs', include: ['*.jar'])
}
  1. [Gradle]ボタンを同期(すべてのGradleプロジェクトを更新も有効)
  2. プロジェクトの再構築

build.gradleminSdkVersionの更新後、ボタンをクリックしてGradleファイルを同期する必要があります( "Sync Project with Gradle files")。これでマーカーが消えます。

たとえば、manifest.xmlを更新します。マニフェストファイル内のSDKレベルへの参照を削除することは、もはやAndroid Studioでは不要です。

544
Sotti

Androidスタジオユーザーの場合:

  1. appディレクトリを右クリック
  2. 「モジュール設定」オプションを選択してください
  3. 必要に応じてADKプラットフォームを変更する
  4. 適用をクリック

Gradleは自動的にプロジェクトを再構築します。

157
user3291001

今やAndroid Studioは安定しているので、それをする簡単な方法があります。

  1. プロジェクトファイルを右クリック
  2. 「Open Module Settings」を選択してください。
  3. [フレーバー]タブに移動します。

enter image description here

  1. ドロップダウンリストから最小SDKバージョンを選択します

PS: この質問はすでに回答されていますが、Android Studioは安定版リリースによって少し変わっています。だから、簡単で素直な方法は、新しいアンサーシーカーがここに着陸するのを助けます。

126
priyankvex

Androidスタジオでは、簡単に押すことができます。

  1. Ctrl + Shift + Alt + S
  2. あなたがAndroid studioの新しいバージョンを持っているならば、それから最初にアプリを押してください。その後、次の手順3に進みます。
  3. たくさんのオプションが表示されたウィンドウが開きます
  4. Flavorsに進んでください。実際に必要なのはこれだけです。

アプリのversionCodeをそこで変更することもできます。

9
Salah Klein

この答え によると、manifest.xmlにminsdkversionを含めないでください。ビルドシステムはbuild.gradleファイルの値を使用して、情報を最後のapkに入れます。

ビルドシステムはとにかくこの情報を必要とするので、これは理にかなっています。この値を2回定義する必要はありません。

build.gradleファイルを変更した後にプロジェクトを同期するだけで済みますが、Android Studio 0.5.2ではbuild.gradleエディタウィンドウの上に黄色いステータスバーが表示されます。

また、少なくとも2つのbuild.gradleファイルがあります。1つはマスター、もう1つはapp/module用です。変更するものはapp /モジュールにあります、それはすでに新しく生成されたプロジェクトでプロパティminSdkVersionを含みます。

5
Meier

build.gradleminSdkVersion 13minSdkVersion 8に変更してください。私はこれをするだけで私の問題を解決しました。

defaultConfig {
    applicationId "com.example.sabrim.sbrtest"
    minSdkVersion 8
    targetSdkVersion 20
    versionCode 1
    versionName "1.0"
}
5
Sabri Meviş

基本Platform SDKではなくGoogle APIにSDKターゲットを指定するのに問題がある場合は、compileSdkVersion 19compileSdkVersion "Google Inc.:Google APIs:19"に変更してください。

4
Juan Reyes

最新のAndroid Studio v2.3.3(2017年10月11日):
1。メニューバーのViewをクリック
2。 Open Module Settingsをクリックします。
3。 Flavorsタブを開く
4。必要な最小のSdkバージョンを選択してください
IDE Project Structure Window 6. [OK]をクリックします

4
Rido

マニフェストを更新するだけでなく、モジュールのbuild.gradleファイルも更新します(マニフェストのすぐ下のプロジェクトペインに表示されます - minSdkVersionキーがない場合は、カップルがあるので間違っているファイルを探しています)。再構築と物事はうまくいくはずです...

3
Chris Rolliston

Androidスタジオでbuild.gradleを開き、次のセクションを編集します。

defaultConfig {
    applicationId "com.demo.myanswer"
    minSdkVersion 14
    targetSdkVersion 23
    versionCode 1
    versionName "1.0"
}

ここで、minSdkVersionを12から14に変更できます。

1

Gradleスクリプト - >
build.gradle(モジュール:app) - >
minSdkVersion (Your min sdk version)

0
Hubert Hubert

マニフェスト内のminSdkVersionを変更する必要はありません。下記のようにgradleビルドファイルでそれを変更すれば、あなたはあなたがする必要があることを達成します。

defaultConfig {
   applicationId "com.demo.myanswer"
   minSdkVersion 14
   targetSdkVersion 23
   versionCode 1
   versionName "1.0"
}
0
Chris Deck

私にとってうまくいったのは、(右クリック)project-> Android tools-> clear lint markerです。何らかの理由でマニフェストが古い(低い)最小APIレベルに戻ったが、それを新しい(高い)APIレベルに戻した後に赤いエラーの下線はなく、プロジェクトは新しい最小APIレベルを使用します。

編集:申し訳ありませんが、EclipseではなくAndroid Studioを使用していたようです。しかし、私はスタジオのどこかに似たような 'clear lint marker'があり、それが問題を解決するかもしれないと思います。

0
Jamppa