webdevqa.jp.net

AVDManagerでターゲットAPIを変更できません

AVD Managerで新しい仮想デバイスを作成するとき、ターゲットのドロップダウンメニューで使用できるオプションは2つだけです。APIレベル8と17(2.2と4.2.2)ですが、その間にすべてのAPIとそのすべてのサブコンポーネントをインストールしました。 。さらに、4.2.2を選択すると、[OK]ボタンが無効になります。

ターゲットAPIをAVDマネージャーに追加するにはどうすればよいですか?インストールしたSDKに直接リンクしていませんか?

13
FloIancu

これらは、インストールしたSDKバージョンに関連付けられていません。使用可能なAVDバージョンは、SDKマネージャーを介してインストールしたシステムイメージに関連付けられています。

たとえば、ARM EABI v7aシステムイメージ、Intel x86 Atomシステムイメージ、およびMIPSシステムイメージはAndroid = SDKマネージャーでは4.2(API17)。

17
Bryan Herbst

ちょうど同じことに遭遇しました。 Eclipseを再起動してみてください。

12
Jonathan Lin

SDKの場所へのパスを確認する必要があるかもしれません。それは、Android 4.2.2-APIレベル17&Android 2.2 -APIレベル8がインストールされています。

これを行うには、[ウィンドウ]-> [設定](Eclipse内)に移動し、[設定]で[Android]に移動し、AndroidにSDKの場所が表示されます。SDKの場所を参照してSDKの場所に変更します。あなたのAndroid SDKツールがインストールされています。例:C:\ Program Files(x86)\ Android\android-sdk

Android SDK Manager 1)に移動し、SDKをインストールした場所へのパスポイントを確認します

2)チェックAndroid 4.2.2(API 17)チェックボックス

3)インストールボタンを押します

0
Kamornik Cola