webdevqa.jp.net

com.Android.tools.lintが見つかりませんでした:lint-gradle Android Studio 3

私はAndroid Studioを3.0にアップデートしましたが、今ではたくさんの問題を受けています。

Could not resolve all files for configuration ':applib:_lintClassPath'.
> Could not find com.Android.tools.lint:lint-gradle:26.1.0-alpha01.
  Searched in the following locations:
      file:/Users/anwender/Library/Android/sdk/extras/m2repository/com/Android/tools/lint/lint-gradle/26.1.0-alpha01/lint-gradle-26.1.0-alpha01.pom
      file:/Users/anwender/Library/Android/sdk/extras/m2repository/com/Android/tools/lint/lint-gradle/26.1.0-alpha01/lint-gradle-26.1.0-alpha01.jar
      file:/Users/anwender/Library/Android/sdk/extras/google/m2repository/com/Android/tools/lint/lint-gradle/26.1.0-alpha01/lint-gradle-26.1.0-alpha01.pom
      file:/Users/anwender/Library/Android/sdk/extras/google/m2repository/com/Android/tools/lint/lint-gradle/26.1.0-alpha01/lint-gradle-26.1.0-alpha01.jar
      file:/Users/anwender/Library/Android/sdk/extras/Android/m2repository/com/Android/tools/lint/lint-gradle/26.1.0-alpha01/lint-gradle-26.1.0-alpha01.pom
      file:/Users/anwender/Library/Android/sdk/extras/Android/m2repository/com/Android/tools/lint/lint-gradle/26.1.0-alpha01/lint-gradle-26.1.0-alpha01.jar
      https://jcenter.bintray.com/com/Android/tools/lint/lint-gradle/26.1.0-alpha01/lint-gradle-26.1.0-alpha01.pom
      https://jcenter.bintray.com/com/Android/tools/lint/lint-gradle/26.1.0-alpha01/lint-gradle-26.1.0-alpha01.jar
      https://jitpack.io/com/Android/tools/lint/lint-gradle/26.1.0-alpha01/lint-gradle-26.1.0-alpha01.pom
      https://jitpack.io/com/Android/tools/lint/lint-gradle/26.1.0-alpha01/lint-gradle-26.1.0-alpha01.jar
      file:/Users/anwender/dev/project/dk_shopping_checklist/augmented/libs/lint-gradle-26.1.0-alpha01.jar
      file:/Users/anwender/dev/project/dk_shopping_checklist/augmented/libs/lint-gradle.jar
  Required by:
      project :applib

誰かが問題が何であるかを知っていますか?

Gradle.build:

apply plugin: 'com.Android.library'

Android {
    compileSdkVersion 26
    buildToolsVersion '26.0.2'
    defaultConfig {
        minSdkVersion 24
        targetSdkVersion 26
    }

    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    implementation fileTree(include: ['*.jar'], dir: 'libs')
    implementation 'com.Android.support:appcompat-v7:+'
}

私は最新のgradleバージョンを使っています: "gradle-4.2.1-all.Zip".

70
D.K.

依存関係を取得するためのgoogle()リポジトリが見つからないようです。

これがあなたが探しているpomファイルへのリンクです: https://dl.google.com/dl/Android/maven2/com/Android/tools/testutils/26.1.0-alpha01/ testutils-26.1.0-alpha01.pom

47
Niklas

古いバージョンのAndroid Studioを使用して作成したプロジェクトでlintを実行している場合は、このエラーが発生する可能性があります。

この問題を解決するには、lintを実行するプロジェクトごとに、以下に示すように、GoogleのMavenリポジトリを最上位のbuild.gradleファイルに含めます。

allprojects {
    repositories {
        // The order in which you list these repositories matter.
        google()
        jcenter()
    }
}
177
0xAliHn

私はこれをhttps://mvnrepository.com/artifact/com.Android.tools.lint/lint-gradle-apiレポジトリをbuild.gradleに追加することで解決しました:

repositories {
    maven {
        url 'https://maven.google.com/'
        name 'Google'
    }
    jcenter()
    maven {
        url 'https://mvnrepository.com/artifact/com.Android.tools.lint/lint-gradle-api'
    }
}
4
Tom Aranda

現在のGradleのバージョン(3.3.23.2.1に変更しました))グローバルbuild.gradleファイルから。

buildscript {
 repositories {
    google()
    jcenter()
    maven { url 'https://maven.google.com' }
 }

 dependencies {
    classpath 'com.Android.tools.build:gradle:3.2.1'
 }
}

allprojects {
 repositories {
    google()
    jcenter()
    maven { url 'https://maven.google.com' }
 }
}

次に、画面の右上隅にあるgradleの同期ボタンをクリックします。

0
l.mome