webdevqa.jp.net

com.google.Android.gms:play-services-measurement-baseは、他のさまざまなライブラリから要求されています

Gradle 4.0.1にアップデートし、以下のエラーを受け取り始めました

ライブラリcom.google.Android.gms:play-services-measurement-baseは[[15.0.4,15.0.4]]で他のさまざまなライブラリから要求されていますが、 15.0.2。プラグインを無効にして./gradlew:app:dependenciesを使用してあなたの依存関係ツリーをチェックしてください。

私のプロジェクトはその依存関係を使用していないので、私はそれをグローバルに検索しました、そしてそれは内部に現れるだけです

build/intermediate/lint-cache/maven.google/com/google/Android/gms/group-index.xml

この行として

<play-services-measurement-base versions="15.0.0,15.0.2"/>

だから私は自分のビルドフォルダを削除してプロジェクトを掃除しようとしましたが、それは同じ値でそれを再生成します。

104
Ilja

実際の問題は https://developers.google.com/Android/guides/releases#may_23_2018の5月23日のリリースノートで説明されています

基本的には、すべてのPlay ServicesFirebaseのライブラリを最新のバージョンに更新する必要があります( バージョン15以降はそれぞれ異なります )。 ] https://mvnrepository.com/ を使用して、各ライブラリの最新バージョンを見つけることができます。

https://firebase.google.com/support/release-notes/Android#20180523 も参照してください。

118
Nico

私のための唯一の実用的な解決策:

build.gradleの一番下に置きます 

com.google.gms.googleservices.GoogleServicesPlugin.config.disableVersionCheck = true
65
htw

Googleがサービスの依存関係とFirebaseの依存関係を最新バージョンに保つようにしてください。

また、すべてのGradleファイル、モジュールレベル、およびプロジェクトレベルを確認してください。すべてのモジュールにわたって、依存関係の共通バージョンは1つだけでなければなりません。これらのバージョンをプロジェクトレベルのgradle変数に保持することで解決できます。

Google Playサービスのアップデートバージョンはこちら

Google Playサービス最新

Firebaseのアップデート版はこちら

Firebase Latest

Android用Firebaseの更新バージョンはこちら

Firebase Android最新 /

21
abitcode

更新しました 

    implementation 'com.google.Android.gms:play-services-analytics:16.0.3'

そしてそれは私のために働く

8
Amine M'hamed

私のbuild.gradleを次のように変更するとうまくいきました。

ext {
  googlePlayServicesVersion   = "15.0.1"
}

allprojects {
  repositories {
      mavenLocal()
      maven { url 'http://maven.google.com' }
      jcenter { url "http://jcenter.bintray.com/" }
      google()
      maven {
        // All of React Native (JS, Obj-C sources, Android binaries) is installed from npm
        url "$rootDir/../node_modules/react-native/Android"
      }

      configurations.all {
        resolutionStrategy {
            force "com.google.Android.gms:play-services-basement:$googlePlayServicesVersion"
            force "com.google.Android.gms:play-services-tasks:$googlePlayServicesVersion"
        }
      }
  }
}
6
mk7danny

私の場合、以下のdependenciesの最新バージョンを使用することで私の問題は解決しました。

'com.google.Android.gms:play-services-analytics:16.0.1'
'com.google.Android.gms:play-services-tagmanager:16.0.1'
5
Murat

あなたの依存関係のリストに追加してください。すべてのfirebaseの依存関係の適切な仕事のために今それを持つ必要があります:

implementation 'com.google.firebase:firebase-core:16.0.1'
3
PavelGP

これは、Android Gradleプラグインが非常に古い場合、単一のGoogleライブラリを使用している場合でも発生する可能性があります。どうやらすべてのGoogleライブラリは、以前とまったく同じバージョンである必要がありました。今、彼らは同じである必要はなく、最新のものだけです。単一のlibでも指定すると、バージョンが一致しない依存関係と古いAndroid Gradleプラグインpukが引き込まれます。

以下のように新しいバージョンを設定してください。

buildscript {
    dependencies {
        classpath 'com.Android.tools.build:gradle:3.3.2'
    }
}

新しいプラグインを使うようにGradleをアップデートする必要があるかもしれません(それはあなたに教えてくれるでしょう)。

3
NateS

私にとっては、Firebaseを介してCrashlyticsを統合した後にこのエラーが表示されました。

implementation 'com.google.firebase:firebase-core:16.0.4'
implementation 'com.google.Android.gms:play-services-location:15.0.1'

最初にFirebase Coreを15.0.1にダウングレードしようとしましたが、 そのようなバージョンはなく、15.0.015.0.2!のみ 代わりに両方をバージョンにダウングレードしなければなりません15.0.0、だから私は

implementation 'com.google.firebase:firebase-core:15.0.0'
implementation 'com.google.Android.gms:play-services-location:15.0.0'

だから今は機能しているが、新しいバージョンが利用可能になったといううっとうしいリント警告を受け取った。このバージョニングの大失敗は異常な混乱です。

2
Magnus W

私のために働く唯一の解決策(リンクがない)

トップメインbuild.graleに 

allprojects {

subprojects {
    project.configurations.all {
        resolutionStrategy.eachDependency { details ->
            if (details.requested.group == 'com.google.Android.gms'
                    && !details.requested.name.contains('multidex')) {
                details.useVersion "x.y.z"
            }
        }
    }
}
2
issamux

私が自分のプロジェクトにFirebase Databaseを追加しようとしたときにも、同様の問題が発生しました。

implementation 'com.google.firebase:firebase-core:16.0.1'
implementation 'com.google.firebase:firebase-database:16.0.3'

この問題は、両方のバージョンを同じレベルにダウングレードするかアップグレードすることで解決できます。

implementation 'com.google.firebase:firebase-core:16.0.1'
implementation 'com.google.firebase:firebase-database:16.0.1'

利用可能なすべてのバージョンはこのサイトで検索できます。 https://mvnrepository.com/

2

デバッグログに古いバージョンのfirebase-analytics(16.0.0)が記載されていることに気付きました。最新バージョンを明示的に追加することで問題が解決しました。

implementation "com.google.firebase:firebase-analytics:16.0.3"
1
smok

私は同じ問題を抱えていた 

すべての依存関係の 最新バージョン があることを確認してください。 Firebase coreとauthに現在のバージョンを使用しました。新しいバージョンにはバグ修正があります。 

あなたはここから最新バージョンを手に入れることができます: https://firebase.google.com/support/release-notes/Android

現時点での最新バージョンの使用

app/build.gradleにあります。

dependencies {
implementation 'com.google.firebase:firebase-core:16.0.6'
implementation 'com.google.firebase:firebase-auth:16.1.0'
}
1
shellym

Firebaseの依存関係のバージョンが異なるために、次のようなエラーが発生すると思います。私が自分のプロジェクトに実装しているすべての依存関係のバージョンを16.0.1に変更すると、魅力的に機能しました。

私にとっては、エラーは com.google.firebase:firebase-auth:16.0.2という行によって作成されました。

そして私はそれを次のように変更しました: com.google.firebase:firebase-auth:16.0.1

そしてそれはうまくいった。

1
Vipin George

すべての依存関係を最新バージョンに更新すると問題が解決します。

追加する必要はありません 
com.google.gms.googleservices.GoogleServicesPlugin.config.disableVersionCheck = true

バージョンが混在しているとクラッシュする可能性があります。

1
RakeshGupta

1.プロジェクトレベルのbuild.gradleを開きます。

com.google.gms:google-servicesのバージョンを最新のものに更新します。 最新のリリースを追跡する 。回答の時点で最新のものは4.1.0です。 

2.アプリレベルのbuild.gradleを開きます。

使用する場合は、依存関係を下に更新してください。firebaseには、依存関係ごとに個別のバージョンがあります。

最新のFirebaseライブラリ を使用してください。答えの時点で最新のバージョンは以下の通りです。

Firebase Core                com.google.firebase:firebase-core:16.0.3
Ads                          com.google.firebase:firebase-ads:15.0.1
Analytics                    com.google.firebase:firebase-analytics:16.0.3
App Indexing                 com.google.firebase:firebase-appindexing:16.0.1
Authentication               com.google.firebase:firebase-auth:16.0.3
Cloud Firestore              com.google.firebase:firebase-firestore:17.1.0
Cloud Functions              com.google.firebase:firebase-functions:16.1.0
Cloud Messaging              com.google.firebase:firebase-messaging:17.3.2
Cloud Storage   c            om.google.firebase:firebase-storage:16.0.2
Crash Reporting              com.google.firebase:firebase-crash:16.2.0
Crashlytics                  com.crashlytics.sdk.Android:crashlytics:2.9.5
Dynamic Links                com.google.firebase:firebase-dynamic-links:16.1.1
Invites                      com.google.firebase:firebase-invites:16.0.3
In-App Messaging             com.google.firebase:firebase-inappmessaging:17.0.1
In-App Messaging Display     com.google.firebase:firebase-inappmessaging-display:17.0.1
ML Kit: Model Interpreter    com.google.firebase:firebase-ml-model-interpreter:16.2.0
ML Kit: Vision               com.google.firebase:firebase-ml-vision:17.0.0
ML Kit: Image Labeling       com.google.firebase:firebase-ml-vision-image-label-model:15.0.0
Performance Monitoring       com.google.firebase:firebase-perf:16.1.0
Realtime Database            com.google.firebase:firebase-database:16.0.2
Remote Config                com.google.firebase:firebase-config:16.0.0

同期とビルド...

1
Khemraj

"+"をバージョン番号に置き換えると、最新バージョンが選択されます。

implementation 'com.google.firebase:firebase-analytics:+'

0
Kyi Moe Min

firebase-coreとfirebase-database ...は同じバージョンにしてください。

実装 'com.google.firebase:firebase-core:16.0.1'実装 'com.google.firebase:firebase-database:16.0.1'

0
RD QUOCVIET

同じエラーが発生しましたが、Audience NetworkとFirebaseの両方を使用している場合とは異なります。

このエラーが出ました

Androidの依存関係「com.google.Android.gms:play-services-basement」には、コンパイル(11.0.4)およびランタイム(16.0.1)クラスパスの異なるバージョンがあります。 DependencyResolutionを使用して同じバージョンを手動で設定する必要があります

audience-networkを使用している場合の解決策は次のとおりです

implementation ("com.facebook.Android:audience-network-sdk:$rootProject.fb_version")
{
    exclude group: 'com.google.Android.gms'
}
0
Nikunj Paradva

私はすべてのために同じバージョンを使用しようとしていたときに私は同様のエラーを得ていました:

implementation 'com.google.Android.gms:play-services-base:16.0.0'
implementation 'com.google.Android.gms:play-services-analytics:16.0.0'
implementation 'com.google.Android.gms:play-services-awareness:16.0.0'
implementation 'com.google.Android.gms:play-services-cast:16.0.0'
implementation 'com.google.Android.gms:play-services-gcm:16.0.0'
implementation 'com.google.Android.gms:play-services-location:16.0.0'
implementation 'com.google.firebase:firebase-messaging:16.0.0'

私が次のことをしたとき、問題は私のために修正されました:

1)各サービスで利用可能な最新バージョンを使用しました。

implementation 'com.google.Android.gms:play-services-base:16.1.0'
implementation 'com.google.Android.gms:play-services-analytics:16.0.8'
implementation 'com.google.Android.gms:play-services-awareness:16.0.0'
implementation 'com.google.Android.gms:play-services-cast:16.2.0'
implementation 'com.google.Android.gms:play-services-gcm:16.1.0'
implementation 'com.google.Android.gms:play-services-location:16.0.0'
implementation 'com.google.firebase:firebase-messaging:17.6.0'

2)Android Studioを本日入手可能な最新バージョン(Android Studio 3.4)にアップグレードしました。

3)Android Gradleプラグインのバージョンを3.4.0に、Gradleのバージョンを5.1.1にアップグレードしました。

0
Jaime Montoya

あなたはこの依存関係を引っ張っているライブラリを見つけることができます:

$ ./gradlew app:dependencies
0
Nico

私は同様の問題を解決しました:

  1. アプリレベルでの課題:すべてのfirebaseの依存関係を最新バージョンに更新します 最新 /
  2. プロジェクトレベルでの課題:最新の依存関係を更新します:gms.google-services、私の場合は「com.google.gms:google-services:4.2.0」です。
0
tabebqena

同じ問題がありました。あなたはコロンを削除しなければなりません:gradleの中のバージョンの後(それはバグです)。

これらの設定は私のために働きました:

implementation 'com.google.firebase:firebase-firestore:17.1.5'

GradeでmultiDexEnabledをtrueに設定します(DexOverflowExceptionエラーが発生した場合)

    Android {
        compileSdkVersion 27
..
            multiDexEnabled true
        }
0
live-love

これは最新の依存関係を使用して解決できます。

以下のサイトで最新のものを見つけることができます

https://firebase.google.com/support/release-notes/Android#20180523

その同期をもう一度投稿すればうまくいくはずです。

0

Firebase-databaseの実装を追加しようとしたときに同じ問題が発生しました。その行にコメントしても、何度か試してみて https://firebase.google.com/docs/Android/setup

そこで利用可能なライブラリのバージョンをチェックし、私のfirebase-coreは16.0.1(現在のバージョンは16.0.4)であったので手動でそれを変更しました、そしてそれはちょうどうまくいきました、構築と同期は成功しました。

0
Anibal

私は同じ問題を抱えています、そして私は偶然に実装された実装 'com.google.firebase:firebase-auth:15+'を代わりに実装しました 'com.google.firebase:firebase-auth:16.1.0'

0
altintasomer

私の場合私はURLの下に最新のrnfirebaseを使用しています

https://rnfirebase.io/docs/v4.3.x/installation/Android

android/app/proguard-rules.proに以下を追加してください)

-keep class io.invertase.firebase.** { *; }
-dontwarn io.invertase.firebase.**
0
krish

これが簡単な解決策です。問題は、一方のライブラリーに最新バージョンを使用し、もう一方のライブラリーに下位バージョンを使用しているためです。バランスをとるようにしてください。最善の解決策は、すべてのライブラリに最新バージョンを使用することです。問題を解決するには、 ここ をクリックして最新バージョンのライブラリを表示し、それをプロジェクトに含めてから同期します。
私の場合、以下が私のために働いています。

dependencies{
    implementation 'com.google.firebase:firebase-core:16.0.7'
    implementation 'com.google.firebase:firebase-database:16.1.0'
}
apply plugin: 'com.google.gms.google-services'
0
In my case

ERROR: The library com.google.Android.gms:play-services-basement is being requested by various other libraries at [[15.0.1,15.0.1]], but resolves to 16.0.1. Disable the plugin and check your dependencies tree using ./gradlew :app:dependencies.

It solves my issue
implementation 'com.google.Android.gms:play-services-analytics:16.0.1'
0
Kishore Reddy

私の場合は単に削除します 

implementation "com.google.Android.gms:play-services-ads:16.0.0

firebase adsの依存関係を追加して 

implementation 'com.google.firebase:firebase-ads:17.1.2'
0
code4rox

私の場合は、build.gradleファイルをこの行に置き換えました

implementation 'com.google.firebase:firebase-core:16.0.8'

implementation 'com.google.firebase:firebase-core:15.0.0' 

そしてこの行を追加しました

implementation 'com.google.Android.gms:play-services-location:15.0.0'

今その罰金

0
Maddu Swaroop

ちょうどコードの下に置く:

    implementation 'com.google.firebase:firebase-core:16.0.6'
    implementation 'com.google.firebase:firebase-database:16.0.6'

そして再構築します。それは私のためだけにうまくいきます

0
shahid

私はこの問題にぶつかっていて、 リリースノート に言及していることに気づいた。

Firebaseでは、Firebaseサービスが期待どおりに機能するための依存関係として、com.google.firebase:firebase-coreを明示的にリストするためのアプリケーショングラドルファイルが必要になりました。

firebase-coreをアプリの依存関係(およびライブラリの依存関係)にすることで、この問題は解決しました。

0
Tad

The library com.google.Android.gms:play-services-measurement-base is being requested by various other libraries at [[16.0.2,16.0.2]], but resolves to 16.0.0. Disable the plugin and check your dependencies tree using ./gradlew :app:dependencies. エラーがありました

./gradlew :app:dependenciesを実行すると、どの依存関係が間違った依存関係を必要としているかが明らかになります(角括弧内のもの)。私にとっては、問題はfirebase-core:16.0.3から来ています。 firebase-coreを16.0.1にダウングレードすることで修正しました

+--- com.google.firebase:firebase-core:16.0.3
|    +--- com.google.firebase:firebase-analytics:16.0.3
|    |    +--- com.google.Android.gms:play-services-basement:15.0.1
|    |    |    \--- com.Android.support:support-v4:26.1.0 (*)
|    |    +--- com.google.Android.gms:play-services-measurement-api:[16.0.1] -> 16.0.1
|    |    |    +--- com.google.Android.gms:play-services-ads-identifier:15.0.1
|    |    |    |    \--- com.google.Android.gms:play-services-basement:[15.0.1,16.0.0) -> 15.0.1 (*)
|    |    |    +--- com.google.Android.gms:play-services-basement:15.0.1 (*)
|    |    |    +--- com.google.Android.gms:play-services-measurement-base:[16.0.2] -> 16.0.2
0
Eric Kim

メッセージが

ライブラリcom.google.Android.gms:play-services-measurement-baseは[[15.0.4,15.0.4]]で他のさまざまなライブラリから要求されていますが、 15.0.2 。プラグインを無効にして./gradlew:app:dependenciesを使用してあなたの依存関係ツリーをチェックしてください。

使用しているすべてのPlayサービスライブラリのバージョンを必要なバージョン(この場合は 15.0.2 )に変更すると、問題を解決できる可能性があります。 

私の場合は、次のように変更しました。

implementation 'com.google.Android.gms:play-services-base:+' -> implementation 'com.google.Android.gms:play-services-base:15.0.2'
implementation 'com.google.Android.gms:play-services-location:+' -> implementation 'com.google.Android.gms:play-services-location:15.0.2'
implementation 'com.google.Android.gms:play-services-maps:+' -> implementation 'com.google.Android.gms:play-services-maps:15.0.2'
implementation 'com.google.Android.gms:play-services-auth:+' -> implementation 'com.google.Android.gms:play-services-auth:15.0.2'
implementation 'com.google.Android.gms:play-services-places:+' -> implementation 'com.google.Android.gms:play-services-places:15.0.2'
0
Jose Q

ここで解決しました: 私もfirebaseにcrashlyticsを追加しようとしたときに同じ問題に直面しました。 com.google.Android.gms:play-services および com.google.firebase:...... の依存関係の最新バージョンを更新してください。それは自動的に問題を解決します

0
Priya Rajan

私はそれが機能するように私のプロジェクトで以下の依存関係を変更しました。

build.gradle(app):

implementation 'com.google.firebase:firebase-core:16.0.1'

implementation 'com.google.firebase:firebase-core:16.0.8'

build.gradle(app):

classpath 'com.google.gms:google-services:4.0.1'

classpath 'com.google.gms:google-services:4.2.0'

****注

依存関係のあるライブラリを最新の状態で使用するには、次のリンクを使用してください https://firebase.google.com/docs/Android/setup

0
Ali Baba