webdevqa.jp.net

emulatorでGoogle Playサービスを更新する

私はグーグルプレイでこのような多くの質問をしました、私はアンドロイド4.2.2 API 17を使っています。

私のアプリはグーグルプレイサービス8.1を必要とし、それはうまくコンパイルされ、それがエミュレータ上で実行されるとそれは'グーグルプレイサービスを更新する必要があります'

更新をクリックしても何も起こりません、

最新のAPIバージョンをダウンロードせずにGoogle Playサービスを更新するにはどうすればよいですか?

128
Johnny

2017年12月18日に更新

API 24から物理的なAndroidデバイスと同じように、エミュレータのPlayストアアプリを介してGoogle Playサービスを更新できます

チェック エミュレータの新機能が追加 Android Studio v 3.0からの安定したアップデート

Google Playのサポート - Googleから:多くのアプリ開発者がGoogle Playサービスを使用していることを知っています。AndroidEmulatorシステムのイメージでサービスを最新の状態に保つことは困難な場合があります。 この問題を解決するために、Playストアアプリを含むAndroidシステムイメージのバージョンを提供するようになりました。 Google Playの画像はAndroid Nougat(API 24) から入手できます。これらの新しいエミュレータ画像を使用すると、実際のAndroidデバイスと同じように、エミュレータのPlayストアアプリを介してGoogle Playサービスを更新できます。さらに、Google Playストアでエンドツーエンドのインストール、更新、購入の流れをテストできるようになりました。


クイックブート - クイックブートを使用すると、6秒以内にAndroid Emulatorセッションを再開できます。

Android CTSの互換性

パフォーマンスの向上 - Androidエミュレータの最新バージョンでは、AVDで定義されている最大のRAMサイズにメモリを割り当てて固定するのではなく、RAMをオンデマンドで割り当てます。

仮想センサー

Wi-Fiサポート

GPSの位置情報など.

_または_

これを SDK Build-ToolsとAndroid Emulatorを最新の に更新すると、この警告メッセージは表示されなくなります。

設定 - > Android SDK - > SDKツール(タブ) - > Android SDK Build-Tools

enter image description here

78
Amit Vaghela

Playストアがインストールされているエミュレータを使用してください。プレイサービスを更新することは、実際のデバイスと同じくらい簡単でしょう。

グーグルは グーグルプレイストアの画像を導入したので アンドロイドSDKツール26.0.0には今エミュレータがインストールされています グーグルプレイストア

enter image description here

26.0.3から

  • Google Playストアの画像用の拡張ウィンドウに、PlayサービスのバージョンとPlayサービスの更新を確認するためのボタンを表示する新しいタブを追加します。

emulator settings

71
user345280

Googleのドキュメント に基づいています

エミュレータでアプリをテストする場合は、Android 4.2.2(API 17)以降のディレクトリを展開し、[Google API]を選択してインストールします。次に、プラットフォームターゲットとしてGoogle APIを使用して新しいAVDを作成します。

エミュレータの[設定] - > [アプリ]に移動して、Google Playサービスを見つけます。バージョン番号を確認してbuild.gradleで使用してください。最新版にアップデートするには、 documentation および SO question にあります。

17
abielita

システムイメージのある仮想デバイスでアプリを実行すると、「Google API」ではなく「Google Play API」で問題がスムーズに解決されます。

  • 仮想デバイスNexus 5xおよびNexus 5は「Google Play API」イメージをサポートしています。

  • Google Play APIにはNougat 7.1.1とO 8.0が付属しています。

以下の簡単な手順に従って、あなたのパソコンがインターネットに接続されていることを確認してください。

  1. Android Virtual Devices ManagerからCreate Virtual Device(左下隅)を選択して、新しい仮想デバイスを作成します。

  2. ハードウェア「Nexus 5x」または「Nexus 5」を選択してください。

  3. システムイメージ「Nougat」をGoogle Playで、または「O」をGoogle Playでダウンロードしてください。 'O'は最新のAndroid 8.0バージョンです。

  4. NextをクリックしてFinishをクリックします。

  5. 新しい仮想デバイスでアプリをもう一度実行して、警告メッセージと一緒に表示される[今すぐアップグレード]オプションをクリックします。

  6. あなたはPlayストアに案内され、あなたはあなたのGoogle Playサービスを簡単に更新することができます。

あなたのアプリがスムーズに動くのを見てください!

  • :Google PlayサービスのAPIを使用する予定の場合は、Google APIs System Imageを使用する必要があります。
16
Michel

Google Playイメージ、Android SDK - > SDKプラットフォーム - > show show package details - > Google playをインストールする必要があります。 enter image description here

14
Houssin Boulla

私の答えは、Googleのplayサービスをアップデートするのではなく、回避することです。次のコードを使用して、エミュレータのプレイサービスバージョンを取得します。

getPackageManager().getPackageInfo("com.google.Android.gms", 0 ).versionName);

たとえば、値が "9.8.79"の場合、利用可能な最も近いバージョンのcom.google.Android.gms:play-services:9.8.0 'を使用します。

これで問題は解決します。 https://developers.google.com/Android/guides/releases#november_2016_-_v100 からリリース履歴を取得します。

7
Ganesh Kanna

パッケージ詳細の表示オプション が見つかるまで、このページの答えは私を避けました。

enter image description here

6
abbood

私は同じ問題を抱えていました。 SDK 27でエミュレータを使用しないでください。SDK 26は正常に動作します。

1
Estevão Lucas

私は同じ問題に直面しました。私は自分のAndroidスタジオを更新し、Android 7.1.1およびX86としてAPI 25ターゲットを使用しましたが、すべてうまくいきました。私は自分のプロジェクトにGoogle playサービスとfirebaseを使っています

0
Mahesh N