webdevqa.jp.net

Flutterプロジェクトのlint-gradle-api-26.1.2.jarが見つかりませんでした

私はFlutterが初めてなので、新しいプロジェクトを作成するときにサンプルプロジェクトを実行しようとしています。実行しようとすると、私はこの問題があります:

FAILURE:ビルドは例外で失敗しました。

私はそれがjcenterリポジトリからファイル "lint-gradle-api-26.1.2.jar"を取得しようとしていることを理解していますが、リンクをたどるとき私はこれを得ます:

{
  "errors" : [ {
    "status" : 404,
    "message" : "Could not find resource"
  } ]
}

それで私はbuild.gradleファイルにGoogleリポジトリを追加しました:

buildscript {
    repositories {
        maven { url 'https://dl.google.com/' }
        google()
        jcenter()
    }

...そして、私はこのリンクをたどってファイルを取得することにも成功しました:

https://dl.google.com/dl/Android/maven2/com/Android/tools/lint/lint-gradle-api/26.1.2/lint-gradle-api-26.1.2.jar

...しかし、 Visual Studio Code 、Android Studio、CLIのいずれを使用した場合でも、プロジェクトを実行しようとすると同じエラーが発生します。

見つけたリンクからGradleにファイルをダウンロードさせるにはどうすればよいですか?

build.gradleファイルは次のようになります。

buildscript {
    repositories {
        //maven { url 'https://dl.google.com/dl/Android/maven2/com/Android/tools/lint/lint-gradle-api/26.1.2/lint-gradle-api-26.1.2.jar' }
        repositories {
            google()
            maven { url 'https://maven.fabric.io/public' }
            mavenCentral()
            jcenter()
        }
    }

    dependencies {
        classpath 'com.Android.tools.build:gradle:3.1.2'
    }
}

allprojects {
    repositories {
        google()
        maven { url 'https://maven.fabric.io/public' }
        mavenCentral()
        jcenter()
    }
}

repositories {
    google()
    maven { url 'https://maven.fabric.io/public' }
    mavenCentral()
    jcenter()
}

....
87
Quentin Ellak

私は移動することで問題を解決しました:

maven {
    url 'https://dl.google.com/dl/Android/maven2'
}

の一番上:

jcenter()

ファイル内:.flutter/packages/flutter_tools/gradle/flutter.gradle

    buildscript {
    repositories {
        maven {
            url 'https://dl.google.com/dl/Android/maven2'
        }
        jcenter()
    }
    dependencies {
        classpath 'com.Android.tools.build:gradle:3.1.2'
    }
}
125
Quentin Ellak

./flutter/packages/flutter_tools/gradleの下のflutter.gradleを変更してツールのバージョンを3.2.1にアップグレードし、最初の行にgoogle()を追加します。

buildscript {
  repositories {
    google()
    jcenter()
    maven {
      url 'https://dl.google.com/dl/Android/maven'
    }
  }
  dependencies {
    classpath 'com.Android.tools.build:gradle:3.2.1'
  }
}

私のコードのスクリーンショット

41
mano233

このエラーに関しては、build.gradleファイルの次の行を変更しました。

classpath 'com.Android.tools.build:gradle:3.1.2'

に:

classpath 'com.Android.tools.build:gradle:3.1.3'

そしてそれは私の問題を解決しました。

19
Alfredo Zamudio

これは25行目のC:\flutter\packages\flutter_tools\gradle\flutter.gradleにあるGradleファイルの単なるバグです。

このファイルを一番上に移動して編集するだけです。

maven {
    url 'https://dl.google.com/dl/Android/maven2'
}

これから変更

buildscript {
    repositories {

        jcenter()
        maven {
            url 'https://dl.google.com/dl/Android/maven2'
        }
    }
    dependencies {
        classpath 'com.Android.tools.build:gradle:3.1.2'
    }
}

これに:

buildscript {
    repositories {
        maven {
            url 'https://dl.google.com/dl/Android/maven2'
        }
        jcenter()
    }
    dependencies {`enter code here`
        classpath 'com.Android.tools.build:gradle:3.1.2'
    }
}
14
Charles

これは現在Flutter 0.9.4に関連しています。次のリリースで修正される予定です。それまでの間は、「Flutterのアップグレード」で説明しているコマンドを実行して、Flutterを手動で更新できます。基本的にそれらは以下を含みます:

  1. Promptコマンドを実行して、Flutter GitHubチャンネルをmasterに変更します。

    flutter channel master
    
  2. 実行してFlutter自体をアップグレードする

    flutter upgrade
    

アップグレードが完了したら、テストドライブアプリケーションを実行すると、正常にコンパイルされるはずです。

6
user3399299

溶液:

Put
maven {
    url 'https://dl.google.com/dl/Android/maven2'
}
at the top of:
jcenter()

.flutter/packages/flutter_tools/gradle/flutter.gradle:ファイルはFlutter SDKにあります。

4
Aegon

これで私の問題は解決しました、SOリファレンス ここ

ルートのbuild.gradleで、google()がjcenter()の前にあることを確認してください。

repositories {
    google()
    jcenter()
}

ほとんどのプロジェクトでは、これを2箇所で更新する必要があります。

buildscript {
    repositories {
        google()
        jcenter()
    }

}

allprojects {
    repositories {
        google()
        jcenter()
    }
}
3
Muahmmad Tayyib

フラッターマスターアップグレード

私はちょうどこの問題を抱えていました。私のための修正は、しかしはるかに簡単でした。ブランチをdevに切り替えてアップグレードした後、私は再びmasterに切り替えました。

flutter checkout dev
flutter upgrade

それからスイッチバック

flutter checkout master
flutter upgrade
flutter run
2
tdmiller

次のようにしてFlutterをアップグレードしてみてください。

flutter upgrade 

(この問題は最新のアップデートで修正されています。)

2
Niyas Ali

私にとっては、 gradle-wrapper.properties ファイルを開いて以下の行をこのバージョンのように編集することで解決しました。

distributionUrl=https\://services.gradle.org/distributions/gradle-4.10.2-all.Zip

1
user1182364

私はまたバタバタ初心者で、今日それをインストールしました。そして、私はあなたと同じ問題を見つけました、しかし3時間のグーグルの後に私はついにそれを解決しました。

私が行ったステップは次のとおりです。

  1. " https://github.com/flutter/flutter/blob/master/packages/flutter_tools/gradle/flutter.gradle "から "flutter.gradle"ファイルを "C:\ flutter\packages\gradle"にコピー

  2. 次に、この部分の内容を変更します。

    buildscript {
        repositories {
            google()
            jcenter()
        }
        dependencies {
            classpath 'com.Android.tools.build:gradle:3.2.1'
        }
    }
    

    に:

    buildscript {
        repositories {
            maven {
                    url 'https://dl.google.com/dl/Android/maven2'
            }
            jcenter()
        }
        dependencies {
            classpath 'com.Android.tools.build:gradle:3.2.1'
        }
    }
    
  3. 「c:\ flutter\bin」で、次のコマンドを実行します。

    flutter channel master
    

    終了するまで待ってから、次のコマンドを実行してください。

    flutter upgrade
    
  4. 終了するまで待ってから、プロジェクトを再実行してデバッグします。

  5. そして最後に、アプリケーションがエミュレータ画面に表示されました。

    ついに実行中の画像

これまでのすべての答えは問題を解決します。追加する1つのコメントは flutte.gradle の場所です。

Flutterプロジェクトではなく、初めてFlutterをインストールしたディレクトリにあります。

1
Mohamed Dernoun

このエラーに遭遇したとき、Flutter 1.0がリリースされていました。以前の問題は修正され、それでも私は同じエラーを受けていました。

以下の手順で修正しました。

1) 'dependencies'セクション内のyour_project/Android/build.gradleでGradleプラグインのバージョンを3.1.2から3.2.1に変更 -

dependencies {
        classpath 'com.Android.tools.build:gradle:3.2.1'
    }

2)your_project/Android/gradle/wrapper/gradle-wrapper.propertiesでGradleラッパーのバージョンを4.4から4.6に変更

distributionUrl=https\://services.gradle.org/distributions/gradle-4.6-all.Zip
1
Harisewak

これらの文を置き換えるだけで修正できます。

allprojects {
    repositories {
        mavenCentral()
        jcenter()
        maven {
            url 'https://maven.google.com/'
            name 'Google'

        }
    }
}

これらの代わりに:

allprojects {
    repositories {
        jcenter()
        google()
    }
}

build.gradleファイルで、依存関係でcompileimplementationに置き換えます。

0
Mohsen Hrt

アップデートバージョンbuild.gradleで修正しました

dependencies {
        classpath 'com.Android.tools.build:gradle:3.3.2'
        ..............
}
0
Triệu Đô La