webdevqa.jp.net

Gradleバージョン1.10が必要です。現在のバージョンは2.0です

最新のGradleバージョン(2.0)を使用しようとしていますが、ターミナルでgradle buildを押すとこのメッセージが表示され続けます。 1.10バージョンが必要なのはなぜですか?私はGradleに慣れていないので、頭を悩ませようとしています。

Gradleバージョン1.10が必要です。現在のバージョンは2.0です

ここに私の依存関係があります(モジュールbuild.gradleファイル):

dependencies {
    classpath 'com.Android.tools.build:gradle:0.12.+'
    classpath fileTree(dir: 'build-libs', include: '*.jar')
}

...およびラッパータスク:

task wrapper(type: Wrapper) {
    gradleVersion = "2.0"
}

また、次のように配布URLを設定しました(local.propertiesファイル内):

distributionUrl=https\://services.gradle.org/distributions/gradle-2.0-all.Zip

最後に、File->Settings->Gradleで[カスタマイズ可能なgradleラッパーを使用する]を選択しました

GRADLE_HOMEはC:\ Program Files(x86)\ Gradle\gradle-2.0に設定されます

Build.gradleファイル:

buildscript {

    repositories {
        mavenLocal()
        mavenCentral()
    }

    dependencies {
        classpath 'com.Android.tools.build:gradle:0.12.+'
        classpath fileTree(dir: 'build-libs', include: '*.jar')
    }
}


task wrapper(type: Wrapper) {
    gradleVersion = "2.0"
}

PDATE1

現状では、このAndroid St​​udio 1.1.0と1.1.0-rc1プラグインバージョンを使用しています。

    dependencies {
    classpath 'com.Android.tools.build:gradle:1.1.0-rc1'
}

Gradle-wrapper.propertiesのGradleバージョンは2.3

distributionUrl=http\://services.gradle.org/distributions/gradle-2.3-all.Zip

プラグインバージョン1.1.0を試しましたが、com.Android.applicationについて文句を言います

2016年1月更新

現状では、gradleでgradle 2.9ディストリビューションを使用しています-> wrapper-> gradle-wrapper.properties

distributionUrl=https\://services.gradle.org/distributions/gradle-2.9-all.Zip

プラグインは

classpath 'com.Android.tools.build:gradle:1.5.0'
80
Nabdreas

Android gradleプラグインのバージョンは、Gradleのバージョンと互換性がある必要があります。 バージョン互換性マッピングテーブル をチェックアウトします。

compatibility mapping table

66
lucas

メッセージ:「Gradleバージョン1.10が必要です。現在のバージョンは2.0です」

次の場合に発生しますネイティブとして2.0バージョンを使用しているときに1.10バージョンのGradleを必要とするAndroidプロジェクトをビルドしようとしています。

ソリューション: Gradle Wrapperの使用

手順:

  1. Androidプロジェクト内のGradle-wrapperプロパティファイルでdistributionUrlgradle-1.10-all.Zipとして指定されていることを確認してください。ファイルパスは次のようになります。

    MyAndroidProject/gradle/wrapper/gradle-wrapper.properties

  2. 実行可能スクリプト(gradlewおよびgradlew.bat)が配置されているプロジェクトの最上位レベルでGradle Wrapperコマンドを実行します。

    nixのような OSの場合:

    ./ gradlew wrapper

    Windows OSの場合:

    gradlew.bat wrapper

  3. Gradle Wrapperでビルドコマンドを実行します。

    nixのような OSの場合:

    ./ gradlew build

    Windows OSの場合:

    gradlew.bat build

64
wono

Build.gradleファイル内のgradleバージョンを更新する問題を修正します。

dependencies {
classpath 'com.Android.tools.build:gradle:0.12.2'

}

これで問題が解決します。これが役立つことを願っています。

16
Mr.Moustard

Android Gradleプラグインの現在のバージョン(0.12.2)は、1.12以降のバージョンのGradleで動作するようです。

私はツールサイトでそのための直接の声明を見つけていません、このフレーズのみがあります:

プラグイン0.11.1を使用したGradle 1.10または1.11または1.12。

しかし、Gradle 2.0および1.2を使用して手動でテストしたところ、動作しません。したがって、ツールサイトのこの制限はAndroid Gradleプラグイン0.12.2にも適用されると思います。

distributionUrl=http\://services.gradle.org/distributions/gradle-1.12-bin.Zipファイルにgradle-wrapper.propertiesを設定して、Gradle 1.12にフェールバックすることをお勧めします。

次に、通常どおりgradlewを使用します。

5
Alexey Dmitriev

Androidプラグインには、Gradleの特定のバージョンが必要です。最新のAndroidプラグインバージョンには1.12が必要で、ビルドで宣言されたAndroidプラグインバージョンには1.10が必要です。

4

Macでwonoの方法に従っていましたが、「gradlew command not found」エラーが発生していました。 gradlewファイルのmodを変更することによる問題を修正

chmod + x gradlew

これが他の人の助けになることを願っています

2
Raheel

上記の修正が機能しない場合、これを試してください

build.gradleのこの行を変更する必要があります

classpath 'com.Android.tools.build:gradle:0.9.+'

classpath 'com.Android.tools.build:gradle:1.1.+'

build.gradleのこの行を変更する必要があります

buildTypes {
        release {
            runProguard false
            proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.txt'
        }
    }

buildTypes {
        release {
             minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.txt'
        }
    }
0
kumar kundan

古いAndroidスタジオを使用して開発されたプロジェクトを新しいAndroid St​​udioに移動したためにこの問題が発生する場合は、新しいAndroid St​​udioで新しいプロジェクトを作成し、クロスチェックします新しくプロジェクトを作成するためのgradle関連ファイル。

0
Praveena