webdevqa.jp.net

Gradleプラグインを解決するにはStudio 3.0以上が必要です

プロジェクトのインポート時にError:This Gradle plugin requires Studio 3.0 minimumを取得しています
プロジェクトリポジトリ: https://github.com/chrisbanes/cheesesquare
here および here しかし、何も働いていません:(

22
Vaibhav Singh

インポートしようとしているリポジトリは、gradle build tools 3.0.0およびgradle 4.0を使用します。これらはAndroid St​​udio 2.3ではサポートされていません。つまり、プロジェクトはAndroid St​​udio 3.0プレビューでのみ開くことができます。

あなたのオプション:

1) Android studio 3.0プレビューをダウンロード プロジェクトで使用

2)リポジトリをチェックアウトし、直前に戻します commit 822b84a1e58126412f708745d8bcee5a525620ae (最新バージョンのgradleへの変換が行われた場所)

16
Oleg Filimonov

オプション#1:Android St​​udio 3.0にアップグレードするまで、プロジェクトをインポートしないでください。

オプション#2:プロジェクトを変更します。

  • プロジェクトレベルbuild.gradleを変更して、com.Android.tools.build:gradle:2.3.3ではなくcom.Android.tools.build:gradle:3.0.0-alpha6を参照するようにします

  • gradle/wrapper/gradle-wrapper.propertiesの代わりにhttps\://services.gradle.org/distributions/gradle-3.3-all.Zipを参照するようにhttps\://services.gradle.org/distributions/gradle-4.1-milestone-1-all.Zipを変更します

  • プロジェクトをインポートし、作成者が変更したものに依存していないことを祈ります

16
CommonsWare

取り替える

    classpath 'com.Android.tools.build:gradle:3.0.0-alpha4'

    classpath 'com.Android.tools.build:gradle:2.3.3'

プロジェクトのbuild.gradleファイル。

8
younes

このエラーは、作成されたプロジェクトstudio 3.0以降Android Studio 2.3.3以前にインポートしようとすると発生します。以下のスタジオで動作するように次の変更を行います3

1)Project gradleで設定の下に追加:

buildscript {

repositories {
    jcenter()
    mavenCentral()
}
dependencies {
    classpath 'com.Android.tools.build:gradle:2.3.3'

    // NOTE: Do not place your application dependencies here; they belong
    // in the individual module build.gradle files
}

}

2)アプリ(またはモジュール)gradleファイル

もしあれば、次の行を削除します

compileOptions {
    targetCompatibility 1.8
    sourceCompatibility 1.8
}

そして、すべてを変更します実装およびannotationProcessor依存関係コンパイルする以下のように

dependencies {
implementation fileTree(include: ['*.jar'], dir: 'libs')

implementation 'com.Android.support:appcompat-v7:26.1.0'   
implementation 'com.Android.support.constraint:constraint-layout:1.0.2'
implementation 'Android.Arch.lifecycle:runtime:1.0.0'
implementation 'Android.Arch.lifecycle:extensions:1.0.0-alpha9-1'
annotationProcessor "Android.Arch.lifecycle:compiler:1.0.0-alpha9-1"
implementation 'Android.Arch.persistence.room:runtime:1.0.0-alpha9-1'
annotationProcessor "Android.Arch.persistence.room:compiler:1.0.0-alpha9-1"
implementation 'Android.Arch.paging:runtime:1.0.0-alpha1'
implementation 'com.Android.support:recyclerview-v7:26.0.2'

}

To

dependencies {
//implementation fileTree(include: ['*.jar'], dir: 'libs')
compile fileTree(include: ['*.jar'], dir: 'libs')

compile 'com.Android.support:appcompat-v7:26.1.0'

compile 'com.Android.support.constraint:constraint-layout:1.0.2'
compile 'Android.Arch.lifecycle:runtime:1.0.0'
compile 'Android.Arch.lifecycle:extensions:1.0.0-alpha9-1'
compile "Android.Arch.lifecycle:compiler:1.0.0-alpha9-1"
compile 'Android.Arch.persistence.room:runtime:1.0.0-alpha9-1'
compile "Android.Arch.persistence.room:compiler:1.0.0-alpha9-1"
compile 'Android.Arch.paging:runtime:1.0.0-alpha1'
compile 'com.Android.support:recyclerview-v7:26.0.2'

}

7
Rahul_Pawar

私は同じ問題に直面していましたが、次の手順を使用してgradleとAndroidプラグインのバージョンを変更することで解決できます。

ファイル->プロジェクト構造->プロジェクト-> gradleバージョンを3.3に変更し、Androidプラグインバージョンを使用中のAndroidスタジオバージョンに変更します。 ->プロジェクトを再構築します。

enter image description here

以前のgradleバージョンにはなかったメソッドについては、エラーが発生する場合があります。コメントのいずれかで言及したものGradleError:(25、0)Gradle DSLメソッドが見つかりません: 'implementation()'は置き換えることで解決できますコンパイルによる実装。

問題を解決したかもしれませんが、他の人を助けるかもしれません。

6
DarkShadow

see the solution or problem こんにちは、私はこの問題を解決しましたAndroid studio ideバージョンを最初にチェックすることを説明したいので、ide 1.5を使用している場合はgradleバージョン3.0+を使用できません。

1
Lalit Baghel