webdevqa.jp.net

Gradle Syncが失敗し、constraint-layoutが見つかりませんでした:1.0.0-alpha2

問題:

Error:Could not find com.Android.support.constraint:constraint-layout:1.0.0-alpha2.
Required by:
myapp:app:unspecified

背景: / Android Studio 2.2 P 1

135
Chulo

ConstraintLayoutのサポートライブラリをインストール/アップデートできませんでした。

Preferences> Appearance & Behavior> System Settings> Androidを開いてSDK Toolsタブに移動するだけです。以下の項目を確認してインストールしてください。

Preferences

322
gokhanakkurt

私の場合は、ConstraintLayoutのサポートライブラリがインストールされていましたが、build.gradleファイルに間違ったバージョンのConstraintLayoutライブラリを追加していました。インストールしたバージョンを確認するには、Preferences> Appearance & Behavior> System Settings> Android SDKにアクセスしてください。今、右ペインのSDK Toolsタブをクリックしてください。 Show Package Detailsをチェックしてバージョンを書き留めます。

enter image description here

最後に、正しいバージョンをbuild.gradleファイルに追加できます。

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile 'com.Android.support.constraint:constraint-layout:1.0.0-alpha9'
    testCompile 'junit:junit:4.12'
}
123
jmartinalonso

これを修正するには、build.gradleのAndroid gradleプラグインを更新します。

これは動作するはずです。クラスパス 'com.Android.tools.build:gradle:2.2.0-alpha2'

あるいは、最新のものを使うこともできます。クラスパス 'com.Android.tools.build:gradle:2.2.0-alpha3'

14
Johnny

私の場合は1.0.0-alpha9でしたが、私のgradle依存関係は

'com.Android.support.constraint:constraint-layout:1.0.0-alpha8'をコンパイルします。ですから、グラドルビルドファイルを次のように変更できます。

'com.Android.support.constraint:constraint-layout:1.0.0-alpha9'をコンパイルするか、SDKツールエディタの[パッケージの詳細を表示]をチェックして、必要なバージョンをインストールします。下のスクリーンショットを見てください。 SDKツールの画像

enter image description here

12
Anshul Agarwal

私は自分のAndroid gradleプラグインを2.2.0-alpha4に更新し、レイアウトの依存関係を1.0.0-alpha3に更新しましたが、現在は動作しているようです

8
sven

まず最初に、スタックオーバーフローについて読んだことをすべて試してみました。GledleからXYバージョンへの更新、ConstraintLayoutからXYバージョンへの更新、そしてSDKツールおよびAndroid Studioの最新バージョンへの更新も可能でした。

唯一の解決策は、gradleとSDKからConstraintLayoutライブラリを削除してから、ランダムなxmlレイアウトを開き、PaletteセクションのDesignビューConstraintLayoutを検索することです。プロジェクトから正しくライブラリを削除した場合は、ConstraintLayout要素をダブルクリックすると、そこからライブラリをインストールすることができます。

それが私のアプリbuild.gradleに次の行を作成しました:

'com.Android.support.constraint:constraint-layout:1.0.0-beta1'

私のプロジェクトbuild.gradleでは、これがあります。

classpath 'com.Android.tools.build:gradle:2.2.2'

Androidスタジオバージョン2.2.2

6
BVantur
  1. モジュールレベルのbuild.gradleファイルrepositories { maven { url 'https://maven.google.com' } }でmaven.google.comリポジトリが宣言されていることを確認してください。

2.同じbuild.gradleファイルに依存関係としてライブラリを追加します。

dependencies {
compile 'com.Android.support.constraint:constraint-layout:1.0.2'
}
5
Rohan

スタジオバージョン2.3では、sdkツールでconstraint-layoutの近くにドロップダウンが表示されないようにするために、デフォルトで最新バージョンがインストールされます。

希望のバージョンを入手するには、パッケージの詳細とブームを表示するボックスをチェックして、インストールしたい希望のバージョンを選択できます。

3
madhur

グラドルcom.Android.tools.build:gradle:2.2.0-alpha6

制約レイアウトの依存関係com.Android.support.constraint:constraint-layout:1.0.0-alpha4

私のために働く

1
lukle

私にとっては全く別の問題でした。 SDKツールに制約依存関係をインストールしたとき、ツールはどういうわけかそれらを wrong ディレクトリに書き込みました。あれは

/home/${USER}/Android/Sdk/extras/+m2repository+/com/.../constraint

の代わりに

/home/${USER}/Android/Sdk/extras/+Android+/+m2repository+/com/.../constraint

救済策:

1.0.0-alpha*ディレクトリを後者のパスにコピーするだけです。

1
peter

私の場合は、まず以前のバージョンを削除し、代わりに最新のバージョンをダウンロードする必要がありました。 v1.0 stableが2月23日にリリースされました。 enter image description here

1
mhdtouban

私の場合は、AS 2.3を使用していましたが、現在最新のConstraintLayout 1.1.3を使用したいのですが、Preferences> Appearance&Behavior> System Settings> Androidの最新バージョンは1.0.2でした。

ConstraintLayout 1.1.3を使用するには、ASを2.3から現在最新の3.2.1に、com.Android.tools.build:gradleを2.2.2から3.2.1に、gradleを3.3から4.6に、buildToolsVersionを25.0.0から28.0.3。

また、プロジェクトレベルのbuild.gradleファイルのMavenリポジトリにmaven {url ' https://maven.google.com '}を追加したところ、問題は解決しました。

1
Allan

SDKツールのアップデート中に、インストールされる予定の制約レイアウトバージョンが表示されたダイアログボックスが表示されました。それに注意し、それに基づいてあなたの依存関係を更新してください。私の場合はbeta3をインストールしていました。

私は以下のように依存関係を変更しました。その後それは働いた。

'com.Android.support.constraint:constraint-layout:1.0.0-beta3'をコンパイルしてください。

私はクラスパス 'com.Android.tools.build:gradle:2.1.0'でcom.Android.support.constraint:constraint-layout:1.0.0-alpha2を使用しました、それは魅力のように働きました。

0
androidStud

Android Studioを再インストールすることで解決した同様の問題。

0
spacedev

制約レイアウトの依存関係を「1.0.0-alpha2」から関連するバージョンに更新してください。私の場合は、次のように変更しました。 'com.Android.support.constraint:constraint-layout:2.0.0-alpha5'をコンパイルします。

0

私の場合は、 "app"と "sdk"というマルチモジュールプロジェクトがありました。 "sdk"モジュールは、私が制約レイアウトライブラリを追加したものです。 「sdk」を「app2」という新しいマルチモジュールプロジェクトに組み込もうとしたときにエラーが発生しました。解決策は、 "app2"のプロジェクトレベルのbuild.gradleファイルにGoogle Mavenリポジトリを確実に追加したことです。 Google Mavenリポジトリは、プロジェクトレベルのbuild.gradleファイルのallprojects.repositoriesの下に "google()"を追加することで追加できます。

allprojects {
    repositories {
        jcenter()
        google()
    }
}
0
Michael Osofsky

次のパッケージとしてandroidxで利用可能

implementation "androidx.constraintlayout:constraintlayout:2.0.0-alpha1"
0
Uzair

手遅れかどうかはわかりませんが、SDK ToolsでConstraintLayoutとSolverを更新した後でまだエラーが発生する場合は、この解決策が役立つことがあります。 エラー:(30、13) Android.support.constraint:制約レイアウト:1.0.0-alpha4

0
Camino2007