webdevqa.jp.net

Gradle Version 2.10が必要です。エラー

私が使ってきたように

classpath 'com.Android.tools.build:gradle:+'

build.gradle ファイルでは、 gradleバージョン2.10 がリリースされているので、次のエラーが発生しました。エラーは次のとおりです。

警告:Gradleバージョン2.10が必要です。現在のバージョンは2.8です。グラドルラッパーを使用している場合は、C:\ Users\blahblah\myproject\gradle\wrapper\gradle-wrapper.propertiesにあるdistributionUrlをgradle-2.10-all.Zipに編集してみてください。

最初はこのガイドで解決しやすいように見えますが、変更を加えたときにもう一度エラーが発生しました。

私は/ =を使用しています Android Studio 2.0 最新の Android SDKツール24.4.1 および Android SDKビルドツール23.0.2

Gradle 2.10 をダウンロードして、Android-studio\gradle \フォルダに手動で配置しようとしたこともありますが、運が悪いです。

任意の助けがいただければ幸いです。

244
SalmanShariati

ファイル>設定>ビルド、実行、配置>ビルドツール> Gradle> Gradle homeパスを変更する必要があります。

Mac OSでは、Android Studio>設定>ビルド、実行、デプロイ>ビルドツール> Gradle> Gradle homeでパスを変更します。

またはデフォルトのグラドルラッパーを使用して、次のようにProject\gradle\wrapper\gradle-wrapper.properties filesフィールドを編集するdistributionUrl

distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.Zip
393
adrbtk

環境設定を開いてGradleを検索するか、ビルド、実行、配置>ビルドツール> Gradleに移動します。

次に、プロジェクトレベル設定をUse default gradle wrapper (recommended)に変更します

または、ローカルの小学校の授業配給オプションをそのままにして、Gradleを/.../gradle-2.10 に設定します。

Preference screen - Gradle

モジュール設定でGradleのバージョンが既に2.10に設定されていることを確認してください。

プロジェクトウィンドウで、プロジェクトを右クリックしてからOpen Module Settings+

Open Module Settings Project > Gradle version and enter 2.10

更新

Gradleバージョン:3.3Androidプラグインバージョン:2.3.1

86
M'hamed

これを達成するためのもっと簡単な方法は次のところに行くことです: オープンモジュール設定(あなたのプロジェクト)>プロジェクト> Gradleバージョン そして2.10を入力してください

52
cmota

最新のgradle-3.0-all.Zipをからダウンロードしてください。

http://gradle.org/gradle-download/ /

完全配布リンクからダウンロード

androidのスタジオファイルで開く - >設定 - > gradle

パスを開き、ダウンロードしたZipフォルダgradle-3.0をそのフォルダに貼り付けます。

ファイルでグラドル2.8をグラドル3.0に変更します - >設定 - >グラドル

または、プロジェクトでグラドルラッパーを変更することもできます。

yourProject\gradle\wrapper\gradle-wrapper.propertiesファイルを編集し、フィールドdistributionUrlを次のように編集します。

distributionUrl = https://services.gradle.org/distributions/gradle-3.0-all.Zip

41

Ionic/Cordovaフレームワークを使用している人々のために、GradleBuilder.jsファイルのdistributionUrlvar distributionUrl = process.env['CORDOVA_Android_GRADLE_DISTRIBUTION_URL'] || 'http\\://services.gradle.org/distributions/gradle-2.10-all.Zip';に変更する必要があります

GradleBuilder.jsproject/platforms/Android/cordova/lib/builders/GradleBuilder.jsにあります

15
nigong

最初に プロジェクトレベルの設定を確認してください at

ファイル>設定>ビルド、実行、配置>ビルドツール> Gradle

そしてオプションを選択します。

  • デフォルトのグラドルラッパーを使用する(推奨)

それからProject'sに行きます

Gradle>ラッパー> gradle-wrapper.properties

distributionUrlのバージョンを編集

distributionUrl = https://services.gradle.org/distributions/gradle-2.10-all.Zip

そして、これで終わりです:)

11
Ashish Shukla

Android studio v2.1の場合

画像からこれらの簡単な手順に従ってください。

  1. 「ファイル」に進み、「プロジェクト構造」をクリックします。 Opening project structure settings for the project

  2. 次に、左側のメニューから[プロジェクト]を選択し、[Gradle version]をSDKマネージャーがインストールしたバージョンに変更します。私の場合は2.10ですので、バージョンを2.10に変更し、[OK]をクリックします。その後、Android studioが自動的に再度gradle同期を行い、エラーが修正されました。 Changing gradle version to the latest installed version for the project

10
Amit Tumkur

私がこの問題を解決するための最も簡単な方法:

  1. iDEを閉じます。
  2. 「gradle」フォルダを削除
  3. プロジェクトを再度開きます。
8

イオンを使用する人は、
[project name]/platforms/Android/cordova/lib/builders/GradleBuilder.js

164行目にが表示されます。
var distributionUrl = process.env['CORDOVA_Android_GRADLE_DISTRIBUTION_URL'] || 'http\\://services.gradle.org/distributions/gradle-2.13-all.Zip';

この行はあなたのgradle-wrapper.propertiesを作成するために使われるので、gradle-wrapper.propertiesへのどんな変更も関係ありません。あなたがする必要があるのは最新版にURLを変えること、gradleを同期させることだけで問題は解決します。

Androidスタジオでgradleのバージョンを変更したい場合はFile>settings>projectに移動してgradleのバージョンを変更してください。適用後、プロジェクトが同期され、ビルドする準備が整いました。

3
roger

問題が解決しない場合は、最上位プロジェクトのbuild.gradleに次のコードを追加します。

buildscript {
System.properties['com.Android.build.gradle.overrideVersionCheck'] = 'true'

...
}
3
saintjab

私は以前に同じ問題に遭遇しました。

結局、問題はあなたが端末を使うことです。システム設定を使用します。

あなたが設定したかどうか、それをチェック

"GRADLE_HOME=.\gradle-2.10" 

それが役に立てば幸い

3
user5327869

Androidビルドシステムは、Gradleビルドツールキットを使用したAndroidアプリケーションのビルドをサポートするために、Androidプラグインfor Gradleを使用します。プラグインはAndroid Studioとは無関係に動作するので、プラグインとGradleビルドシステムはAndroid Studioとは無関係に更新することができます。

グラドルラッパーを使用(推奨) - Gradleラッパーを使用するにはこのオプションを選択します。 Gradleラッパーを使用すると、ビルド用の自動Gradleダウンロードを取得できます。また、正確なGradleバージョンを使ってビルドすることもできます。

Gradleプラグインの新しいバージョンでは、IDEの新機能を有効にするために新しいバージョンのStudioが必要になる場合がありますが、プロジェクトは古いバージョンのStudioで開いてそこからビルドする必要があります私達はこれについて非常に慎重になるでしょう。

Click on Settings -> Build -> Execution -> Deployment ->
Gradle -> Select  default gradle wrapper

あなたは使うことができます

classpath 'com.Android.tools.build:gradle:2.0.0-alpha3'  // or alpha2
Or //classpath 'com.Android.tools.build:gradle:2.1.3'
3
IntelliJ Amiya

重要:

あなたが実行したときにあなたがこれを得ているならば:
gradle build
コマンドラインから使用する必要があります。
gradlew build
代わりにを使用して、アプリに必要な適切なgradleバージョンをダウンロードするためにgradle wrapperを使用します。

gradle buildを実行すると、システムにインストールされているグローバルグレードを使用していることになります。

2
dsharew

私にとっては、以前の解決策はすべて失敗したので、編集しただけです。

Project\gradle\wrapper\gradle-wrapper.properties -> field distributionUrl 
distributionUrl=https\://services.gradle.org/distributions/gradle-2.8-all.Zip

distributionUrl=https://services.gradle.org/distributions/gradle-2.10-all.Zip
2
Fasiha

「ファイル」 - >「設定」 - >「ビルド」、「実行」、「デプロイメント」 - >「Gradle」 - >「Use default gradle wrapper」の順に選択します。

2
Lenny

あなたはchange Prefrences > Builds,Execution,Deployment > Build Tools > Gradle >Gradle home pathする必要があります

または、デフォルトのグラドルラッパーを使用を設定し、Project\gradle\wrapper\gradle-wrapper.propertiesファイルのフィールドdistributionUrlを次のように編集します。

distributionUrl = https://services.gradle.org/distributions/gradle-2.10-all.Zip

1

私の問題は違うかもしれないので、私は私と同じ問題を抱えているかもしれない誰かに言いたいだけです。

ターミナルパスを変更してこの問題を解決しました。 gradle cleanを実行すると、エラーは "Gradle version 2.10 is required. Current version is 2.2.1"をまたいで発生します。

私は自分のプロジェクトで.gradleディレクトリをチェックしました。そこには2つのバージョンがあります:2.2.1、2.10。

gradle -vを実行すると、現在のバージョンが2.2.1であることがわかります。私は自分のシステム環境をGRADLE_HOME2.10ルートディレクトリに変更してから、ASでターミナルを再起動して 'gradle -v'を実行します。それでも現在のバージョンは2.2.1です。

設定を開く - >ターミナルcmd.exeパスをSystem32/cmd.exeに変更します。それからterminalを再起動し、gradle cleanを実行してください。

1
Freddy

Ubuntu 14.04をベースにしたMint 17.03で私のために働いたこと

Sudo add-apt-repository ppa:cwchien/gradle Sudo apt-getアップデートSudo apt-getインストールgradle

Android Studioを再度開きます。 Run/Debug Configurationに行き、Gradleを更新する必要があるというアイコンが表示されます。クリックするだけです。

1
CESCO

Android Studioバージョン1.5.1がインストールされていて、このエラーが発生していました。私は次のビルドスクリプトを持っています(これはUbuntuでは動作していましたが、Windowsでは動作していませんでした)。

buildscript {
    dependencies {
        classpath 'com.Android.tools.build:gradle:2.1.0'
    }
}

私は試した:

  1. gradlew clean
  2. デフォルトのグラドルラッパーを使用する(推奨)
  3. ローカルディストリビューションを使用してダウンロードしたgradle 2.2.1バイナリにリンクする

残念ながらこれらの解決策のどれもうまくいきませんでした。 Android Studioを1.5.1から2.1.1にアップグレードすると、2.10が欠落しているというエラーも発生したため、実行できないことに注意する必要があります。

解決策: 私がやめたのは、単に最新の安定版のAndroid Studioをダウンロードし、代わりにそれをインストールすることでした(当時の2.1.1)。正常に同期されたそのgradleを実行した後

1
alexgophermix

私は同じ問題を抱えていてstackoverflowの答えが助けにならなかった。しかし、私は自分のプロジェクトで問題を見つけました。それは私の.gitignoreファイルがこれらの行を含んでいたからです:

# Package Files #
*.jar
*.war
*.ear

これが、gitがMyProject\gradle\wrapper\gradle-wrapper.jarファイルをremoteにアップロードしなかった理由です。だから、私はこの行を.gitignoreに追加しました:

!/gradle/wrapper/gradle-wrapper.jar

この行も持っていることを確認してください。少なくともこれで私の問題は解決しました

1
emiraslan

ターミナルタイプでは、クリーンルードル。それは自動的にgradleバージョン2.10をダウンロードしてインストールします(すなわち利用可能な最新のgradle verson)

例:C:\ Android\workspace\projectname> gradlew clean

0
killers

このエラーがある場合、 "Gradleのバージョンは2.14.1をサポートしています。現在のバージョンは2.4です。" 、端末上。グラドルを更新する必要があることを意味します。

Mac OSの場合: brew upgrade gradle を使用できます。

0
lingyfh

最新の成績

最新のgradle-3.3-all.Zipをからダウンロードしてください。

http://gradle.org/gradle-download/

1.完全配布リンクからのダウンロード

Androidのスタジオファイルで2.open - >設定 - > gradle

3.パスを開き、ダウンロードしたZipフォルダgradle-3.3をそのフォルダに貼り付けます

4.ファイルでグラドル2.8をグラドル3.3に変更します - >設定 - > gradle

5.またはプロジェクトでグラドルラッパーを変更できます

6. YourProject\gradle\wrapper\gradle-wrapper.propertiesファイルを編集し、フィールドdistributionUrlを次のように編集します。

distributionUrl = https://services.gradle.org/distributions/gradle-3.0-all.Zip

Androidスタジオのgradleファイルに表示

私の場合、問題はgradle-wrapper.propertiesファイル内のdistributionURLとAndroid Studioの自動修正挿入に実際にありました

distributionUrl = https://services.gradle.org/distributions/gradle-4.0-20170417000025+0000-all.Zip

しかし、これは間違ったURLです。正しいのは

distributionUrl = https://services.gradle.org/distributions-snapshots/gradle-4.0-20170417000025+0000-all.Zip

どうやらURLはgradleのAPIでは変更されましたが、Android Studioでは変更されなかったので、手動で修正して問題を解決しました。

0

最新バージョンのGradleをサポートするために、私のバージョンのCordovaをアップグレードする必要がありました。 GradleBuilder.jsのdistributionUrlを更新してもうまくいきませんでした。

0
Steve W

場合によっては、プロジェクトの問題解決やAndroid-studioに問題がないためうまくいかないことがあります。

ステップ1:

サポートされているGradleの最小バージョンは2.14.1です。現在のバージョンは2.11です。グラドルラッパーを使用している場合は、distributionUrlを編集してみてください。

  • あなたのシステムのgradleバージョンをチェックしてくださいgradle -version
  • 古いバージョンのアップグレードグレードバージョンbrew install gradle

ステップ2

  • Android-スタジオ - >設定 - >ビルド、実行、デプロイ - > Gradleに移動します。

  • デフォルトのグラドルラッパーを使用し、オフライン作業のマークを解除する

ステップ3

  • Gradle-wrapper.propertiesのdistributionUrlを確認してください。

  • 古いバージョンの場合はアップグレードしてください。

  • クリーンプロジェクト

0

これは私のために働きます。

androidスタジオで新しいプロジェクトを作成します。プロジェクト設定を開き、ローカル許可パスをコピーします。現在、問題を抱えているプロジェクトを開き、そのURLを貼り付けてローカルパスを選択します。

適用問題をクリックすると解決されます。

0
Muhammad Dawood