webdevqa.jp.net

N Developer Previewの適切なプロジェクト構成は何ですか?

ドキュメントは、このようにbuild.gradleが機能すると主張しています。

Android {
  compileSdkVersion 'Android-N'
  buildToolsVersion 24.0.0
  ...

  defaultConfig {
     minSdkVersion 'N'
     targetSdkVersion 'N'
     ...
  }
  ...
}

Android Plugin for Gradle and Gradle 2.5)にfailed to find Build Tools revision 24.0.0を使用すると、'com.Android.tools.build:gradle:1.5.0'が得られます。

Android SDKインストールでbuild-tools/を見ると、24.0.0-previewではなく24.0.0が表示されます。ただし、build.gradleを切り替えるとbuildToolsVersion "24.0.0-preview"を使用するには、Invalid revision: 24.0.0-previewを取得します。

では、build.gradle値のどのような組み合わせが、N Developer Preview SDKに対してコンパイルするプロジェクトを構築するために機能しますか?

11
CommonsWare

サンプルアプリの1つ に基づいて、私は現在使用しています:

  • Gradle 2.10
  • 'com.Android.tools.build:gradle:2.1.0-alpha1' for Android Plugin for Gradle(トップレベルのbuild.gradleファイルに含まれます)
  • buildToolsVersion "24.0.0 rc1"

これは、Android Studio 1.5.1を含め、持ちこたえているようです。

[〜#〜] update [〜#〜]:N Developer Preview 4がリリースされたので、24の使用を開始できます。 "N""Android-N"の場所:

Android {
    compileSdkVersion 24
    buildToolsVersion "24.0.0"

    defaultConfig {
        minSdkVersion 24
        targetSdkVersion 24
    }
}
3
CommonsWare

buildToolsVersion 24.0.0を使用したために問題が発生したと思います。

公式セットアップガイド によると、使用:

  compileSdkVersion 'Android-N'
  buildToolsVersion '24.0.0 rc1'

  defaultConfig {
    minSdkVersion 'N'
    targetSdkVersion 'N'
    ...
  }

「N」以外のminSdkVersionも同様に機能しますが、とにかくアプリを実行するには「N」デバイスを使用する必要があることに注意してください。

Gradle 2.4は私のために動作します。また、プレビューで説明されているように、 'com.Android.tools.build:gradle:2.1.0-alpha1'を使用する必要はありません- サンプルclasspath 'com.Android.tools.build:gradle:1.5.0'の使用も同様に機能します。

 dependencies {
     classpath 'com.Android.tools.build:gradle:1.5.0'
     ...
 }

Java 8 JDKおよびJREを取得することを忘れないでください。'Nで動作させるために必要です。 'ただし、Java 8機能を使用しない場合は、sourceCompatibility JavaVersion.VERSION_1_7およびtargetCompatibility JavaVersion.VERSION_1_7を設定できます。

注:新しいJava 8言語機能を使用することは、Android Nプラットフォームを対象とするアプリを開発するための要件ではありません。コードを記述したくない場合Java 8言語機能を使用すると、プロジェクトのソースとターゲットの互換性の値をJava 7に設定したままにすることができますが、ビルドするにはJDK8でコンパイルする必要がありますAndroid Nプラットフォーム。

詳細については、 Java 8言語機能 を確認してください。

3
Ivan V

PixelCを使用した新しいプロジェクトで、この構成を使用するとかなりうまくいくようです。

Android {
    compileSdkVersion 'Android-N'
    buildToolsVersion '24.0.0 rc4'

    lintOptions {
        abortOnError false
    }


    defaultConfig {
        minSdkVersion 'N'
        targetSdkVersion 'N'

        jackOptions {
            enabled true
        }
    }

    compileOptions {
        sourceCompatibility JavaVersion.VERSION_1_8
        targetCompatibility JavaVersion.VERSION_1_8
    }

...
}
1
user5640015

に基づく サンプルプロジェクト 使用する必要があります

Android {
    compileSdkVersion 'Android-N'
    buildToolsVersion '24.0.0 rc1'

    defaultConfig {
        applicationId "com.Android.multiwindowplayground"
        minSdkVersion 'N'
        targetSdkVersion 'N'
  ....

    }

    compileOptions {
        sourceCompatibility JavaVersion.VERSION_1_7
        targetCompatibility JavaVersion.VERSION_1_7
    }
}
  • Android Studio2.1プレビュー
  • Gradle-2.10-all.Zipを使用する
  • com.Android.tools.build:gradle:2.1.0-alpha1 for Android Plugin for Gradle(トップレベルbuild.gradleファイルに含まれます)
  • buildToolsVersion "24.0.0 rc1"
  • Nを選択します:Android API 23、Nプレビュー(プレビュー)。それは私のために働いています。
0

問題は、minSdkVersionlessを「N」より小さくすることができないことです。小さいバージョンを配置した場合、エラーが発生した場合、または+23デバイスのみを使用した場合。

0
diaconu liviu