webdevqa.jp.net

SDKプラットフォームツールバージョン(24.0.4)は古すぎて、API 25でコンパイルされたAPIを確認できません。更新してください

Android St​​udioの最新バージョンでこのエラーが発生し、Android SDK Platform API 25とAndroid SDK Build-Tools 25の両方をインストールしています。

11
Jaymin Bhadani

同様の問題がありました。 project_name/build.gradleファイルのAndroid Studioをバージョン2.2.2(この記事の執筆時点で最新)に、Gradleバージョンを2.2.2(この記事の執筆時点で最新)に更新この問題。

参考のために、これはproject_name/app/build.gradleファイルの私の設定です:

minSdkVersion = 19
targetSdkVersion = 25
compileSdkVersion = 25
buildToolsVersion = "25"
supportLibraryVersion = "25.0.0"

そして、これは私のdependencies in project_name/build.gradleファイルです:

buildscript {

    repositories {
        jcenter()
    }

    dependencies {
        classpath 'com.Android.tools.build:gradle:2.2.2'
        // NOTE: Do not place your application dependencies here; they belong
       // in the individual module build.gradle files
    }
}
5
VishnuSosale

Vishnuが言ったように、私にとってはAndroid studioとGradleは問題を修正しませんでした。

ツール-> Android-> SDK Managerに移動し、BuildToolsを選択し、プラットフォームツールに関連する更新を確認しました。更新およびインストール後、問題を修正しました。

そして私の友人の場合、上記の手順を実行し、[ヘルプ]-> [更新の確認]に移動して、利用可能なすべての更新をインストールすると、問題は解決しました。

同じための添付のスクリーンショット。 Screenshot

14
ChaitanyaAtkuri

Android Studioを3.0にアップグレードした後、同様の問題に直面しています。これを修正する非常に簡単な方法は

ツール-> Android-> SDK Manager-> SDK Tools

Android SDKプラットフォームツールを探して更新します。スクリーンショットが添付されています) SDK tools window image

それだけです。他のgradle設定を変更する必要はありません。

10
Ezio
  1. 開いた AndroidMainfest.xml
  2. 赤いアイコンをクリックします=>検査を無効にします=>エラーが消えました

enter image description here

5
Mack Hirpara

私は同じ問題に直面していますが、交換するとき

buildToolsVersion "25.0.0"

最初の行に問題が解決しました。その後、最終的なアプリグレードは次のようになります。

Android {
    buildToolsVersion "25.0.0"
    compileSdkVersion 25

    defaultConfig {
        applicationId "com.***"
        minSdkVersion 15
        targetSdkVersion 25
        versionCode 0
        versionName "0.0.0"
    }
    buildTypes {
        release {
            minifyEnabled true
            proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.pro'
        }
    }
}
4

Android sdk platform-toolsをSDKマネージャーで24.0.4から25.xxのリビジョンに更新します。その後、Android studioクリックしてFile-> Invalidate Caches /再起動...

エラーはすぐに解消されなければなりません。

2
abdullahselek

更新してみてください

  • Android SDKビルドツール
  • Android SDKプラットフォームツール
  • Android SDKツール
  • Androidサポートリポジトリ
  • Google Playサービス
  • Googleリポジトリ

    などを最新バージョンに。エラーがなくなっている必要があります。

1
anp8850

コマンドラインで

./sdkmanager "platform-tools" "platforms;Android-26"
./sdkmanager --list

最新リリースへのアップデートがあるかどうかを確認してください

0
java_dude

Gradle(app)に移動して置き換えます

  buildToolsVersion "25"

  buildToolsVersion "24.0.4" // Or Latest installed gradle version 

また、targetSdkVersionが25の場合、これを24にします

0
Ganesh Pokale