webdevqa.jp.net

Mac OS X 10.5.8にBash> = 3.2.25をインストールするにはどうすればよいですか?

私はMichael HartlのRailsチュートリアルですが、これまでにGit 1.7.5.4 x86_64(OSX 10.5.8を実行しています)をインストールしました)に従っていて、rvmをインストールしようとしています

次を実行した後:

$ curl -kL get.rvm.io | bash -s stable

私は得ます:

BASH 3.2.25 required (you have 3.2.17(1)-release)

chsh -s /opt/local/bin/bashを使用してシェルを変更しようとしましたが、Shell '/opt/local/bin/bash' does not existが表示されます

ここからどこに行くべきかわからないが、どんなガイダンスもありがたい。ありがとう!

27
kadolor

Homebrewは、多くのSudoアクションを必要としないため、MacPortsよりも少し優れています。インストールのbashをアップグレードするためのガイドとなる記事を次に示します。 http://concisionandconcinnity.blogspot.com/2009/03/upgrade-bash-to-40-in-mac-os-x.html =

手順について:

  1. インストール Homebrew ドキュメントからホームページに
  2. Homebrewを使用してGitをインストールします(オプションですが、最新のgitを用意してください)

    brew install git
    
  3. bashをインストールします:

    brew install bash
    
  4. このbashのインストールを許可されたシェルリストに追加します。

    echo '/usr/local/bin/bash' | Sudo tee -a /etc/shells;
    
    • Homebrewはデフォルトで/usr/local/Cellar/にインストールし、次にバイナリを/usr/local/binにシンボリックリンクします。これにより、/usr/local/bin/bashにある最新のbashを入手できます。
  5. 最後に、この新しいシェルを使用するようにシェルを変更します。

    chsh -s /usr/local/bin/bash
    
  6. 新しいターミナルウィンドウ/タブを開き、次のコマンドを実行して作業を再確認します。

    $ echo $Shell
    /usr/local/bin/bash
    $ echo $BASH_VERSION
    4.2.37(2)-release
    
37
jeffbyrnes

mpapisの指示はすばらしいですが、試したときにすべての問題を完全に網羅していなかったので、これを行う必要がありました。レガシーシステムにRVMをインストールするたびに、それは本当の試練です。以下は完璧とはほど遠いで、1時間近くかかりましたが、10.5.8でRuby 1.9.3が得られました。

全体像(常に説明されるとは限らないもの):

  1. RVMはSudoのrootとしてではなく、ユーザーアカウントの下で実行するように設計されているため、これらのコマンドはSudoなしで入力する必要があります。
  2. Mpapisの警告に耳を傾けたところ、Ruby-1.9.3-p448は10.5.8に付属するgccバージョン4.0.1で動作しますが、他のRubyは動作しない場合があります。
  3. 一部のライブラリRubyは、MacPortsのインストールを開始する必要があります。たとえば、_rvm pkg install zlib_のように実行した場合、pkgは非推奨になっているため、_rvm help autolibs_と入力します続きを読む…
  4. …MacPortsよりも何か他のものを好むかもしれませんが、_rvm pkg install zlib_に私が与えたものを後にさせた後、Rubyの私のRVMインストールはそれをうまく使用しました。
  5. Rubyのインストールには非常に長い時間がかかり、何も実行していないように見える場合があります(_Installing required packages: autoconf, automake, [etc.] gdbm, ncurses........_の後に_.........._の非常にゆっくりと表示される行が続く場合があります)。)それ意志終わり。
  6. これらのプロセッサ集中型のインストール中、コンピュータのファンはおそらくしばらくの間最大速度まで回転します:-)

Rvm-installスクリプトを取得します(kオプションはSSL警告をバイパスします):

_curl -Lk get.rvm.io -o rvm-installer
_

BASHバージョンチェックを防止する

「rvm-installer」スクリプトでbashのバージョンを確認する行(行3〜11)を手動でコメント化します(理由:OS X 10.5.8にはBASH 3.2.17があり、スクリプトは警告します:BASH 3.2.25 required (you have 3.2.17(1)-release)

インストーラーを実行する

Rvm-installerスクリプトが実行可能であることを確認します。

_chmod +x rvm-installer
_

以下のようにスクリプトを実行してRVMを取得します(推奨されるコマンド_/rvm-installer -s stable_はUsageドキュメントのみを表示する場合があります):

_./rvm-installer
_

その後、次のように表示されます。

_Downloading RVM from wayneeseguin branch master
_

_SSL certificate problem_を取得した場合、curlに「安全でない」ダウンロードを許可し、スクリプトを再度実行します。

_echo insecure >> ~/.curlrc
./rvm-installer
_

RVMの使用を開始してRubyをインストールする

RVMの使用をすぐに開始するには、次のように入力します。

_source /Users/your_user_name/.rvm/scripts/rvm
_

Ruby 1.9.3(標準10.5ライブラリで最も安全なオプション))をインストールするには、次のように入力できるはずです。

_rvm install 1.9.3
_

(ここでは長いプロセス-上記のポイント5を参照)。次に、新しいRubyを使用するには、次のように入力します。

_rvm use 1.9.3
_
4
Dave Everitt

正しいバージョンのBashをインストールする方法が必要です。 1つの方法は次のとおりです。

  1. MacPortsをインストール
  2. Sudo port install bashを使用してBashポートをインストールします
  3. シェルを変更 新しいバージョンのBashを使用するには
3
Todd A. Jacobs

Bashバージョンのチェックを削除して、インストーラーを実行できます。

RVMをインストールする

curl -L get.rvm.io -o rvm-installer # Download
sed -i"" '2,9 d' rvm-installer      # Remove the check
chmod +x rvm-installer              # Allow executing the script
./rvm-installer -s stable           # Run installer

必ずrvm requirementsをお読みください。gcc-4.2をサポートするosx-installerまたはXcodeをインストールすることをお勧めします-a GNU GCC LLVM GCCではなく、Ruby 1.9.3-p194はLLVMで正常に動作しています。

ルビーをインストール

rvm pkg install zlib
rvm pkg install openssl
rvm pkg install libyaml
rvm install 1.8.7
rvm install 1.9.2
rvm install 1.9.3

テスト

git clone https://github.com/wayneeseguin/rvm-test.git
cd rvm-test
gem install dtf
dtf --text rvm-test/fast/* 2>&1 | tee test.log

ファイルtest.logが作成されます。 RVMのチケット を開いて結果を表示してください-正常に機能した場合、チェックをダウングレードします-ダウンしていない場合、チェックをダウングレードする前に修正を行う必要があります。

1
mpapis

Power PC Macを使用していますか? Intel PCを使用している場合は、Lionにアップグレードしてみませんか。 LionにはBASH 3.2.48が付属しています。そうでない場合は、MacPortsを CodeGnome として使用する必要があります。

0
David W.