webdevqa.jp.net

エラーVisual Studio CodeとOmnisharp Extension with .Net Core SDK 3.0 preview

Visual Studio Codeの.Net Core 3.0プロジェクトのエラーを修正するにはどうすればよいですか?

フォルダーにdotnet newコマンドを使用して作成した新しいプロジェクトから.NET Core 3.0 SDKをダウンロードしました。

Visual Studio Codeでプロジェクトを開くと、次のエラーが発生します。

[失敗]:OmniSharp.MSBuild.ProjectLoader現在の.NET SDKは、.NET Core 3.0のターゲットをサポートしていません。 .NET Core 2.2以下をターゲットにするか、.NET Core 3.0をサポートするバージョンの.NET SDKを使用してください。 [警告]:OmniSharp.MSBuild.ProjectManagerプロジェクトファイル 'c:\ Users\Marco\source\Workspaces\WebDevelopment\Samples\hello-world\hello-world.csproj'のロードに失敗しました。 c:\ Users\Marco\source\Workspaces\WebDevelopment\Samples\hello-world\hello-world.csproj C:\ Program Files\dotnet\sdk\2.2.102\Sdks\Microsoft.NET.Sdk\targets\Microsoft。 NET.TargetFrameworkInference.targets(137,5):エラー:現在の.NET SDKは、.NET Core 3.0のターゲティングをサポートしていません。 .NET Core 2.2以下をターゲットにするか、.NET Core 3.0をサポートするバージョンの.NET SDKを使用してください。

[失敗]:OmniSharp.MSBuild.ProjectManagerロードされていないプロジェクトを更新しようとしました:c:\ Users\Marco\source\Workspaces\WebDevelopment\Samples\hello-world\hello-world.csproj

8
Marco Duindam

解決策ではありませんが、私のための回避策:

OmniSharpで_.NET CORE 3.0.100-preview3-010431_を使用してVisualコードを処理していますが、問題は_OmniSharp.MSBuild.Discovery.MSBuildLocator_で使用されているMSBuildのバージョンにあるようです。

ビジュアルコードで、OmniSharpログを確認します。

enter image description here

ソリューションが好きかどうかはわかりませんが、OmniShartログで、Visual Studio 2017 MSBuildを使用していたことを確認しました。VS2017で.net Core Preview 3プロジェクトに問題があったため、Visual Studio Communityをインストールしました2019 RC。私のコード.NET CORE 3.0はVS 2019で動作しますが、Visual CodeのOmniSharpで問題があります。ビジュアルコードで機能させるには、C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\MsBuildの名前をC:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\MSBuild.disabledに変更します。NETCoreを使用したビジュアルコードでは、すべて問題ありません。

_    Located 3 MSBuild instance(s)
        1: Visual Studio Enterprise 2017 15.9.28307.344 - "C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\MSBuild\15.0\Bin"
        2: Visual Studio Community 2019 16.0.28714.193 - "C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Current\Bin"
        3: StandAlone 15.0 - "c:\Users\JPB\.vscode\extensions\ms-vscode.csharp-1.17.1\.omnisharp\1.32.8\msbuild\15.0\Bin"
    Registered MSBuild instance: Visual Studio Enterprise 2017 15.9.28307.344 - "C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\MSBuild\15.0\Bin"
_

になる:

_[info]: OmniSharp.MSBuild.Discovery.MSBuildLocator
        Located 2 MSBuild instance(s)
            1: Visual Studio Community 2019 16.0.28714.193 - "C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Current\Bin"
            2: StandAlone 15.0 - "c:\Users\JPB\.vscode\extensions\ms-vscode.csharp-1.17.1\.omnisharp\1.32.8\msbuild\15.0\Bin"
[info]: OmniSharp.MSBuild.Discovery.MSBuildLocator
        Registered MSBuild instance: Visual Studio Community 2019 16.0.28714.193 - "C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Current\Bin"
_

結論:Omnisharpには、.net Core 3.0をサポートするMSBuildが必要なようです。 VS 2019以外では見つかりません。

8
JPBlanc