webdevqa.jp.net

DockerはインストールされていますがDocker Composeがインストールされていませんか?どうして?

以下のコマンドを実行して、dockerをcentos 7にインストールしました。

curl -sSL https://get.docker.com/ | sh
systemctl enable docker && systemctl start docker
docker run hello-world

注:helloworldは正しく動作し、問題はありません。

しかし私がdocker-composeを実行しようとすると(docker-compose.ymlが存在し有効です)それは私にCentos上でのみエラーを与えます(Windows版はdocker-composeファイルのためにうまく働きます)

/usr/local/bin/docker-compose: line 1: {error:Not Found}: command not found
79
mahen3d

Docker Composeもインストールする必要があります。 マニュアル をご覧ください。実行する必要があるコマンドはここにあります

Sudo curl -L "https://github.com/docker/compose/releases/download/1.22.0/docker-compose-$(uname -s)-$(uname -m)"  -o /usr/local/bin/docker-compose
Sudo mv /usr/local/bin/docker-compose /usr/bin/docker-compose
Sudo chmod +x /usr/bin/docker-compose
171

Raspbian 8を使ってRaspberry Pi 3にインストールしています。curlメソッドが失敗し(line 1: Not: command not foundを要求するとdocker-compose --versionエラーが発生しました)、@ sunapi386の解決策は少し古くなったので、これを試してみました。

まず、以前の取り組みから物事を整理します。

Sudo rm /usr/local/bin/docker-compose
Sudo pip uninstall docker-compose

それから このガイダンスに従ってRpi を作成してください。

Sudo apt-get -y install python-pip
Sudo pip install docker-compose

私のために(2017年11月1日)、これはdocker-compose --versionへの以下の応答となります。

docker-compose version 1.16.1, build 6d1ac219
26
Scott Veirs

Raspbian OS 3上のRaspberry Pi 3にインストールしています。 curlメソッドは有効な応答に解決されませんでした。それはまた{error: Not Found}と言いました、私はURL https://github.com/docker/compose/releases/download/1.11.2/docker-compose-Linux-armv7lを見ました、そして、それは有効ではありませんでした。私はそこに建造物がなかったと思います。

このガイド https://github.com/hypriot/arm-compose は私にとって役に立ちました。

Sudo apt-get update Sudo apt-get install -y apt-transport-https echo "deb https://packagecloud.io/Hypriot/Schatzkiste/debian/ jessie main" | Sudo tee /etc/apt/sources.list.d/hypriot.list Sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 37BBEE3F7AD95B3F Sudo apt-get update Sudo apt-get install docker-compose

6
sunapi386

あなたがdockerを公式リポジトリをあなたのリポジトリリストに追加してインストールした場合は、次のようになります。

curl -L https://nightly.odoo.com/odoo.key | apt-key add -
Sudo echo "deb http://nightly.odoo.com/10.0/nightly/deb/ ./" >> /etc/apt/sources.list.d/odoo.list
Sudo apt-get update && Sudo apt-get install odoo

ただしてください:

$ Sudo apt-get install docker-compose

RHELベースのディストリビューション/ Fedoraの場合:

$ Sudo dnf install docker-compose
2

上記の回答を参考にして(私は個々の解決策を個別に参照するのに十分な評判がないので、ここでまとめてこれを行います)、いくつかの重要な提案を付け加えたいと思います。

  1. docker-composeはリポジトリからインストールすることができます(このパッケージをリポジトリに持っていて、システムにこのパッケージでリポジトリを追加できない場合)、またはプロジェクトの公式Webサイトでuse curl - totourialを使ってバイナリをダウンロードします。 https://docs.docker.com/compose/install /

  2. リポジトリからdocker-composeはバージョン1.8.0(少なくとも私には)にあります。このdocker-composeバージョンは、バージョン3の構成ファイルをサポートしません。バージョン= 2未満のサポートしかありません。プロジェクトの公式サイトでは、バージョン3のコンテナ設定を使用することをお勧めします - src: https://docs.docker.com/compose/compose-file / compose-versioning /私自身のdockerでの作業の経験から、バージョン3ではコンテナー構成を使用することをお勧めします - バージョン<3よりも使用する構成オプションが多くあります。バージョン3の設定を使用したい場合は、docker-composeを少なくとも1.17のバージョン(できれば最新の安定版)にアップデート/インストールする必要があります。プロジェクトの公式サイトは、このプロセスを実行する方法を全面的に説明しています - src: https://docs.docker.com/compose/install/

  3. 古いdocker-composeバイナリを手動で削除しようとすると、見つからないファイルに関する情報をデフォルトパス/usr/local/bin/docker-composeに含めることができます。私の場合、docker-composeはデフォルトのパス/ usr/bin/docker-composeにありました。この場合、バイナリファイルdocker-composeを見つけるためにあなたのシステムのfindツールを使うことをお勧めします - 構文例:Sudo find / -name 'docker-compose'。それは私を助けました。これのおかげで、私は古いdocker-composeのバージョンを削除してシステムに安定版を追加しました - 私はcurlツールを使ってバイナリファイルdocker-composeをダウンロードし、正しいパスに入れて正しいパーミッションを与えました。上記の記事で説明されています。

よろしく、アダム

1

まずはdocker-composeがインストールされているか確認してください。

$ docker-compose -v

インストールされていない場合は、インストールガイド https://docs.docker.com/compose/install/ を参照してください。バイナリ.

$ chmod +x /usr/local/bin/docker-compose

これでうまくいくか確認してください。

1
ASON

上記の解決策は私にはうまくいきませんでした。しかし、私はこれがうまくいったのを見つけました:

Sudo apt-get update -y && Sudo apt-get install -y python3-pip python3-dev
Sudo apt-get remove docker docker-engine docker.io
curl -fsSL get.docker.com -o get-docker.sh
Sudo sh get-docker.sh
Sudo pip3 install docker-compose
#Sudo docker-compose -f docker-compose-profess.yml pull ofw
Sudo usermod -a -G docker $USER
Sudo reboot
0
Shaun Barney

docker-composeは現在docker(-engine)を利用するツールですが、dockerの配布には含まれていません。

インストールマニュアルへのリンクは次のとおりです。 https://docs.docker.com/compose/install/

TL; DR:

curl -L https://github.com/docker/compose/releases/download/1.8.0/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose
chmod +x /usr/bin/docker-compose

(1.8.0は将来変更されます)

0

私はMac上で公式のpkgを使うことを勧めます。 docker-composeはもはやデフォルトではdockerに含まれていないと思います。 https://docs.docker.com/toolbox/toolbox_install_mac/

0
R Claven

Dockerをインストールしても、docker-composeをインストールしたという意味ではありません。それはあなたがすでにやったdockerエンジンをすでにインストールしていることを前提条件として持っています。その後、Centos 7の場合は、この リンク に従ってdocker-composeをインストールできます。

0
lvthillo