webdevqa.jp.net

バンドル「org.Eclipse.core.runtime」を解決できません

最近、Eclipse KeplerからLunaにアップグレードしました。私が取り組んでいたプラグインは、ソースを変更せずにビルドエラーを表示しています。

これが私のMANIFEST.MFからの抜粋です。

Require-Bundle: org.Eclipse.core.runtime;bundle-version="3.7.0",
 org.Eclipse.ui;bundle-version="3.7.0",
 org.Eclipse.ui.ide;bundle-version="3.7.0",
 org.Eclipse.core.resources;bundle-version="3.7.0",
 org.Eclipse.ui.forms;bundle-version="3.6.0",
 org.Eclipse.wst.sse.ui;bundle-version="1.3.0",
 org.Eclipse.jface.text;bundle-version="3.8.100",
 org.Eclipse.ui.workbench.texteditor;bundle-version="3.8.101",
 org.Eclipse.ui.views;bundle-version="3.6.0"

coreまたはuiバンドルは解決されません。私はEclipseがなくても実行できるとは思いません。同等の.jarファイルが存在し、読み取り可能で、アップグレードの一部として変更されていないため、実際には欠落していません。 [依存関係]タブで依存関係を追加しようとすると、問題のバンドルが表示されません。

EclipseはArch Linuxパッケージマネージャーによってアップグレードされました。完全を期して言及しましたが、他のアップグレードメカニズムと同じであると考えられます。新しいプラグインプロジェクトを作成してみましたが、同じことが起こりました。これは、グローバル設定であることを意味していると思います。私はPDEに比較的慣れていないので、これまでのところ、設定を変更する必要はありません。

19
clockworkgeek

設定ページ(Preferences > Plug-in Development > Target Platform)、実行中のプラットフォームターゲット定義を削除して適用し、デフォルトに戻します。多分それは単に古く、Archが変わったことを知らないjarを指しているだけかもしれません。

41
nitind