webdevqa.jp.net

(Eclipse SDKアップデートエラー)インストールするアイテムの収集中にエラーが発生しました

ADKを更新したところ、この人とまったく同じ問題(同じバージョンのアップグレード)が発生しました( ADTを22.3.0から22.6.1に更新できません、更新が見つかりませんでした

彼らのコメントに従いましたが、手順4で説明したダイアログが表示されませんでした(4.「このソフトウェアは既にインストールされています。代わりに更新が実行されます」というダイアログが表示されます。[OK]をクリックすると22.6.1になります。インストールされています。)

代わりに、タイトルの付いたエラーメッセージがあります

問題が発生しました

それは言う

ソフトウェアのインストールで問題が発生しました。インストールするアイテムの収集中にエラーが発生しました

そして、私が理解していない詳細のチャンクが続きます(以下を参照)。誰か助けてもらえますか?そんなにThx

インストールするアイテムの収集中にエラーが発生しましたセッションコンテキストは次のとおりです:(profile = profile、phase = org.Eclipse.equinox.internal.p2.engine.phases.Collect、operand =、action =)。 osgi.bundle、com.Android.ide.Eclipse.adt、22.6.2.v201403212031-1085508を含むリポジトリが見つかりません:osgi.bundle、com.Android.ide.Eclipse.adt.package、22.6.2を含むリポジトリが見つかりません.v201403212031-1085508以下を含むリポジトリが見つかりません:osgi.bundle、com.Android.ide.Eclipse.base、22.6.2.v201403212031-1085508以下を含むリポジトリが見つかりません:osgi.bundle、com.Android.ide.Eclipse.ddms、22.6 .2.v201403212031-1085508以下を含むリポジトリが見つかりません:osgi.bundle、com.Android.ide.Eclipse.gldebugger、22.6.2.v201403212031-1085508以下を含むリポジトリが見つかりません:osgi.bundle、com.Android.ide.Eclipse.hierarchyviewer 、22.6.2.v201403212031-1085508以下を含むリポジトリが見つかりません:osgi.bundle、com.Android.ide.Eclipse.traceview、22.6.2.v201403212031-1085508以下を含むリポジトリが見つかりません:osgi.bundle、overlay.com.Android.ide .Eclipse.adt.overlay、22.6.2.v201403212031-1085508以下を含むリポジトリーが見つかりません:org.Eclipse.update.feature、com.Android.ide.Eclipse.adt、22.6.2.v201403212031-1085508リポジトリーが見つかりませんconta ining:org.Eclipse.update.feature、com.Android.ide.Eclipse.ddms、22.6.2.v201403212031-1085508以下を含むリポジトリが見つかりません:org.Eclipse.update.feature、com.Android.ide.Eclipse.gldebugger、 22.6.2.v201403212031-1085508以下を含むリポジトリーが見つかりません:org.Eclipse.update.feature、com.Android.ide.Eclipse.hierarchyviewer、22.6.2.v201403212031-1085508以下を含むリポジトリーが見つかりません:org.Eclipse.update.feature、 com.Android.ide.Eclipse.traceview、22.6.2.v201403212031-1085508

10
Derekyy

Joneswのリンクによると https://stackoverflow.com/a/14896322/621481 あなたがする必要があるのはあなたがチェックを外していることを確認することです 'インストール中にすべてのアップデートサイトに連絡して必要なソフトウェアを見つける' Eclipseからソフトウェア画面をインストールします。

28
Chris Noldus

私は最近、これと非常によく似た問題を抱えていました。そして、@ ChrisNoldusからの回答は私にはうまくいきませんでした。しかし私は見つけました このリンク

基本的に、利用可能な更新サイトのリンクに末尾の「/」がない場合、問題があるようです。

ファイルに何もエクスポートする必要はありませんでしたが、[ウィンドウ]-> [設定]-> [インストール/更新]-> [利用可能なソフトウェアサイト]で構成を変更するだけでした。

0
J.Makela

私は最近同じ問題に遭遇し、マークされた答えは私のために働きませんでした。私はこのエラーを修正するために可能なすべての解決策を試しました。最後に、C:\Users\Public\DocumentsNeonMars)の下にEclipseのワークスペースが2つあることがわかりました。不要なフォルダを削除して(Neonで作業していると仮定して、他のフォルダMarsを削除します)、アップデートをインストールしてみてください。

0
akash karothiya