webdevqa.jp.net

Eclipse用Coberturaプラグインをインストールできません

EclipseマーケットプレイスからEclipse kepler(Java/j2eeバージョン)にcoberturaプラグインをインストールしようとすると、次のエラーメッセージが表示されます。

1つ以上の必要なアイテムが見つからなかったため、インストールを完了できません。インストールされるソフトウェア:eCobertura 0.9.8.201007202152(ecobertura.feature.group 0.9.8.201007202152)

欠落している要件:eCobertura 0.9.8.201007202152(ecobertura.feature.group 0.9.8.201007202152)には 'org.junit4 0.0.0'が必要ですが、見つかりませんでした

25
Krunal Shah

以前のバージョンのEclipseからjunitプラグインサブディレクトリを自分のplugins /ディレクトリにコピーしてEclipseを再起動することで、eCoberturaをインストールすることができました。

私のEclipse(Spring Toolsuite v3.3)に付属のjunitバージョンはorg.junit_4.11.0.v201303080030でした。これは、eCoberturaのインストールが失敗した原因です。

STS 3.2からコピーした2つのバージョンは、org.junit4_4.8.1.v20120523-1257とorg.junit_4.10.0.v4_10_0_v20120426-0900でした。

22
user2816065

新しいEclipse(eCoberturaKepler)にLunaをインストールすると、JUnit依存関係チェッカーで処理されない新しいバージョンのeCoberturaパッケージが原因で問題が発生します。

ソリューションの1つ(前の回答で推奨)は、古いEclipseインストールからorg.junit*パッケージをコピーする必要があることですが、それがない場合は問題になる可能性があります。

完全に新規インストールするためのソリューションは非常に似ています。インターネットからorg.junit4_4.8.1.v20120523-1257.jarをダウンロードして、Eclipseのプラグインフォルダーに配置するだけです。

その場合、org.junit_4.10.0.v4_10_0_v20120426-0900.jarを追加する必要がないことに注意してください。

その後、eCoberturaをインストールできるようになります。

12
Bosko Mijin

このリンク からEclipseをダウンロードし、$Eclipse_home/pluginsに移動してこれらのフォルダーをコピーします

  • org.junit_4.10.0.v4_10_0_v20120426-0900
  • org.junit4_4.8.1.v20120523-1257
3
Sumit Sahay

少し遅くなりましたが、これはEclipse Marsを使用したSTS 3.8.1で機能することを追加したかっただけです。上記で指定したJARをダウンロードして、「plugins」フォルダーに配置するだけです。

0
jdavis