webdevqa.jp.net

次のFirefoxバージョン:拡張機能/アドオンの互換性を*簡単に*チェックする方法は?

質問:

私は現在Firefox3.6を使用しています。次のバージョンのFirefox(現時点ではFirefox 4)をインストールする前に、インストールした拡張機能/アドオンのallを確認する簡単な方法はありますか? onsはそれと互換性がありますか?

背景:

私はワンクリックソリューションを望んでいます。なぜなら、私はしない最初にFF4をインストールしたいのですが、それらのいくつかに互換性がないことを確認したいのですが、私はしないチェックしたいのです。インストールされているすべての拡張機能のすべてのホームページで、サポートされているバージョンを確認します。

おそらく、 '各アドオンの互換性のある最高のFFバージョンをリストする'拡張機能が存在しますか?私はこれをグーグルで検索しましたが、何も見つかりませんでした...

この質問は、FF 1から2、2から3に移行するときに同じ問題が発生したため、FFの将来のバージョンでも一般的なものです。当時、私はさまざまなことをいじって試してみてもかまいませんでした。私がやります。

編集:理想的には、どこかでチェックボックスをチェックして、拡張機能(またはFirefox自体-> FF開発者向けのヒント)が監視するかどうかを監視できるようにする必要があります私のアドオンは互換性があり、互換性があると(ポップアップで)通知するので、アップグレードできます。統計にはいいと思いますし、Mozillaが 互換性のある拡張機能の膨大なリスト と平均的なユーザー適応を提供するので、ユーザーとしての私がもっと簡単に自分をチェックできればもっと便利だったでしょう個人状況。

編集2:私の質問は私だけではなかったようです: このライフハッカーの投稿 を参照してください。

12
Rabarberski

たぶんFirefoxアドオン 互換性はありますか? はあなたを助けます(それは私を助けました)。インストールされているアドオンのリストに互換性情報を追加するだけです。

11
Martin

または、 アドオン互換性センター をチェックすることもできます。

インストールされているすべてのアドオンの95%を占めるアドオンを人気順に並べ替えたレポートがあります。 (リンクしますが、直接のURLはありません。)

6
ale

最初のコメント:バージョン4.0は非常に不安定なので、いずれにせよFF4.1を待つことをお勧めします。頻繁に打ち切られていたので、ようやくFF3に戻りました。新しいJavascriptエンジンにはまだ問題があると思います。

今あなたの質問に対処するために:アドオンがFF4と互換性があるかどうかを知る確実な方法はありません。 FF4で互換性がなく無効になっているとマークされていても、実際には完全に互換性がある可能性があります。試してみるだけで、最も簡単な方法はチェックをオフにすることです。

Firefox拡張機能の互換性を強制する 、バージョンチェックは about:config でオフになります:リストを右クリックして[新規]を選択します(すでに存在する場合は最初に参照してください) 、その後に「ブール値」が続きます。名前を「 extensions.checkCompatibility 」として入力し、値を「false」として入力します。完了すると、拡張機能は、実行しているFirefoxのバージョンと互換性があるかどうかを確認しなくなります。チェックを「true」に設定すると、いつでもチェックを再度有効にできます。

これを行うためのはるかに優れた方法は、コミュニティを支援すると同時に、この記事で紹介されています: Firefoxでのアドオンの互換性のテストとレポート

アドオン互換性レポーター をインストールします。これにより、互換性のないすべての拡張機能を使用して、それらがまだ機能するかどうかをテストできます。アドオンの1つが以前のバージョンのアプリケーションと同じように機能していないように見える場合は、アドオンマネージャーを開き、そのアドオンの横にある[互換性]をクリックしてレポートを送信します。 Mozilla。もちろん、拡張機能が完全に機能していることを報告することもできます。

2
harrymc

「互換性がありますか」アドオンを試してください https://addons.mozilla.org/en-US/firefox/addon/is-it-compatible/ 試していませんが、これは可能性がありますあなたが探しているもの。

0
user76008

@Rabarberskiのように、ワークフローを正常に保つためにAdd-on Compatibility Report for Firefox <release>を使用できないことがわかりました。 Is It Compatible?に関しては、FF v30以降、検証されず、動作を停止しました。

私の一時的なソリューションatm:プロファイル全体をbackup(スナップショット)し、以前のFirefoxパッケージを保持します。これにより、面倒な問題が発生した場合に、(Mozillaの方法で)盲目的に更新し、ダウングレードを以前のリリースに更新することができます。 Firefox PortableはLinuxでは使用できません。

また、ここにあります この主題に関する詳細を尋ねる質問 Mozillaサポートについて

0
tuk0z

Firefox Portable Edition を使用してみてください。そうすれば、現在のバージョンのFirefoxをアンインストールせずに、Firefox4とそのアドオンとの互換性を確認できます。

0
ale

これはワンクリックソリューションではありませんが、私の意見では最も柔軟性があります。Firefox4をFirefox 3とは別のディレクトリにインストールしてから、プロファイルのコピーを作成します。古いプロファイルではFirefox3を使用し、新しいプロファイルではFirefox4を使用します。 Firefox 4は、起動するとすぐにアドオンの互換性をチェックします。

長所:

  • Firefox4自体が互換性をチェックします
  • いつでもFirefox3に戻ることができます
  • すべての拡張機能が追いつくか、Firefox 4が満足のいくものになるまで待ってから、簡単に新しいバージョンに切り替えることができます。

短所:

  • ワンクリックソリューションではありません
  • ディスクフットプリントの増加(ただし、システムのスペースが非常に狭い場合(SSDが小さいネットブックなど)を除いて、通常は問題になりません)

プロファイルのコピーを作成するには、プロファイルマネージャーを有効にしてFirefox 3を起動し( Mozillaサイト の表示方法がわからない場合)、新しいプロファイルを作成します。終了し、プロファイルが保存されているフォルダーを開き(これは、使用しているOSと特定のバージョンによって異なります)、古いプロファイルを新しいプロファイルにコピーします。

これまでに行ったことがない場合、操作は約10〜15分で実行できます。

0
plco