webdevqa.jp.net

Firefoxにアドオンのインストールを強制する

Firefoxに新しいアドオンであるFiresheepをインストールしたかったのですが、(xpiファイルから)インストールしようとすると、4.0.1と互換性がないため、インストールできると言われました。

ただし、互換性チェックは無効になっています。アドオンを強制的にインストールする方法はありますか?

4
genesis

アドオン互換性レポーター を使用できます。この拡張機能を使用すると、Firefoxは互換性があるかどうかに関係なくすべての拡張機能をインストールします。さらに、アドオンマネージャーから、特定の拡張機能がFirefoxの現在のバージョンと互換性がないかどうかを報告したり、バグを報告したりできます(必要な場合)。

0
Realcool

私に関する限り、xpiファイルを「ハッキング」して、必要な最大バージョンを変更することができます。

  1. xpiの名前をZipに変更し、お気に入りのアーカイブ解除ソフトウェアで抽出します
  2. を見つける install.rdfファイルを作成し、テキストエディタで開きます
  3. 次の行を変更します(あなたが話している場合 このFiresheep ):

    <em:maxVersion>3.6.*</em:maxVersion>
    
  4. その1つに:

    <em:maxVersion>4.0.1</em:maxVersion>
    
  5. ファイルを保存し、フォルダ全体を再度圧縮します。

  6. Zipの名前をxpiに変更し、アドオンのインストールを再試行してください。

これにより、必ずしもアドオンが機能するとは限りませんが、少なくともインストールする必要があることに注意してください。

9
slhck

他のすべてが失敗した場合、Firefoxの以前のバージョンをダウンロードするためのいくつかのリンクがあります:
https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/

おそらくバージョン3.6が必要になるでしょう:
https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/3.6/win32/en-US/

0
w3bshark

このバージョンのmozillaをダウンロードすると、完全に機能するはずです: https://ftp.mozilla.org/pub/firefox/releases/3.6.28/win32/en-GB/

0
Slic0007