webdevqa.jp.net

Firefox 4のアップグレードでR-Kioskが壊れました...簡単に回避できますか?

R-Kiosk というFirefoxアドオンを使用する必要があります。 Firefox3からFirefox4にアップグレードしましたが、R-Kioskが機能しません。 ff4をサポートしていると言っているバージョンのr-kioskが表示されません...

この問題を解決する最も簡単な方法について誰かが何かアイデアを持っていますか?

3
JMecham

アドオンはまだ互換性がある可能性があり、開発者がまだ更新していないため、互換性がないとマークされているだけです。この場合、about:configに移動し、設定extensions.checkCompatibility.4.0falseに変更することで、互換性チェックを無効にできます。

実際に互換性がない場合(つまり、互換性チェックを無効にしても機能しない場合)、開発者が次のことを行うのを待つ必要があります。コードを更新するか、拡張機能のXPIファイル(.xpi名が付いた単なるZipファイル)を開いて、自分で変更します。 Firefoxアドオン開発の基本 を理解したら、 https://developer.mozilla.org/en/Extensions/Updating_extensions_for_Firefox_4 を見て、どのような変更が行われたかを把握してください。作る必要があります。

2
MatrixFrog

インストールできます 互換性レポーターFirefoxアドオンを追加

アドオン互換性レポーターをインストールした後、Firefoxは互換性のチェックを停止します。続行して、R-kioskfirefoxアドオンをインストールできます。不正行為の可能性があります。何か見つけたら、アドオンをアンインストールします。

0
mvg

3.6にダウングレードして、互換性を待ちますか?それは私にとって最も簡単なアプローチのようです。

0
MDMarra