webdevqa.jp.net

NPAPIプラグインサポートの削除は、エンドユーザーにとってどのような意味がありますか?

私はレガシープラグインのファミリー、つまりQuickTime、Flash、およびJava Webプラグインをいくつか挙げます。これらはかなりの数のWebアプリケーションの主力の一種です。時間。

だから、私は 学ぶことに驚いた (まあ...私は実際に周りを学びました 代わりにこのブログ投稿 、非説明脚注として)NPAPIプラグインはGoogle Chromeで廃止される予定です。 Firefoxでも削除されるとの噂が聞こえてきましたが、これについての明確な言及はありません。

それはいいです。私はそれを理解し、尊重することができます。これらのプラグインは、ブラウザに多くのセキュリティ脆弱性を追加し、多くの膨張を引き起こします。

しかし、エンドユーザーとしての私にとって、それは実際には何を意味するのでしょうか。これは、Java、QuickTime、またはFlashプラグインが利用可能になることを期待しているアプリケーションを実行できないことを意味しますか?アプリケーション自体が更新されるまで、代替品または互換性のある「プラグイン」のようなものはありますか?

これらのプラグインを引き続き使用するアプリケーションを引き続き使用するには、古いバージョンのブラウザを使用する必要がありますか?

必要に応じて、私が参照しているプラ​​ットフォームを指定できます:(X)Ubuntu/Linux Mint、最新バージョン、64ビットOS。

12
Makoto

フラッシュ開発を行って以来、私は実際に私の会社のためにいくつかの研究をしました。これは、上級者向けのメールの内容です(一部は編集済み)

tl; dr

  • フラッシュはどちらの場合も影響を受けません
  • UnityはChromeが新しいAPIを使用するために(とりわけOpenGLを使用して)、Chromeが推進している)のプラグインを書き換える必要があります。 (最新のUnityはすでにそれをサポートしていると思います)
  • 新しいAPIを使用するには、JavaがChromeのプラグインを書き直す必要がありますJavaは、Java 9 で始まるプラットフォーム用の将来のプラグインを開発しない予定であり、新しいブラウザプラグインアーキテクチャをサポートするために既存のプラグインを更新する意図はありません。
  • Firefoxの「Click-to-Play」はすべてのプラグイン(Flashを除く)で必要になりますが、ユーザーの選択は保存されます(サイトごと)。Mozillaは2016年末までにFirefoxからNPAPIサポートを削除する予定です。

Chrome

ChromeのNPAPI非推奨ロードマップ:
http://www.chromium.org/developers/npapi-deprecation

  • 2014年1月。Silverlight、Unityなどの一般的なプラグイン、Javaは今のところホワイトリストに登録されます(UnityとJavaはすでに デフォルトでブロックされていますが
  • 他のプラグインには 許可を求める黄色のポップアップ が表示されます。
  • 2014年半ば。NPAPIプラグインの更新は許可されなくなりました。 NPAPIプラグインがストア検索にリストされなくなりました。
  • ブロックされたプラグインの実行を許可することは、UIを介してより困難になりますが、まだ可能です(すでにインストールされている場合)
  • 2014年9月。すべてのNPAPIプラグインがストアから削除されました(ただし、すでにインストールされている場合は引き続き機能します)。
  • 2014年末。ChromeでのNPAPIサポートは完全に削除されます(NPAPIを使用するプラグインは機能しません)

NPAPIの代替Chrome:

Firefox

  • Auroraと呼ばれる新しいFirefoxバージョンのリリースで「Click-to-Play」プラグインを有効にします(まだベータ前)
    https://blog.mozilla.org/futurereleases/2013/09/24/plugin-activation-in-firefox/
  • この変更は以下に影響します:allプラグイン、exception of Flash(古いFlashバージョンを除く)
  • ユーザーは、プラグインの実行を許可するために ポップアップをクリック する必要があります。
    • 2016年末までに、サポートされるプラグインはFlashのみになります。他のすべてのNPAPIプラグインは互換性がありません。

Firefoxのプラグインの代替:

  • ここでも、ブラウザ内で利用可能ななどのテクノロジを使用することが推奨されます。
    • WebGL 、OpenGL ESアクセスを許可します
    • WebRTC。
16
Slav

私はあなたの質問の2つに返信し、2018年にブラウザーでのNPAPIプラグインのステータスに関する情報を提供します。企業ページ、管理ページ、eラーニングコース、ハードウェアWeb管理者などのためにプラグインを実行する必要があるすべての人のために...

これらのプラグインを引き続き使用するアプリケーションを引き続き使用するには、古いバージョンのブラウザを使用する必要がありますか?

いいえ、更新しましたFirefoxのフォーク次のようなNPAPIをサポートします:

Waterfox 56(更新され、FF56に基づく)

バジリスク201801(更新され、FF55に基づく)

Palemoon 27(更新され、FF27 UIに基づいています)

これらのプラグインを引き続き使用するアプリケーションを引き続き使用するには、古いバージョンのブラウザを使用する必要がありますか?

はい、もし公式FirefoxまたはChrome browserを使用したい場合。実際、「Chrome」エンジンを搭載したブラウザの最新バージョンは次のとおりです。

クロム。ビルド45.0.2416.0-win32(chrome:// flags /#enable-npapiでPPAPIを有効にする必要があります)

0
Daniel Perez