webdevqa.jp.net

「[AppName]」Xcode 11.5、iOS 13.5をインストールできません

最近、iPhone 6sをiOS 13.5にアップデートしましたが、エラーが発生し続けます「アプリ名」をインストールできません:

Details

Unable to install "AppName"
Domain: com.Apple.dt.MobileDeviceErrorDomain
Code: -402620383
--
The maximum number of apps for free development profiles has been reached.
Domain: com.Apple.dt.MobileDeviceErrorDomain
Code: -402620383
User Info: {
    DVTRadarComponentKey = 487925;
    MobileDeviceErrorCode = "(0xE8008021)";
    "com.Apple.dtdevicekit.stacktrace" = (
    0   DTDeviceKitBase                     0x000000011beb081a DTDKCreateNSErrorFromAMDErrorCode + 233
    1   DTDeviceKitBase                     0x000000011bef1f70 __90-[DTDKMobileDeviceToken installApplicationBundleAtPath:withOptions:andError:withCallback:]_block_invoke + 155
    2   DVTFoundation                       0x0000000101e91155 DVTInvokeWithStrongOwnership + 73
    3   DTDeviceKitBase                     0x000000011bef1ca8 -[DTDKMobileDeviceToken installApplicationBundleAtPath:withOptions:andError:withCallback:] + 1654
    4   IDEiOSSupportCore                   0x000000011bd7ae91 __118-[DVTiOSDevice(DVTiPhoneApplicationInstallation) processAppInstallSet:appUninstallSet:installOptions:completionBlock:]_block_invoke.352 + 4165
    5   DVTFoundation                       0x0000000101fc47f4 __DVT_CALLING_CLIENT_BLOCK__ + 7
    6   DVTFoundation                       0x0000000101fc6436 __DVTDispatchAsync_block_invoke + 1194
    7   libdispatch.dylib                   0x00007fff689ce6c4 _dispatch_call_block_and_release + 12
    8   libdispatch.dylib                   0x00007fff689cf658 _dispatch_client_callout + 8
    9   libdispatch.dylib                   0x00007fff689d4c44 _dispatch_lane_serial_drain + 597
    10  libdispatch.dylib                   0x00007fff689d55d6 _dispatch_lane_invoke + 363
    11  libdispatch.dylib                   0x00007fff689dec09 _dispatch_workloop_worker_thread + 596
    12  libsystem_pthread.dylib             0x00007fff68c2da3d _pthread_wqthread + 290
    13  libsystem_pthread.dylib             0x00007fff68c2cb77 start_wqthread + 15
);
}
--


System Information

macOS Version 10.15.4 (Build 19E287)
Xcode 11.5 (16139)

私はおそらく here または here のようなすべてを試しましたが、運はありません。

失う なしで下位バージョンにダウングレードすることは可能ですか?

注意:Apple開発者プログラムの一部ではありません。

1
Axel

まだその問題を抱えている人のために。 Xcode 11.4リリースノート 既知の問題として持っています:

既知の問題

  • 無料のApple開発者アカウントを使用してiOS 13.3.1、tvOS 13.3.1、watchOS 6.1以降を実行しているデバイスを対象とする場合、アプリ拡張機能は、同時にインストールできる3つのアプリの制限に対して誤ってカウントされます。 Xcodeがエラーを報告する:「無料開発プロファイルのアプリの最大数に達しました。」(59264389)(FB7568073)

回避策:無料のアカウントで署名されたアプリをデバイスから削除し、関連するプロビジョニングプロファイルをXcodeの[デバイス]ウィンドウを使用してデバイスから削除します。アプリに3つ以上のアプリ拡張機能が含まれている場合は、それらを削除して、3つのアプリ制限未満のままにします。

提案された回避策は私にはうまくいきませんでした。うまくいくことを願っています。

2
Ozx