webdevqa.jp.net

エラーMT0117:64ビットアプリのみをサポートするシミュレーターで32ビットアプリを起動できません(iPhone 6s)

Xamarin.Forms、PC上のVisual Studio 2017、およびiOS向けモバイルアプリケーションを構築するためのMacBook Airの使用。

昨日、VSバージョンを15.3.5に更新し、iOSの最新バージョン(11.0)を取得するためにMacBook Airも更新しました(11.0)更新をテストするためだけに新しいアプリ(Xamarin.Forms)を作成し、すべてが期待どおりに機能しました。

以前のアプリを開発しようとしていた古いアプリを実行しようとしましたが、Macで実行できませんでした。次のエラーが表示されました。

起動に失敗しました。アプリ「AppName.iOS」を「iPhone 6s iOS 11.0」で起動できませんでした。エラー:エラーMT0117:64ビットアプリ(iPhone 6s)のみをサポートするシミュレーターで32ビットアプリを起動できません。 。詳細については、ログを確認してください。アプリは終了しました。

次に、デバイス(iPhone)をMacに接続し、アプリケーションをデバイスで実行しようとしました。アプリケーションを実行できましたが、デバイスのiOSを更新するとすぐにアプリケーションの実行が停止することを通知するメッセージが表示されました(デバイスのiOSを更新しませんでした)。

だから、問題はどのように問題を解決するのですか?これは私のアプリケーション、または私が使用しているパッケージと関係がありますか?設定する必要がある設定はありますか? Macで古いシミュレータを実行することは可能ですか?

ありがとう

18
Dimitris

サポートアーキテクチャを「i386 + x86_64」または「x86_64」に変更すると、問題が解決するはずです。

プロジェクトを右クリック->プロパティ-> iOSビルド->「サポートされるアーキテクチャ」を「i386 + x86_64」または「x86_64」に変更

53
Alirio Mendes

Xcode 9を使用すると、iOS 8.1までシミュレータをインストールできます。少なくとも、Xcodeの設定で[コンポーネント]タブに表示されていることです。

私の会社には、サポートされているすべてのiOSバージョンを備えたテストデバイスがいくつかあり、シミュレータでのテストよりも実際のハードウェアでのテストを信頼しているため、シミュレータを定期的に使用しません。

0
Gunter Hager