webdevqa.jp.net

印刷:エントリ ":CFBundleIdentifier"が存在しません

react-native run-iosを実行するとビルドは成功しますが、以下のエラーが発生します。私はあちこちをチェックしたが、何も働いていないようだ。コマンドの前にSudoを使用しても役に立ちません。 Xcode 7.3を使用しています、react-native-cli:0.2.0、react-native:0.24.1、ノードv5.11.0。

=== BUILD TARGET mobileTests OF PROJECT mobile WITH CONFIGURATION Release ===

Check dependencies

** BUILD SUCCEEDED **

Installing build/Build/Products/Debug-iphonesimulator/mobile.app
An error was encountered processing the command (domain=NSPOSIXErrorDomain, code=2):
Failed to install the requested application
An application bundle was not found at the provided path.
Provide a valid path to the desired application bundle.
Print: Entry, ":CFBundleIdentifier", Does Not Exist
/Users/astiefel/workspace/bosspayments/mobile/node_modules/promise/lib/done.js:10
      throw err;
      ^

Error: Command failed: /usr/libexec/PlistBuddy -c Print:CFBundleIdentifier build/Build/Products/Debug-iphonesimulator/mobile.app/Info.plist
Print: Entry, ":CFBundleIdentifier", Does Not Exist

    at checkExecSyncError (child_process.js:470:13)
    at Object.execFileSync (child_process.js:490:13)
    at _runIOS (runIOS.js:91:34)
    at runIOS.js:24:5
    at tryCallTwo (/Users/astiefel/workspace/bosspayments/mobile/node_modules/promise/lib/core.js:45:5)
    at doResolve (/Users/astiefel/workspace/bosspayments/mobile/node_modules/promise/lib/core.js:200:13)
    at new Promise (/Users/astiefel/workspace/bosspayments/mobile/node_modules/promise/lib/core.js:66:3)
    at Array.runIOS (runIOS.js:23:10)
    at Object.run (/Users/astiefel/workspace/bosspayments/mobile/node_modules/react-native/local-cli/cli.js:86:13)
    at Object.<anonymous> (/usr/local/lib/node_modules/react-native-cli/index.js:88:7)
106
astiefel

私の問題は、私のビルドがデバッグモードではなくリリースモードになっていたことです。その結果、識別子は存在しないものを指していました。私はビルドの種類を変更しましたが、それはうまくいきました。

10
astiefel

Xcodeでプロジェクトを開く

Xcode> 9ならコマンドreact-native upgradeを実行してください(これはあなたのすべてのiOS設定を上書きします、注意して使う!)

それから

1.ファイルに移動 - >プロジェクト設定

2.詳細設定ボタンをクリック

3. [カスタム]を選択し、プルダウンメニューから[ワークスペースに相対]を選択します。

4.「ビルド/製品」を「ビルド/ビルド/製品」に変更します。

Add package

5.クリック完了、完了

101
Katta Nagarjuna

config.hファイルがない場合、これが発生することがあります。

config.hファイルを更新するには、

1)Xcodeを閉じます。

2)ターミナルを開き、あなたのプロジェクトのルートフォルダに行ってください:

cd node_modules/react-native/third-party/glog-{X}.{X}.{X}/

3)configureスクリプトを実行します。

./configure

4)Xcodeを開き、アプリを実行してみます。

{X}:バージョン番号glog

65
Lijith Vipin

react-native upgradeを使ってReactをアップデートしてください。

免責事項:これはあなたのすべてのiOS設定を上書きします、慎重に使用してください

30
sbastidasr

Xcode 10を使用している場合は、Xcodeの最新のビルドシステムとの互換性がないことが原因である可能性があります。従来のビルドシステムに切り替えてみてください。

Xcode 10を開き、[ファイル]> [プロジェクト設定]> [ビルドシステム]>ドロップダウンを[レガシビルドシステム]に切り替えます。

Screenshot

22
ChrisBorg

私もこの問題に遭遇し、私はそれを修正する方法を見つけました

これが私がしたことです:

1)ファイルディレクトリに空白がないことを確認してください。

2)cdプロジェクトディレクトリ

3)コマンドを実行する反応ネイティブアップグレード

4)ネイティブのiosフォルダに移動してxcodeプロジェクトを開きます。

5)[ファイル]> [プロジェクト設定]> [詳細設定]に移動します。

6)カスタム>ワークスペースに相対的を選択

7)製品パスは 'build/build/Products'であるべきです

8)中間物パスは 'build/Build/Intermediates'であるべきです

9)端末でコマンドを実行してみてくださいreact-native run-ios

私はこの解決がこの問題に直面している私達の何人かを助けることを願っています。

10
Usman Awan

[email protected]のために、以下は私のためにトリックをやった:

1)パスを確認し、.xcodeproj(.xcworkspaceではなく)ファイルを開いて、

  • ファイル>プロジェクト設定>詳細設定に移動します。

  • カスタム>ワークスペースに相対

  • 商品のパスを'build/Build/Products'に設定します
  • 中間パスを'build/Build/Intermediates'に設定します
  • 完了を押して変更を保存します

2)プロジェクトのルートディレクトリでrm -rf ios/buildを実行してください。

3)担当パッケージを閉じる

4)react-native run-iosをもう一度実行する

9
Tim

新しいパッケージをインストールした後にnode_modulesフォルダが壊れたときに、このようなことが起こりました。私はフォルダrm -rf node_modulesを殺して、それから私のパッケージを再インストールするためにnpm installをしました、そしてそれはそれを修正しました。

8
Jade

Print: Entry, ":CFBundleIdentifier", Does Not Existメッセージは、プロジェクトがコンパイルまたはリンクに失敗したことを示しているだけです。実際の根本的な原因についてのヒントを見つけるためにあなたの出力を遡る必要があるでしょう。

問題がある場合は、最後の数行だけではなく、フルビルド出力を見てください。 Xcodeでプロジェクトを開き、⌘Bを押してプロジェクトをビルドします。 Xcodeのビルドエラーは、失敗の根本的な原因を見つけるのに役立ちます。

7
Héctor Ramos

このエラーを受け取った場合は、おそらくアプリケーションの正しいパスがありません。

コマンドの処理中にエラーが発生しました(domain = NSPOSIXErrorDomain、code = 2):要求されたアプリケーションのインストールに失敗しました指定されたパスにアプリケーションバンドルが見つかりませんでした。目的のアプリケーションバンドルへの有効なパスを指定してください。印刷:エントリ ":CFBundleIdentifier"が存在しません

React Nativeは、runIOS.jsのrun-iosコマンドの一部としてそれをハードコードしました。

build/Build/Products/${configuration}-${isDevice ? 'iphoneos' : 'iphonesimulator'}/${appName}.app

残念ながら、Xcodeはあなたの設定やXcodeプロジェクトとWorkspaceのどちらを使っているかによってビルドパスが異なります。 Xcodeプロジェクトのデフォルトパスはbuild/Productsだと思います。
私はこのプル要求 11899 を送信して、プログラマーにCLIからの柔軟性を高めました。

6
Charlle

私にとっては、偶然にCocoapodsとreact-native linkを使ってモジュールを誤って設定することが問題でした。

同じモジュールに対してこれら2つを混在させないでください。

3
Oleg

/build/を削除してreact-native run-iosを再度実行することでこれを修正しました

3
user3196599

私の場合は、gitからプロジェクトを取り出し、それにはiosフォルダーも含まれます。

まず私はiosフォルダを削除しますrm -rf ios、そしてreact-native upgrade

このエラーを解決するには、以下の手順に従ってください。

ステップ1

Open terminal

ステップ2

cd node_modules/react-native/third-party

ステップ3

ls

Copy or identify glog-{version}

ステップ4

cd ../../../

ステップ5

cd node_modules/react-native/third-party/glog-{version}

ステップ6

./configure

これがうまくいくことを願っています!!!

2
Dheeraj D

バンドル識別子を宣言したことを確認しましたか?これを行うには、xcodeでプロジェクトファイルをクリックしてから[一般]タブを選択します。これが[ID]の下の最初のテキストボックスに表示されます。確認するもう1つの方法は、プロジェクトのiosフォルダにあるinfo.plistファイルをチェックインすることです。これが私のinfo.plistに表示される方法です。私のプロジェクトのための私の実際のバンドル識別子はxcodeです。

<key>CFBundleIdentifier</key>
<string>$(PRODUCT_BUNDLE_IDENTIFIER)</string>
2
Ben Dellarocco

私はこれらすべての解決策を試してみましたが、私のために働いてきたものは以下のとおりです。

  1. react-native upgradeを実行
  2. xcodeを開く
  3. xCodeでアプリケーションを実行する
  4. 正常に動作します!
2
Eli

数ヵ月後にすべての答えを試した後、私はついに自分のOSをSierraにアップデートし、XCodeを最新バージョンにアップデートすると、すべてのエラーが消えます。これが何人かの人々に役立つことを願っています!

1
damianfabian

Xcodeで使用していないシミュレータをいくつか削除したため、私の端末で同じメッセージが表示されます。

特定のパラメータを指定せずにreact-native run-iosを実行すると、react-nativeはデフォルトのシミュレータであるiOS 10.3.1を搭載したiPhone 6を実行します。このシミュレータは偶然に削除しました。

これが私のエラーメッセージです。

xcodebuild: error: Unable to find a destination matching the provided destination specifier:
        { id:F3A7BF54-B827-4517-A30D-8B3241C8EBF8 }

Available destinations for the "albums" scheme:
    { platform:iOS Simulator, id:CD64F26B-045A-4E27-B05A-5255924095FB, OS:10.3.1, name:iPad Pro (9.7 inch) }
    { platform:iOS Simulator, id:8FC41950-9E60-4264-B8B6-20E62FAB3BD0, OS:10.3.1, name:iPad Pro (10.5-inch) }
    { platform:iOS Simulator, id:991C8B5F-49E2-4BB7-BBB6-2F5D1776F8D2, OS:10.3.1, name:iPad Pro (12.9 inch) }
    { platform:iOS Simulator, id:B9A80D04-E43F-43E3-9CA5-21137F7C673D, OS:10.3.1, name:iPhone 7 }
    { platform:iOS Simulator, id:58F6514E-185B-4B12-9336-B8A1D4E901F8, OS:10.3.1, name:iPhone 7 Plus }

。 。 。

Installing build/Build/Products/Debug-iphonesimulator/myapp.app
An error was encountered processing the command (domain=NSPOSIXErrorDomain, code=2):
Failed to install the requested application
An application bundle was not found at the provided path.
Provide a valid path to the desired application bundle.
Print: Entry, ":CFBundleIdentifier", Does Not Exist

Command failed: /usr/libexec/PlistBuddy -c Print:CFBundleIdentifier build/Build/Products/Debug-iphonesimulator/myapp.app/Info.plist
Print: Entry, ":CFBundleIdentifier", Does Not Exist

これらを取り除くには、あなたのXcodeを開いて利用可能なシミュレータをチェックして(リストされている端末と同じ)、react-native run-ios --simulator="your device name"を実行してください。

私の場合は、react-native run-ios --simulator="iPhone 7"を実行して問題を解決しました。

1
Frank Wang

追加、それは私のために働く、上記の何も修正しないとき:

  1. React-native-git-upgradeをインストールしてプロジェクトを更新します。 npm i -g react-native-git-upgrade && react-native-git-upgrade
  2. Xcode - >ファイル - >プロジェクト設定 - >詳細設定を開きます。
  3. カスタム」を選択し、次に「ワークスペースに相対する」を選択してから完了、クリック.
  4. CLIを更新してください。 npm i -g react-native-cli
  5. Nodejs 8とNPMを更新してください。 nvm install --ltsnvm install-latest-npm
  6. プロジェクトのルートパスにあるios/buildとnode_modulesを削除します。
  7. npm installreact-native run-iosでもう一度進み、抱きしめてください:-)

それはついにここで動作します。

  • Mac OS High Sierra 10.13.4
  • Xcode 9.3
  • NPM 5.8.0
  • ノード8.11.1
  • RN 0.55.2
1

0.44は実行しても問題ありませんが、0.45では実行できません。バージョンの問題は次のコマンドで解決した可能性があります。

1
Joshua

Xcodeをv8にアップデートしましたが、エラーは解決しました。

1
Mech Minds

私にとっては、それはcocoapodsによって管理されているios依存関係でした。

これをしなければならなかった:

$ cd ToProject/ios

$ pod install

$ react-native run-ios

これは私のために働きました

https://shift.infinite.red/beginner-s-guide-to-using-cocoapods-with-react-native-46cb4d372995

シモンズ:誰か他の人によって行われた仕事を把握しようとしていました

1
user710907

このバージョンを使用することはxcode 10.1で私のために働きます

"react": "16.6.0-alpha.8af6728",
"react-native": "0.57.4"

npm installコマンドを実行するとインターネットの問題が発生する場合があります。node_modules\react-native\third-party内のファイルは正しくダウンロードされていません。

それからreact-native run-iosコマンドを実行します

0
Nisarg Thakkar

この作業はあなたのナビゲーターでRCTWebSocketプロジェクトをクリックしてbuild settings> custom compiler flags の下のフラグを削除してください。enter image description here

0
Jackson Harry

現在のエラーの前に発生した以前のエラーメッセージ、つまり"CFBundleIdentifier”, Does Not Existを調べてみてください。

前のエラーを修正すると、このエラーは消えます。

react-native run-ios --simulator="iPad Pro (9.7-inch)を実行したときの以前のduplicate symbols for architectureエラーを修正すると、問題はなくなりました。

0
base64k

私は問題を解決する方法を見つけました:あなたのプロジェクトパスでスペースを使わないでください! ???? ????

0
Floris M

基本的な理由はportのデプロイが自由ではないということです。デバイスを再起動して他のすべてのポートを解放するには$ lsof -i :8081を実行し、ポート8081を占有しているプロセスを見つけます。$ kill -9 {process_which_is_running_under_8081}を実行してポート8081を使用しているプロセスを強制終了します。

0
Gururaj Jeerge

まずXcodeからプロジェクトを実行してから、コマンドラインから実行してみます。それが私の問題でした。

0

これは私のために働きました。手順 https://facebook.github.io/react-native/docs/getting-started.html (ネイティブコードを使用したプロジェクトの構築)に従ってください。

react-native run-iosコマンドを実行する前に、 https://sourceforge.net/projects/boost/files/からブーストノードモジュールをダウンロードしてください。 boost/1.63.0 / そしてnode_modules/react-native/third-party/boost_1_63_0を置き換えてください。

では、react-native run-iosコマンドを実行してください。

0
PDM

react-native run-ios --scheme="customscheme"を実行したときにcustomschemeの名前のスペルが間違っていると、このエラーが発生しました。

0
basbase

The domain/default pair of (../ios/Runner/Info, CFBundleIdentifier) does not existに類似したエラーメッセージ

Xcodeはあなたがplist持っている_invalid format contentと思うことを意味します。

Info.plistファイルの内容を貼り付けて、そのファイルの何が問題なのかを見つける必要があります。

考えられる問題の1つは、この<key>sと<values>s(<array>s、<string>s、または<bool>s)がペアになっていないことです。例えば:

<key>UISupportedInterfaceOrientations</key>         //<------ here is the key
<key>NSPhotoLibraryUsageDescription</key>
<key>NSCameraUsageDescription</key>
<string>Tagueo necesita usar la camara</string>
<key>NSMicrophoneUsageDescription</key>
<string>Tagueo necesita usar el microfono</string>
<array>                                            //<------ here is the value
    <string>UIInterfaceOrientationPortrait</string>
    <string>UIInterfaceOrientationLandscapeLeft</string>
    <string>UIInterfaceOrientationLandscapeRight</string>
</array>
<key>UISupportedInterfaceOrientations~ipad</key>   //<------ please compare this key
<array>                                            //<------ please compare this value
    <string>UIInterfaceOrientationPortrait</string>
    <string>UIInterfaceOrientationPortraitUpsideDown</string>
    <string>UIInterfaceOrientationLandscapeLeft</string>
    <string>UIInterfaceOrientationLandscapeRight</string>
</array>

keyvalueを一緒に移動するだけです

<key>UISupportedInterfaceOrientations</key>        //<------ here is the key
<array>                                            //<------ follow with the value
   <string>UIInterfaceOrientationPortrait</string>
   <string>UIInterfaceOrientationLandscapeLeft</string>
   <string>UIInterfaceOrientationLandscapeRight</string>
</array>
0
JerryZhou

Xcodeアプリでプロジェクトを開くだけで、自動的にすべてのインポートを実行して問題を解決します。私のために働いた、Xcode 10+

編集1:グローバルフォルダではなく、アプリのiOSフォルダを開きます。

0
Rishav Kumar

私はXCode 10でRNバージョン0.5.7を使用しています、私はほとんどすべての解決策を試しましたが、何もうまくいきませんでした。

多くの時間を浪費した後、ついに私は次のようにすることによって仕事にそれを得た方法

  1. react-native init project --version [email protected]を実行して、以前のバージョンのreact-nativeをインストールします。
  2. project/ios/project.xcodeprojを開き、コマンドラインビルド用にDebugを選択します
  3. 正しい開発用証明書を必ず選択してください
  4. もう一度react-native run-iosを実行してください。今度はうまくいくはずです。
0

これらすべての解決策は私にはうまくいかなかったことを示唆しています。 rn 0.58.5プロジェクトを作成しました。そして私のプロジェクトと比較しました。 JavaScriptCore.framework> Build Phasessの下にLink Binary With Librariesがないのがわかりました。ドラッグアンドドロップしてJavaScriptCore react-native run-iosのビルドに成功しました。

JavaScriptCore.frameworkの場所:‎⁨Macintosh HD⁩ ▸ ⁨Applications⁩ ▸ ⁨Xcode⁩ ▸ ⁨Contents⁩ ▸ ⁨Developer⁩ ▸ ⁨Platforms⁩ ▸ ⁨iPhoneOS.platform⁩ ▸ ⁨Developer⁩ ▸ ⁨SDKs⁩ ▸ ⁨iPhoneOS.sdk⁩ ▸ ⁨System⁩ ▸ ⁨Library⁩ ▸ ⁨Frameworks⁩

JavaScriptCore.framework

0
agenc