webdevqa.jp.net

無効なアーキテクチャXcode 10

Xcode 10をアップグレードしてアプリを送信しました。アーキテクチャ設定を変更していないというメールが届きました。有効なアーキテクチャはarmv7およびarm64です。

App Store Connect

親愛なる開発者、

アプリ「#####!」の最近の配信で1つ以上の問題が見つかりました。次の問題を修正してから、もう一度アップロードしてください。

無効なアーキテクチャ-このアプリには無効なアーキテクチャがあり、無効なビルド設定または互換性のないツールでビルドされた可能性があります。最新のXcodeバージョンでアプリを再構築してみてください。サードパーティの開発ツールを使用している場合は、プロバイダーにお問い合わせください。

宜しくお願いします、

App Storeチーム

6
Labs Panda

Xcode 10は8.0より前のデプロイメントターゲットをサポートしていません。デプロイメントターゲットを更新する必要があります。または、より低いターゲットが必要な場合は、Xcode 9.4.1を再インストールできます。

4
picciano

このリンクのセクション「非推奨の通知非推奨」を確認してください。

https://developer.Apple.com/documentation/xcode_release_notes/xcode_10_release_notes
xcode 10の場合:macOS 10.9以降、またはiOS 7以降の展開ターゲットを設定することをお勧めします。

Deployment Targetを7.0に変更するだけでこの問題は修正されます。 (テストと合格)

そして...もっと情報があります。
アップルから「無効なアーキテクチャ」を取得する前。 xcodeを10に更新すると、コンパイルエラーが発生しました

libstdc ++。6が見つかりません。
(私の導入ターゲットは6.0です)

これを修正しました。古い(xcode 9)libstdc ++ファイルをgithubの担当者からダウンロードしました。 Appleリリースノートでもこのエラーについて説明できます。

したがって、iOS 6.0用にビルドする場合は、xcode 9の使用をお勧めします。
さもないと
xcode 10とDeployment target 7.0以降を使用してください。

0
dravensx