webdevqa.jp.net

iTunesStoreへのアップロード中にエラーが発生しました

私たちは本当にこれについていくつかの助けが必要です:

過去2か月間、すべてのApple Mumbo-Jumboに苦労しており、APPStoreでAPPを入手できないようです...

今のところ私の問題は、ARCHIVEコンパイルを検証して共有した後です..私が取得した送信プロセスで-

「iTunesStoreへのアップロード中にエラーが発生しました」

私は本当に自分が間違っていることを知りませんし、問題を解決するものをインターネット上で見つけられないようです...

私はこれに1週間以上苦労しています...私は試しました:

  • コード署名用の新しい配布プロファイルの作成。

  • すべてのターゲット設定を何度も確認します。

  • FTPモードをパッシブから非パッシブに変更する

  • 異なるネットワークから接続する

  • Xcode4の再インストール

  • アプリケーションローダーのダウンロードなど、その他の回避策(まだインストールされていませんが、必要かどうかわかりません)

私たちを助けてください、あなたは何が問題になると思いますか?

ありがとう

ヘルナン

30
Hernan Arber

アプリをAppleにアップロードできず、JavaOSXアップデート(2012年4月3日)をインストールした場合、アプリをアップロードする機能を取り戻すのに役立つ場合があります。

古いJava 1.5シンボリックリンクを再作成することで、この問題を回避できます。

cd /System/Library/Frameworks/JavaVM.framework/Versions
Sudo ln -s CurrentJDK /System/Library/Frameworks/JavaVM.framework/Versions/1.5
Sudo ln -s CurrentJDK /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0

2012年10月5日編集OracleのJava 7

以下のハックモンフォードのコメントについて詳しく説明します。

この正確なエラーメッセージは、OracleのJava SE 71.7.0_10パッケージがインストールされている場合にも発生します。解決するには、「Java設定」を開き、AppleのJava SE 6を最初に使用するように順序を変更するか、アプリストアに送信するときにOracleのJava 7のチェックを外します。ターミナルを開いて変更を確認します。

prince$ Java -version
Java version "1.6.0_35"
103

今週この問題が発生し、OS X Lion2012-002アップデート用にJavaをインストールしたところ、問題は解決しました。ディスクのアクセス許可をリセットしても効果はありませんでした。

16
jbcaveman

JavaVM/JREの問題もありました。 OracleからJDK7プレビューをインストールしましたが、「iTunesStoreへのアップロード中にエラーが発生しました」という既知のアップロードプロセスが混同されました。

/var/log/system.logを簡単にチェックすると(たとえば、端末でテールを使用する:tail -n 100 /var/log/system.log)、次のエラーメッセージが表示されました。

Java 1.5、1.6、または1.7が必要です。現在、JavaがデフォルトのJavaバージョンです。アップグレードしてください。

Oracleから直接JDK7のMacOSプレビューをインストールしました。この問題を修正するには、ユーティリティでJava設定アプリを起動し、OracleのJDK 7のチェックを外します。もちろん、Appleの代替JREが必要です。スクリーンショットを参照してください。私の構成はどのように表示されますか。アップロード今私のために働いています。

奇妙なことに、OracleJDKはAppleによってJava 1.7として認識されません。これはバグのようです。

Screenshot of my settings (sorry in German only, but you should get the clue)

UPDATE:GUIツールはMacOSから削除されました。今、私が知っている唯一の解決策は、JDK1.7フォルダーを手動で削除することです。 JDK 7 docs これを行う方法を参照してください。

/ Library/Java/JavaVirtualMachinesに移動し、名前が次の形式に一致するディレクトリを削除します。

/Library/Java/JavaVirtualMachines/jdk<major>.<minor>.<macro[_update]>.jdk

たとえば、7u6をアンインストールするには:

% rm -rf jdk1.7.0_06.jdk

15
spa

これはまた起こった。
OSX 10.8.2ユーザー(Javaプリファレンスがない)の場合、これを修正する唯一の方法は、Oraclejdkをアンインストールすることです。

cd /Library/Java/JavaVirtualMachines
Sudo rm -rf jdk1.7.0_09.jdk/
15
Marku

少し遅れて、私は知っています-しかし、まだこの問題を抱えている人のために-あなたの/var/log/system.logログファイルを見てください。私の場合、問題は、iTMSTransporterスクリプト(オーガナイザーがファイルのアップロード時に使用)が「awk」を使用していたことであり、「/ usr/bin/awk」に置き換える必要がありました。

私の問題を完全に解決しました。

Y。

3
user92301

最新のXCodeをインストールした後、今日この問題が発生しました。

ソフトウェアアップデートを実行し、最新のJavaアップデートをインストールすることで修正しました。

2
Clayton Bell

これが他の人に役立つ場合に備えて、私にとってはJava JREが最新ではなかったということでした。コンソールを確認したところ、アプリケーションローダーが文句を言っていました。

2
Joe

4月1日にAppStoreに送信しても問題ありません。 4月9日に問題が発生しました。 Mac-OSソフトウェアアップデータを介してOSX Lion2012-002アップデートのJava)をインストールし、マシンを再起動すると修正されました。

0
Horst

この問題を解決する手順は次のとおりです。

まず、OracleをインストールしましたJava 1.7 JDK、これは本当に混乱していました。

Finder>アプリケーションに移動し、検索ボックスに入力しました-JavaAppletPlugin.plugin

右クリックしてゴミ箱に移動しました。

ターミナルでJavaバージョンをチェックすると、まだJava 1.7

my-iMac:〜my $ Java -version

Javaバージョン「1.7.0_07」

Java(TM)SEランタイム環境(ビルド1.7.0_07-b10)

Java HotSpot(TM)64ビットサーバーVM(ビルド23.3-b01、混合モード)

1. Finder> Library> Java> JavaVirtualMachinesは1.7SDKを示しました(ディレクトリ名の正確な名前をメモしてください)

何か問題が発生した場合に備えて、次の項目を実行する前に、1.7SDKフォルダーをデスクトップにコピーしました。

2.ターミナルタイプ

cd/Library/Java/JavaVirtualMachines

3.これでそのディレクトリにいるはずです

Sudo rm -rf jdk1.7.0_06.jdk(または、ステップ1のディレクトリの正確な名前)

管理者パスワードの入力が必要になる場合があります

これでディレクトリが削除され、ターミナルで確認できます。

Javaバージョン

鉱山は「Java1.6_xxx」を表示しました

Xcode Organizerにアクセスし、問題なくアプリをiTunesストアに配布しました。おっと、おっ!

0
loganathan

私のmbpはLionでXcode4.2(4D199)を実行し、Lion用に最新のJavaをインストールしました。そして、ついにこの問題を解決しました。

多くの人が、彼は古いアプリケーションローダーアプリを使用してアプリをアップロードできると言いました。だから私は問題が最新のアプリケーションローダーアプリ(2.4.1(190))であると思います、そして事実は私が正しいと私に言いました

Okie、一言で言えば:これが解決策です:

1.古いXcode(4.1)を削除しないでください。古いバージョンのアプリケーションローダーアプリを選択する必要があります。

cd <Install Xcode app>/Contents/Resources/Packages
cp ApplicationLoader.pkg ~/Desktop/

これで、ApplicationLoaderパッケージを入手できます。

2.古いものをインストールします。ヒント:パス内の最新のアプリケーションローダーアプリを削除できます:/Developer/Applications/Utilities/または単にそれを残します。

それで全部です。

この方法があなたを助け、新しいXcode4.2を楽しむことができることを願っています。また、Apple開発者がこの問題を確認し、最新のApplicationLoaderアプリをさらにテストできることを願っています。

0
Wayne

Hernanと同じことを試しましたが、アプリケーションローダー1.3でもアップロードできませんでした。

OSx LionをインストールしてXCodeを4.1にアップグレードした後、これが発生したことに気づきました。

Joeのヒントに従って、Javaがインストールされていないことがわかりました。

このブログエントリに従ってください:

アプリをApp Storeにアップロードできません

0
Khattab

Macソフトウェアアップデートで最新のJavaに更新するだけです。

0
ixiel