webdevqa.jp.net

LionのXcode4.1に古いiOSSDKを追加する

LionとXcode4.1をインストールしました。 iPhone/iPad Simulatorの4.1または4.2でビルドして実行できるように、古いSDKを追加するにはどうすればよいですか? Xcode 4.1には、iOS 4.3SDKのみが付属しています。

Lionにはビルド用の最小限のSDKがありますか?

ありがとう、

20
Rafeed C.

実際には、古いSDKで古いバージョンのXcodeを入手できる限り、古いSDKを追加することは可能です。これは時々役に立ちます。これを行うと、実行時ではなくコンパイル中に使用している可能性のあるサポートされていない定数とメソッドについて知ることができます。これがその方法です。

  1. 古いSDKで古いバージョンのXcodeを入手してください。 Apple iOS Dev Centerは現在、Xcode3.2.6ダウンロードを含む4.3SDKをリストしています。

  2. Dmgをマウントし、ターミナルを介してdmg内に隠されているPackagesフォルダーを開きます。

    / Volumes/Xcode \および\ iOS\SDK/Packages /を開きます

  3. 必要なSDKバージョンのpkgファイルをダブルクリックします。 iPhoneSDK4_3.pkgを探していましたが、4.3に加えて、iPhoneSDK3_0.pkgと同じくらい古いパッケージが見つかりました。したがって、古いSDKは、どこにあるかがわかっている場合は、App Storeのダウンロードにパッケージ化されている可能性があります(私は知りませんでした)。

  4. Applications/Xcode.app/Contents/Developer(現在のDeveloperフォルダーがある場所)に強制的にインストールすることはできないため、選択した独自のフォルダーにインストールします。

  5. 選択したボリュームのPlatformsフォルダーにインストールされているパッケージがあります。関連するSDKをXcode.app内のDeveloperフォルダーに移動します。おそらくSudoを使用する必要があります。

    Sudo mv /Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS4.3.sdk /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/

  6. Xcodeを再起動すると、Base SDKのオプションに新しい(古い)SDKが表示されます。わーい!

2013年9月12日現在の更新

追加しようとしている「古いSDK」がXcode4.3以降にバンドルされている場合、SDKの追加は、「古いバージョンのXcodeをお探しですか?」という開発センターのリンクからXcodeをダウンロードするだけです。 (現在は ここ を指しています)、dmgをマウントしてから、関連するファイルをコピーします。

ターミナルでは、次のようにします(適切なSDKバージョン番号を編集します)。

cp -R /Volumes/Xcode/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS6.1.sdk /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/

4.3より前のバージョンのXcodeのSDKの場合、古い手順が引き続き関連します。

これは、Xcode 5 GMを取得して、iOS7デバイスにデプロイされている場合でも古いiOS6UIを保持するビルドをコンパイルするために機能することがわかりました。UIの再設計が保留されているバグを修正するのに役立ちます。 、iOS7デバイスでiOS6UIを取得する簡単な方法が必要です。

27
nioq

できません。ただし、できることは、ファイルナビゲータの最上位のエントリをクリックすることです。アプリケーションの設定に移動します。 [ビルド設定]というタブに移動し、iOS展開ターゲットをサポートするiOSのバージョン(サポートする最も古いバージョン)に変更します。

「ビルド設定を編集するには…」を参照してください。 http://developer.Apple.com/library/ios/documentation/ToolsLanguages/Conceptual/Xcode4UserGuide/Building/Building.html#//Apple_ref/doc/uid/ TP40010215-CH9-SW5

8
FeifanZ

Xcodeを開き、[設定]を開きます([Xcode]-> [設定]メニュー)。ダウンロードアイコンをクリックして、[コンポーネント]タブを確認します。 3.0から5.1までのすべてのバージョンが利用可能である必要があります。使用したいものの[インストール]をクリックするだけです。

8
2cupsOfTech

これらの答えはどれも、Mac OS10.8とXCode4.5ではうまくいきませんでした。しかし、Applicationsフォルダーの下にインストールされるようになったため、管理がはるかに簡単になりました。

オプション#1:XCodeの古いコピーを保持するには、新しいコピーをインストールする前に名前を変更することで簡単に行えます。次に、[製品]-> [プリフォームアクション]-> [ビルドなしで実行]を新しいバージョンで使用して、新しいデバイスまたは新しいシミュレーターでテストできます。

オプション#2:新しいXCodeで古いSDKを使用してビルドしたい場合は、Finderを使用してSDKをコピーするだけです。これを機能させるには、アプリケーションの下に古いバージョンのXCodeをインストールする必要があります。次の例では、XCode 4.5をインストールする前に、XCode4.4の名前をXCode_oldに変更しました。注:.appファイルを右クリックし、[コンテンツの表示]を選択してこれらのファイルにアクセスするか、ターミナルウィンドウからcpを使用することができます。

from: /Applications/Xcode_old.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.1.sdk
to:   /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/

次に、iOS5.1が[ビルド設定]にBaskSDKとして表示されます。シミュレーターでも同じことができます。

from: /Applications/Xcode_old.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.1.sdk
to:   /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/
6
Brainware

それはできませんが、古いバージョンのiOS(適切なテストを実行する必要があるもの)を実行しているプラ​​グインされたデバイスでは正常にビルドされます。

1
jrtc27

古いiOSバージョンと組み合わせて提供された古いバージョンのXcodeでアプリケーションを実行する必要があります。 /Developer-3.2.5/の下に3.2.5をインストールしました。 Xcode 4よりも約10倍高速だと言わざるを得ません...古いバージョンはここからダウンロードできます: http://iphonesdkdev.blogspot.com/2010/04/old-versions-of-iphone-sdk。 html

1
Aram Kocharyan

Stevenの回答に加えて、古いバージョンのXCode(古いSDKを含む)を見つけることができます。

古いバージョンのXcodeをお探しですか?

0
Pega88

SDK4.3を使用したSnowLeopardのXcode4.02でも同様の問題が発生しました。 iPhone 3Gでテストしたかったのですが、iOS4.2がそのデバイスの最新(そして正しいバージョン)です。スキーム内のそのデバイスで「表示」して実行するには、上記のようにiOSデプロイメントターゲットのビルド設定を変更する必要がありました。 (ところで、Xcodeにアプリをインストールさせるには、iPhoneの制限をオフにする必要もあります:))

0
user899007